Feed geht nicht richtig

Dieses Thema im Forum "Konfiguration" wurde erstellt von Downkiller, 5. Oktober 2007.

  1. Downkiller

    Downkiller Active Member

    Registriert seit:
    6. Dezember 2005
    Beiträge:
    30
    Zustimmungen:
    0
    Hallo Leute ,

    hoffe bin in der richtigen Abteilung gelandet.

    Habe folgendes Problem mit meinem Feed :

    IE7 Fehlermeldung
    Firefox ... geht nicht
    Feedreader 3.10 funktioniert
    GoogleReader funktioniert

    Weiss leider keinen Rat wo das Problem liegt ??!!
    Vielleicht kann mir jemand helfen ?

    FEEDVALIDATOR sagt :

    This feed does not validate.
    • line 1, column 1: XML parsing error: <unknown>:1:1: xml declaration not at start of external entity [help]
      <?xml version="1.0" encoding="UTF-8"?>
      ^​
    Source: ACKERGOLF.de


    Vielen Dank im Vorraus
    Gruss M
     
  2. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.822
    Zustimmungen:
    0
    Klick doch mal auf das [help], da wird doch schön erklärt, was mögliche Fehlerursachen sein könnten. Besonders der letzt Absatz bei "Solution" ist dort interessant.

    Gruß
    Ingo
     
  3. Downkiller

    Downkiller Active Member

    Registriert seit:
    6. Dezember 2005
    Beiträge:
    30
    Zustimmungen:
    0
    Ähhm .... ja ...
    und was soll mir das sagen ?
    Sorry bin nicht der Profi in solchen Sachen ... Wo muss ich was ändern / nachschauen ?
     
  4. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.822
    Zustimmungen:
    0
    Direkt am Anfang vor dem <?xml ... steht ein Leerzeichen. Das darf nicht sein, XML ist da ziemlich penibel.

    Da ich davon ausgehe, daß Du nicht direkt in den Wordpress-Dateien rumeditiert hast, dürfte irgendein Plugin dafür verantwortlich sein. Welches, kann ich allerdings nicht sagen.

    Gruß
    Ingo
     
  5. Downkiller

    Downkiller Active Member

    Registriert seit:
    6. Dezember 2005
    Beiträge:
    30
    Zustimmungen:
    0
    Zur Sicherheit hier mal der Code aus der wp-rss2.php :

    PHP:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
     
  6. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.822
    Zustimmungen:
    0
    Ja das ist schon so richtig, dort steht kein Leerzeichen davor. Deshalb meine Hinweis auf die Plugins. Denn bevor die wp-rss2.php überhaupt zum Zuge kommt, wird ja das ganze WP mit allen Plugins uns sonstigen Sachen geladen. Und wenn da irgendwo ein Leerzeichen ausgegeben wird, kommt es zum Fehler.

    Nachtrag: Es kann auch an der wp-config.php liegen, falls dort ein Leerzeichen außerhalb von <?php ... ?> steht.

    Gruß
    Ingo
     
    #6 Putzlowitsch, 5. Oktober 2007
    Zuletzt bearbeitet: 5. Oktober 2007