1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Fehler 404

Dieses Thema im Forum "Installation" wurde erstellt von MrsMama, 14. Dezember 2019.

  1. MrsMama

    MrsMama New Member

    Registriert seit:
    14. Dezember 2019
    Beiträge:
    4
    Zustimmungen:
    0
    Hallo zusammen,
    ich bin absoluter WordPress-Neuling und versuche hartnäckig, die Materie zu verstehen. Es macht riesig viel Spaß, zahlreiche Probleme konnte ich mit viel Recherche auch selbst lösen. Nun komme ich aber nicht mehr weiter und hoffe auf Eure Hilfe ;o)

    Ich hatte meine Website bereits am Laufen und war sehr happy damit. Seit gestern kommt aber nur noch "Fehler 404", wenn ich auf die Website gehe. Ich kann mich auch über wp-admin nicht mehr anmelden!

    Nun habe ich in letzter Zeit zwei Dinge verändert (und das war nicht gerade schlau, da ich nun nicht weiß was den Fehler ausgelöst hat...):
    1. Ich habe meine Domain bei GMX. Ich hatte im Nachgang auch ein SSL-Zertifikat gekauft, welches ich am 12.12. aktiviert hatte. Seitdem geht nichts mehr. Allerdings müsste ich nun ja auch die Permalinks etc. anpassen - nur komme ich ja gar nicht mehr rein in meine Seite...
    2. Und da glaub ich habe ich Scheiße gebaut: Ich hatte mich ganz zu Beginn meines Website-Erstellens bei WordPress.org für einen Business-Account entschieden. Da ich aber nicht weiter gekommen bin habe ich mir zudem ein Buch zum Thema WordPress gekauft und mich dann entschieden, über FTP-Zugang mit WordPress.com meine Website aufzubauen. Das war für einen Laien wie mich zwar nicht ganz einfach, aber irgendwann hat es ja geklappt und ich bin sehr stolz auf meine Website. Nun dachte ich, dass ich den Business-Account für jährlich €90 gar nicht mehr brauche, da ich ja nicht die Templates von wordPress.org nutze sondern über FTP mit WordPress.com die Website aufgebaut habe. Ich habe also den Account am 7.12. gekündigt. Kann es daran liegen? Die Website lief aber auch in den Tagen danach noch weiter...

    Ich würde mich sehr freuen, wenn mir jemand helfen könnte und Licht ins Dunkel bringt.
     
  2. Marcus[IS]

    Marcus[IS] Well-Known Member

    Registriert seit:
    23. August 2009
    Beiträge:
    5.611
    Zustimmungen:
    93
    Hi,

    Ich glaube du wirfst da was durcheinander, aber das passiert jedem zu Anfang.

    wordpress.com bietet fertiges WordPress an. Also registrieren und direkt mit dem Blog loslegen.
    Ist ziemlich eingeschränkt und nur für Leute zu gebrauchen die keine Lust auf den ganzen technischen Schnickschnack haben.

    WordPress.org ist das unabhängige WordPress, wo jeder Nutzer sich einen eigenen Webspace bei Anbietern wie zum Beispiel 1&1, Host Europe, Webgo, Strato, etc. anmietet und per FTP das WordPress auf seinen Webspace hochlädt und dann selber installiert und einrichtet.

    Nur so als Ersterklärung. ;)

    Nun zu deinem Problem.

    Ist nicht so dramatisch, das kann man mit etwas Handarbeit wieder gerade rücken, indem man wie du schon treffend ermittelt hast die URLs wieder anpasst.

    Das ist denke ich nicht so der Fall.
    https://de.support.wordpress.com/ftp-zugriff/
    Gehe ich da recht in der Annahme, dass du erst versucht hast den Blog bei wordpress.com (Business Tarif) ans laufen zu bekommen und hast dich dann dafür entschieden lieber selber eine wordpress.org Variante bei GMX zu hosten und hast dort FTP Zugang?
    Soweit ich weiß, bieten die ja 2GB für eigene Webseiten an.

    Falls dem so ist, solltest du dir dies durchlesen.
    https://www.im-tal.net/wordpress/117758-falsche-wordpress-adresse-url-aendern/
    https://forum.wpde.org/threads/falsche-wordpress-adresse-url-eingegeben.145345/#post652266

    Ist zwar beides älter, aber die Vorgehensweise hat sich nicht geändert.
    Beachte allerdings das die http Angabe bei dir https lauten muss, da du ja ein Sicherheitszertifikat laufen hast.
     
  3. MrsMama

    MrsMama New Member

    Registriert seit:
    14. Dezember 2019
    Beiträge:
    4
    Zustimmungen:
    0
    Hi, vielen Dank für Deine schnelle Antwort!

    Ja Du hast recht, ich wollte zuerst bei WordPress.com meinen Blog zum laufen bringen. Das hat aber nicht geklappt (ich hätte wohl den nameserver ändern müssen, der GMX-Support sagte mir aber dass das nicht machbar ist - würde auch nie mehr GMX wählen, aber nun habe ich es nun mal dort gekauft, also Haken dran). Dann habe ich das Buch gekauft und endlich auch den Unterschied verstanden ;o) Es macht auch richtig Spaß, die Website selbst aufzubauen. Auch wenn ich immer wieder an meine Grenzen stoße, aber nur so lernt man es halt...

    Also, ich habe Variante 1 und 2 aus dem Beitrag "Falsche WordPress-Adresse (URL) ändern" ausprobiert, leider ohne Erfolg. Es erscheint immer nur "404 not found".

    Dann habe ich mich bei phpMyAdmin angemeldet, in "wp_options" die "siteurl" auf "https://www.mrsmama.de" geändert und aktualisiert. Wieder "404 not found".

    Ich komme überhaupt nicht mehr ins backend rein, es ist als wäre alles weg... Kann es sein, dass meine Website keinen Inhalt mehr hat, also irgendwie alles gelöscht wurde? Kann ich das irgendwo nachsehen? Befürchte ja dass ich (mal wieder) die Installation ganz von vorne beginnen muss (wäre ja nicht das erste mal, aber sehr schade da ich schon sehr viel am Design geändert hatte).

    Liebe Grüße!
     
  4. SirEctor

    SirEctor Well-Known Member
    Ehrenmitglied

    Registriert seit:
    28. Oktober 2008
    Beiträge:
    12.299
    Zustimmungen:
    406
    Wenn die Datenbank noch da ist, hast du das Wichtigste noch. Logge dich per FTP ein und schaue ob die Dateien noch da sind. Schaue in die wp-config.php ob die richtige Datenbank hinterlegt ist.

    Bekommst du denn irgendeinen Fehler? Der Link zum Login funktioniert bei mir https://www.mrsmama.de/wp-login.php. Und auch deine Seite wird angezeigt.
     
  5. MrsMama

    MrsMama New Member

    Registriert seit:
    14. Dezember 2019
    Beiträge:
    4
    Zustimmungen:
    0
    Vielen Dank. Die Dateien sind noch da. In der wp-config.php ist die richtige Datenbank hinterlegt. Zumindest stimmen alle Daten wie DB_NAME, DB_USER und DB_HOST mit den Zugangsdaten, die ich von GMX, habe überein. Eine Fehlermeldung bekomme ich hier nicht.

    Wenn ich auf www.mrsmama.de gehe, dann erscheint der Hinweis, dass keine sichere Verbindung möglich ist:
    upload_2019-12-15_12-7-56.png upload_2019-12-15_12-7-56.png


    Auch wenn ich es über www.mrsmama.de/wp-login.php versuche, kommt die gleiche Anzeige:
    upload_2019-12-15_12-12-24.png

    Versuche ich, mich unter mrsmama.de/wp-admin anzumelden, erscheint "404 not found":
    upload_2019-12-15_12-10-2.png

    Ich habe es sogar an verschiedenen PCs probiert (ohne zu wissen ob das überhaupt einen Unterschied macht...). Aber immer das Gleiche. Ich verstehe nicht, wie es sein kann, dass Du die Seite dann angezeigt bekommst...

    Es ist echt frustrierend... ich würde so gern weitermachen und komme einfach nicht auf den Fehler...
    Liebe Grüße!
     
  6. MrsMama

    MrsMama New Member

    Registriert seit:
    14. Dezember 2019
    Beiträge:
    4
    Zustimmungen:
    0
    Noch ein Nachtrag: Ich konnte mich bei WordPress auch nicht mehr anmelden. Ich habe durch das abmelden des Business-Accounts bei WordPress.com mein Konto gelöscht (habe jetzt also auch kein kostenfreies mehr).

    Kann es also sein, dass es daran liegt, dass ich mich dadurch auch bei WordPress.org abgemeldet habe?
     
  7. Marcus[IS]

    Marcus[IS] Well-Known Member

    Registriert seit:
    23. August 2009
    Beiträge:
    5.611
    Zustimmungen:
    93
    Nein das sind zwei völlig unterschiedliche Baustellen.
    Die wordpress.org Version hat im Grunde nichts mit einem wordpress.com Account zu tun und ist in dieser Sache unabhängig.
     
  8. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    7.160
    Zustimmungen:
    696
    Die Seite scheint inzwischen zu funktionieren.

    Eine falsche Einbindung via http statt https des Logos auf der Startseite könnte man noch beheben, und das Impressum scheint bei der ganzen Aktion verlorengegangen zu sein, und so wie es aussieht einige Teile der Datenschutzerklärung...
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden