1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Fehler bei Installation - Forbidden

Dieses Thema im Forum "Installation" wurde erstellt von Trixi111, 28. Januar 2024.

  1. Trixi111

    Trixi111 Member

    Registriert seit:
    28. Januar 2024
    Beiträge:
    7
    Zustimmungen:
    0
    Hallo!

    Ich habe mit die neue Version von Wordpress.org heruntergeladen und über FTP in einen Ordner meines Webspaces geladen. Dann habe ich die wp-config.php angepasst und hochgeladen. Das habe ich immer so gemacht und es hat auch immer gut funktioniert.
    Leider erscheint jetzt folgendes, wenn ich meine Zugangsdaten erstellen möchte: Forbidden - You do not have permission to access the requested file on this server.

    Benutzername, Passwort usw. habe ich jetzt schon oft überprüft und neu eingegeben. Hat nichts gebracht. Auch habe ich die Dateiberechtigungen angepasst. Hat auch nichts gebracht.
    Kennt jemand dieses Problem?

    Ich wäre dankbar für Hilfe!
    Danke!
    Liebe Grüße,
    Trixi
     
  2. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    11.578
    Zustimmungen:
    1.746
    Wann/wo genau erscheint die Meldung? Im Frontend? Im Backend? Der Login Dialog funktioniert?
     
  3. Trixi111

    Trixi111 Member

    Registriert seit:
    28. Januar 2024
    Beiträge:
    7
    Zustimmungen:
    0
    Danke! Nein, der Login Dialog funktioniert nicht.
    Ich habe die Daten eingegeben und normalerweise kommt dann ein Dialog, bei dem ich den Benutzernamen für meine WP-Installation eingeben kann. Also der Dialog nach den Eingaben der Datenbank. Also ich komme gar nicht ins Back- oder Frontend ...
     
  4. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    11.578
    Zustimmungen:
    1.746
    Entferne Deine hochgeladene wp-config.php und starte die Installation neu, WordPress legt die Datei im Installationsverlauf selbst an.

    Wenn eine korrekt manuell erstellte wp-config.php mit gültigen Datenbank Daten vorhanden wäre, würde keine Abfrage zur Eingabe der Datenbank Daten erscheinen.
     
    #4 b3317133, 28. Januar 2024
    Zuletzt bearbeitet: 28. Januar 2024
  5. Trixi111

    Trixi111 Member

    Registriert seit:
    28. Januar 2024
    Beiträge:
    7
    Zustimmungen:
    0
    Das habe ich auch schon gemacht. Da kommt leider der gleiche Fehler ...
    Ich habe es heute auch schon mit einer älteren WP-Version probiert, das Verzeichnis umbenannt usw.
    Vielleicht ist es ein Sonntagsproblem ... Ich werde morgen mal bei meinem Hoster anfragen.

    Danke, dass du dir Gedanken darüber machst :)
     
  6. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    11.578
    Zustimmungen:
    1.746
    Evtl. sind auch schon (unpassende) Inhalte in der Datenbank, lösche alle Tabellen dort bevor Du die Installation neu beginnst.
     
    Trixi111 gefällt das.
  7. Trixi111

    Trixi111 Member

    Registriert seit:
    28. Januar 2024
    Beiträge:
    7
    Zustimmungen:
    0
    Danke, das probiere ich mal. Ich hatte die Datenbank ganz neu erstellt. Aber wer weiß ...
    Danke auf jeden Fall!
     
  8. r23

    r23 Well-Known Member

    Registriert seit:
    9. Dezember 2006
    Beiträge:
    7.283
    Zustimmungen:
    576
    Vielleicht liegt WordPress im falschen Verzeichnis oder die Domain zeigt auf ein anderes Verzeichnis? Bei einigen muss man wenige Minuten warten, bis derartige Änderungen an Verzeichnis <-> Domain funktionieren.

    Und per se es ist ein Sonntagsproblem;)
     
    Trixi111 gefällt das.
  9. Trixi111

    Trixi111 Member

    Registriert seit:
    28. Januar 2024
    Beiträge:
    7
    Zustimmungen:
    0
    Hat auch nicht funktioniert. Ich mach für heute mal Schluss und werde morgen weiterforschen ...
    Vielen Dank auf jeden Fall!
     
  10. Trixi111

    Trixi111 Member

    Registriert seit:
    28. Januar 2024
    Beiträge:
    7
    Zustimmungen:
    0
    Hallo!
    Ich konnte das Problem immer noch nicht lösen. Mein Hoster scheibt mir: Am Server liegt es nicht. Woran denn bitte dann?
    Ich habe die Dateiberechtigungen angepasst, habe diverse Ordner verwendet, habe unterschiedliche Wordpress-Versionen ausprobiert. Es bleibt die Meldung: You do not have permission to access the requested file on this server.
    Hier ist der Link: https://www.melius-vivere.at/Versuch2/wp-admin/install.php
    Es hakt irgendwie bei dem Schritt, bei dem Wordpress installiert werden soll.
    Ist leider kein Sonntagsproblem geblieben ;)
    Ich bin dankbar für alle Ideen!
    Liebe Grüße
     
  11. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    11.578
    Zustimmungen:
    1.746
    Die aktuell sichtbare 403 Fehlermeldung stammt nicht von WordPress, der Server verbietet offenbar Zugriff auf die gewünschte install.php Datei.

    Befindet sich eine Datei .htaccess in dem Ordner auf den dieser Pfad zeigt? Falls ja, entferne diese.
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Falls das nichts ändert, benenne die Datei wp-admin/install.php temporär um in z.B. wp-admin/test.php und versuche dann, diese im Browser aufzurufen.
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Wenn das möglich ist und keine 403 Fehlermeldung erzeugt, liegt es an irgendwelchen Sicherheitsfunktionen des Servers. Die Installation wird dann trotzdem nicht fortgeführt werden können, da für die nächsten Schritte install.php in der Datei hardgecodet ist, aber Du weisst dann schon mehr.

    Da im übergeordneten Ordner eine weitere WordPress Installation läuft, kann es theoretisch auch Einflüsse von dort geben.
     
  12. Trixi111

    Trixi111 Member

    Registriert seit:
    28. Januar 2024
    Beiträge:
    7
    Zustimmungen:
    0
    Danke für dein ausführliche Antwort.
    Ja, das mit den anderen WP-Installationen war auch schon mein Gedanke. Ich hatte dann mehrere Unterordner erstellt und die WP-Dateien für die Installation in einen Unter-unter-unter-Ordner gepackt. Hat auch nicht funktioniert ;)

    Mein Server-Support hat die Installation jetzt über Easy.Install gemacht, was funktioniert hat.
    Für mich ist es noch immer nicht nachvollziehbar, warum es auf meine "alte" Methode über FTP upload nicht funktioniert.
    Ich werde es einfach nochmal probieren und deine Hinweise ausprobieren. Falls ich die Lösung finden sollte, werde ich sie hier posten.
    Vielen Dank!
    Liebe Grüße
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden