1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

WP 4.9 Fehler beim Import einer DB

Dieses Thema im Forum "Installation" wurde erstellt von mteepee, 21. September 2018.

Schlagworte:
  1. mteepee

    mteepee Well-Known Member

    Registriert seit:
    23. Januar 2012
    Beiträge:
    266
    Zustimmungen:
    0
    Hallo,

    ich versuche auf meinem Webspace bei 1und1 eine DB zu installieren, um eine neue WP Installation hochzuladen. Dabei bekomme ich immer den Fehler hier.

    Was kann ich da machen?
    Ich bin etwas überfragt und der Support von 1und1 hilft nicht, weil man für den Import der DB selbst verantwortlich ist.

    VG Marco


    SQL-Befehl:


    http://www.inimap.de/


    /*!40101 SET @OLD_CHARACTER_SET_CLIENT=@@CHARACTER_SET_CLIENT */;



    MySQL meldet: [​IMG]

    #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'http://www.inimap.de/

    /*!40101 SET @OLD_CHARACTER_SET_CLIENT=@@CHARACTER_SET_C' at line 1
     
  2. JABA-Hosting

    JABA-Hosting Well-Known Member

    Registriert seit:
    29. März 2016
    Beiträge:
    2.401
    Zustimmungen:
    87
    Zeig mal bitte die Zeile 1 deines SQL Dumps.
     
  3. mteepee

    mteepee Well-Known Member

    Registriert seit:
    23. Januar 2012
    Beiträge:
    266
    Zustimmungen:
    0
    Was genaue meinst du? Zeile 1 der DB?
    Ich sehe nur das im Anhang...
     

    Anhänge:

  4. JABA-Hosting

    JABA-Hosting Well-Known Member

    Registriert seit:
    29. März 2016
    Beiträge:
    2.401
    Zustimmungen:
    87
    Öffne bitte die .sql Datei mit einem Text Editor und mach ein Screenshot von den ersten Zeilen.
     
  5. mteepee

    mteepee Well-Known Member

    Registriert seit:
    23. Januar 2012
    Beiträge:
    266
    Zustimmungen:
    0
    ...anbei der screeny... danke, dass du dir das anschaust.
     

    Anhänge:

  6. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    5.862
    Zustimmungen:
    504
    Bei Import zu 1und1 ist oft das hier das Problem.

    In Deinem Fall steht einfach ohne Grund die Webadresse mit im SQL-Dump, entferne diese.
     

    Anhänge:

  7. JABA-Hosting

    JABA-Hosting Well-Known Member

    Registriert seit:
    29. März 2016
    Beiträge:
    2.401
    Zustimmungen:
    87
    Lösche bitte den kompletten

    SET ...

    Teil raus, inkl. diese URL dahinter. Die Wird wohl das Problem machen.
     
  8. mteepee

    mteepee Well-Known Member

    Registriert seit:
    23. Januar 2012
    Beiträge:
    266
    Zustimmungen:
    0
    hab das alles gemacht. nun bekomme ich die Fehlermeldung:



    [​IMG]
    [​IMG]
    [​IMG][​IMG][​IMG][​IMG]
    Aktueller Server:
    [​IMG]Server: db754495038.db.1and1.com


    [​IMG]
    Fehler
    SQL-Befehl:




    --
    -- Datenbank: `d02aad9e`
    --

    -- --------------------------------------------------------

    --
    -- Tabellenstruktur für Tabelle `wp_commentmeta`
    --

    CREATE TABLE IF NOT EXISTS `wp_commentmeta` (
    `meta_id` bigint(20) unsigned NOT NULL AUTO_INCREMENT,
    `comment_id` bigint(20) unsigned NOT NULL DEFAULT '0',
    `meta_key` varchar(255) COLLATE utf8mb4_general_ci DEFAULT NULL,
    `meta_value` longtext COLLATE utf8mb4_general_ci,
    PRIMARY KEY (`meta_id`),
    KEY `comment_id` (`comment_id`),
    KEY `meta_key` (`meta_key`(191))
    ) ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8mb4_general_ci AUTO_INCREMENT=21 ;



    MySQL meldet: [​IMG]

    #1046 - No database selected
    [ Zurück ]
     
  9. JABA-Hosting

    JABA-Hosting Well-Known Member

    Registriert seit:
    29. März 2016
    Beiträge:
    2.401
    Zustimmungen:
    87
    Du musst in phpmyadmin auch eine Datenbank auswählen wo du den Dump einspielen willst.
     
  10. mteepee

    mteepee Well-Known Member

    Registriert seit:
    23. Januar 2012
    Beiträge:
    266
    Zustimmungen:
    0
    Hier die Schritte mit dem Fehler am Ende in Step 3
     

    Anhänge:

  11. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    5.862
    Zustimmungen:
    504
    Zu diesem Fehler, siehe Hinweis oben:
     
  12. mteepee

    mteepee Well-Known Member

    Registriert seit:
    23. Januar 2012
    Beiträge:
    266
    Zustimmungen:
    0
    So - hat alles geklappt. Was ein Stress.
    Wollte mich bei allen hier bedanken, die mich so unterstützt haben. Ihr seid groß!
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden