1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

WP 4.7 Fehler im Backend

Dieses Thema im Forum "Konfiguration" wurde erstellt von fmt@kurpfalz, 2. Januar 2017.

  1. fmt@kurpfalz

    fmt@kurpfalz Well-Known Member

    Registriert seit:
    12. Juni 2015
    Beiträge:
    70
    Zustimmungen:
    0
    Hallo,
    nach einem Hosterwechsel habe ich im Backend das folgenden Problem:
    Zwischenablage03.jpg
    Kann mir da jemand helfen?
    Bei allen anderen WP-Installationen hat der Umzug funktioniert.
    Verwende WP4.7 und die Theme "Weaver II".
     
  2. JABA-Hosting

    JABA-Hosting Well-Known Member

    Registriert seit:
    29. März 2016
    Beiträge:
    2.440
    Zustimmungen:
    95
    Wordpress 4.7 runterladen und mit deinen Daten überschreiben per FTP.
     
  3. fmt@kurpfalz

    fmt@kurpfalz Well-Known Member

    Registriert seit:
    12. Juni 2015
    Beiträge:
    70
    Zustimmungen:
    0
    Hallo,
    Leider hat eine Neuinstallation keine Besserung gebracht. Ich habe WP auf das bestehende WP neu aufgespielt.
    Auch brauch der Costumizer bei Weaver xtreme eine halbe Ewigkeit um zu laden.
    Bringt es etwas die WP-Installation zulöschen und ganz neu zu installieren?
    Wie bekomme ich es dann hin, nicht die defekten Daten bei dem Einspielen meiner alten Daten zuüberschreiben?
     
  4. danielgoehr

    danielgoehr Well-Known Member

    Registriert seit:
    13. Juli 2016
    Beiträge:
    2.443
    Zustimmungen:
    62
    Verwendest du "Weaver II" oder "Weaver Xtreme"?

    Zu ersterem hattest du gestern ja schon einen Thread eröffnet und das soll laut Author nicht mehr verwendet werden.

    Ich würde an deiner Stelle auch mal genau da ansetzen: Sind die Probleme weg, wenn du (temporär) auf ein Standard-Theme wechselst?
     
  5. fmt@kurpfalz

    fmt@kurpfalz Well-Known Member

    Registriert seit:
    12. Juni 2015
    Beiträge:
    70
    Zustimmungen:
    0
    Hallo,
    habe mittlerweile auf die Weaver Xtreme gewechselt.
    Das mit der Standard-Theme test ich mal.
     
  6. fmt@kurpfalz

    fmt@kurpfalz Well-Known Member

    Registriert seit:
    12. Juni 2015
    Beiträge:
    70
    Zustimmungen:
    0
    Hallo,
    hab jetzt mal in eine Standard-Theme gewechselt.
    Leider keine Änderung.
     
  7. JABA-Hosting

    JABA-Hosting Well-Known Member

    Registriert seit:
    29. März 2016
    Beiträge:
    2.440
    Zustimmungen:
    95
    Steht in den Error Logs was drin?

    Ansonsten, vielleicht sagt der Debug Modus irgendwas?
     
  8. fmt@kurpfalz

    fmt@kurpfalz Well-Known Member

    Registriert seit:
    12. Juni 2015
    Beiträge:
    70
    Zustimmungen:
    0
    Hallo,
    die Error.log hat den letzten Eintrag von September. Dort hat die Seite aber noch funktioniert.
    Der Debug-Modus sagt mir nichts. Wie kann man den aktivieren. Habe damit keine Erfahrung.
     
  9. JABA-Hosting

    JABA-Hosting Well-Known Member

    Registriert seit:
    29. März 2016
    Beiträge:
    2.440
    Zustimmungen:
    95
  10. fmt@kurpfalz

    fmt@kurpfalz Well-Known Member

    Registriert seit:
    12. Juni 2015
    Beiträge:
    70
    Zustimmungen:
    0
    Hallo,
    das deaktivieren aller Plugins hat keine weitere Besserung gebracht.
    Zwischenablage04.jpg
    Ich habe an dieser Stelle keine Ahnung mehr, was ich machen soll.

    Zu dem Debug-Modus. Das kam heraus, als ich das Backend neu geladen hatte:

    Notice: register_sidebar_widget is deprecated since version 2.8.0! Use wp_register_sidebar_widget() instead. in /www/htdocs/w015582f/fmt-kurpfalz.de/wp-includes/functions.php on line 3783

    Notice: register_widget_control is deprecated since version 2.8.0! Use wp_register_widget_control() instead. in /www/htdocs/w015582f/fmt-kurpfalz.de/wp-includes/functions.php on line 3783

    Notice: has_cap wurde mit einem Parameter oder Argument aufgerufen, der seit Version 2.0.0 veraltet ist! Die Benutzung von user_level in Plugins und Themes ist veraltet. Nutze stattdessen das Abfragen von roles oder capabilities. in /www/htdocs/w015582f/fmt-kurpfalz.de/wp-includes/functions.php on line 3975

    Notice: has_cap wurde mit einem Parameter oder Argument aufgerufen, der seit Version 2.0.0 veraltet ist! Die Benutzung von user_level in Plugins und Themes ist veraltet. Nutze stattdessen das Abfragen von roles oder capabilities. in /www/htdocs/w015582f/fmt-kurpfalz.de/wp-includes/functions.php on line 3975

    Notice: has_cap wurde mit einem Parameter oder Argument aufgerufen, der seit Version 2.0.0 veraltet ist! Die Benutzung von user_level in Plugins und Themes ist veraltet. Nutze stattdessen das Abfragen von roles oder capabilities. in /www/htdocs/w015582f/fmt-kurpfalz.de/wp-includes/functions.php on line 3975

    Notice: has_cap wurde mit einem Parameter oder Argument aufgerufen, der seit Version 2.0.0 veraltet ist! Die Benutzung von user_level in Plugins und Themes ist veraltet. Nutze stattdessen das Abfragen von roles oder capabilities. in /www/htdocs/w015582f/fmt-kurpfalz.de/wp-includes/functions.php on line 3975

    Notice: has_cap wurde mit einem Parameter oder Argument aufgerufen, der seit Version 2.0.0 veraltet ist! Die Benutzung von user_level in Plugins und Themes ist veraltet. Nutze stattdessen das Abfragen von roles oder capabilities. in /www/htdocs/w015582f/fmt-kurpfalz.de/wp-includes/functions.php on line 3975

    Notice: has_cap wurde mit einem Parameter oder Argument aufgerufen, der seit Version 2.0.0 veraltet ist! Die Benutzung von user_level in Plugins und Themes ist veraltet. Nutze stattdessen das Abfragen von roles oder capabilities. in /www/htdocs/w015582f/fmt-kurpfalz.de/wp-includes/functions.php on line 3975

    Notice: register_uninstall_hook wurde fehlerhaft aufgerufen. Nur eine Methode oder Funktion einer statischen Klasse kann in einem uninstall hook verwendet werden. Weitere Informationen: Debugging in WordPress (engl.) (Diese Meldung wurde in Version 3.1.0 hinzugefügt.) in /www/htdocs/w015582f/fmt-kurpfalz.de/wp-includes/functions.php on line 4091

    Fatal error: Call to undefined method UserAccessManager::getAdminOptions() in /www/htdocs/w015582f/fmt-kurpfalz.de/wp-content/plugins/user-access-manager-nextgen-gallery-extension/class/UamNgg.class.php on line 50
     
    #10 fmt@kurpfalz, 3. Januar 2017
    Zuletzt bearbeitet: 3. Januar 2017
  11. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    6.484
    Zustimmungen:
    584
    Deaktiviere (dauerhaft) das Plugin User Access Manager – NextGEN Gallery Extension, es verursacht einen "Fatal Error" und ist ur-alt, letztes Update vor 4 Jahren!

    Würde zudem empfehlen, die anderen Antworten zu Deinen Postings zu beherzigen und ein aktuelles Theme mit aktuellen Plugins zu verwenden.

    Zitat von https://weavertheme.com/why-weaver/

     
    #11 b3317133, 3. Januar 2017
    Zuletzt bearbeitet: 3. Januar 2017
  12. fmt@kurpfalz

    fmt@kurpfalz Well-Known Member

    Registriert seit:
    12. Juni 2015
    Beiträge:
    70
    Zustimmungen:
    0
    Hallo,
    beim Start der Seite kommen folgende Zeilen:

    Notice: wp_enqueue_script was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or login_enqueue_scripts hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.0.) in /www/htdocs/w015582f/fmt-kurpfalz.de/wp-includes/functions.php on line 4091

    Notice: register_sidebar_widget is deprecated since version 2.8.0! Use wp_register_sidebar_widget() instead. in /www/htdocs/w015582f/fmt-kurpfalz.de/wp-includes/functions.php on line 3783

    Notice: register_widget_control is deprecated since version 2.8.0! Use wp_register_widget_control() instead. in /www/htdocs/w015582f/fmt-kurpfalz.de/wp-includes/functions.php on line 3783

    Notice: Undefined variable: use_session in /www/htdocs/w015582f/fmt-kurpfalz.de/wp-content/plugins/wp-ticker/wp-ticker.php on line 138
     
  13. fmt@kurpfalz

    fmt@kurpfalz Well-Known Member

    Registriert seit:
    12. Juni 2015
    Beiträge:
    70
    Zustimmungen:
    0
    Hallo,
    nachdem ich alle Plugins aktiviert habe kommen immer mehr Fehler im Backend:

    Notice: register_uninstall_hook was called incorrectly. Only a static class method or function can be used in an uninstall hook. Please see Debugging in WordPress for more information. (This message was added in version 3.1.0.) in /www/htdocs/w015582f/fmt-kurpfalz.de/wp-includes/functions.php on line 4091

    Notice: wp_enqueue_script was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or login_enqueue_scripts hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.0.) in /www/htdocs/w015582f/fmt-kurpfalz.de/wp-includes/functions.php on line 4091

    Notice: register_sidebar_widget is deprecated since version 2.8.0! Use wp_register_sidebar_widget() instead. in /www/htdocs/w015582f/fmt-kurpfalz.de/wp-includes/functions.php on line 3783

    Notice: register_widget_control is deprecated since version 2.8.0! Use wp_register_widget_control() instead. in /www/htdocs/w015582f/fmt-kurpfalz.de/wp-includes/functions.php on line 3783

    Notice: Undefined variable: use_session in /www/htdocs/w015582f/fmt-kurpfalz.de/wp-content/plugins/wp-ticker/wp-ticker.php on line 138

    Notice: has_cap wurde mit einem Parameter oder Argument aufgerufen, der seit Version 2.0.0 veraltet ist! Die Benutzung von user_level in Plugins und Themes ist veraltet. Nutze stattdessen das Abfragen von roles oder capabilities. in /www/htdocs/w015582f/fmt-kurpfalz.de/wp-includes/functions.php on line 3975

    Notice: has_cap wurde mit einem Parameter oder Argument aufgerufen, der seit Version 2.0.0 veraltet ist! Die Benutzung von user_level in Plugins und Themes ist veraltet. Nutze stattdessen das Abfragen von roles oder capabilities. in /www/htdocs/w015582f/fmt-kurpfalz.de/wp-includes/functions.php on line 3975

    Notice: has_cap wurde mit einem Parameter oder Argument aufgerufen, der seit Version 2.0.0 veraltet ist! Die Benutzung von user_level in Plugins und Themes ist veraltet. Nutze stattdessen das Abfragen von roles oder capabilities. in /www/htdocs/w015582f/fmt-kurpfalz.de/wp-includes/functions.php on line 3975

    Notice: has_cap wurde mit einem Parameter oder Argument aufgerufen, der seit Version 2.0.0 veraltet ist! Die Benutzung von user_level in Plugins und Themes ist veraltet. Nutze stattdessen das Abfragen von roles oder capabilities. in /www/htdocs/w015582f/fmt-kurpfalz.de/wp-includes/functions.php on line 3975

    Notice: has_cap wurde mit einem Parameter oder Argument aufgerufen, der seit Version 2.0.0 veraltet ist! Die Benutzung von user_level in Plugins und Themes ist veraltet. Nutze stattdessen das Abfragen von roles oder capabilities. in /www/htdocs/w015582f/fmt-kurpfalz.de/wp-includes/functions.php on line 3975

    Notice: has_cap wurde mit einem Parameter oder Argument aufgerufen, der seit Version 2.0.0 veraltet ist! Die Benutzung von user_level in Plugins und Themes ist veraltet. Nutze stattdessen das Abfragen von roles oder capabilities. in /www/htdocs/w015582f/fmt-kurpfalz.de/wp-includes/functions.php on line 3975

    Notice: has_cap wurde mit einem Parameter oder Argument aufgerufen, der seit Version 2.0.0 veraltet ist! Die Benutzung von user_level in Plugins und Themes ist veraltet. Nutze stattdessen das Abfragen von roles oder capabilities. in /www/htdocs/w015582f/fmt-kurpfalz.de/wp-includes/functions.php on line 3975



    Im Frondend kommen diese Meldungen:

    Notice
    : register_uninstall_hook was called incorrectly. Only a static class method or function can be used in an uninstall hook. Please see Debugging in WordPress for more information. (This message was added in version 3.1.0.) in /www/htdocs/w015582f/fmt-kurpfalz.de/wp-includes/functions.php on line 4091

    Notice: wp_enqueue_script was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or login_enqueue_scripts hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.0.) in /www/htdocs/w015582f/fmt-kurpfalz.de/wp-includes/functions.php on line 4091

    Notice: register_sidebar_widget is deprecated since version 2.8.0! Use wp_register_sidebar_widget() instead. in /www/htdocs/w015582f/fmt-kurpfalz.de/wp-includes/functions.php on line 3783

    Notice: register_widget_control is deprecated since version 2.8.0! Use wp_register_widget_control() instead. in /www/htdocs/w015582f/fmt-kurpfalz.de/wp-includes/functions.php on line 3783

    Notice: Undefined variable: use_session in /www/htdocs/w015582f/fmt-kurpfalz.de/wp-content/plugins/wp-ticker/wp-ticker.php on line 138


     
  14. JABA-Hosting

    JABA-Hosting Well-Known Member

    Registriert seit:
    29. März 2016
    Beiträge:
    2.440
    Zustimmungen:
    95
    Ich kann mir nicht vorstellen, dass die Meldungen im Standard Theme und alle Plugins deaktiviert kommen.

    Dein Themes ist einfach veraltet und einige Plugins auch.
     
  15. fmt@kurpfalz

    fmt@kurpfalz Well-Known Member

    Registriert seit:
    12. Juni 2015
    Beiträge:
    70
    Zustimmungen:
    0
    Hallo,
    erstmal vielen Dank für die Geduld und die Hinweise.
    Ich habe mittlerweile eine aktuelle Theme (Weaver Xtreme) installiert. Habe alle Plugins durchforstet und alle alten Plugins deinstalliert. Trotzdem komme ich mit dem Backend nicht weiter. Das Costumizer-Menu braucht eine Ewigkeit zuladen, bzw. lädt gar nicht. Das oben beschriebene Problem mit dem Editor existiert immer noch.
    Auch das Deakitvieren aller Plugins und eine Standard-Theme haben darab nichts geändert.
    Ich bin mit meinem Latein am Ende.
     
  16. danielgoehr

    danielgoehr Well-Known Member

    Registriert seit:
    13. Juli 2016
    Beiträge:
    2.443
    Zustimmungen:
    62
    Hat sich dadurch gar nichts geändert? Mindestens zwei der Buttons auf deinem Screenshot sind nicht WP-Standard. Zumindest die (und die Fehlermeldung vom User Access Manager) müssten dann verschwunden sein.

    Was sagt die die Javascript-Konsole auf der Editor-Seite?


    Und zur Sicherheit nochmal die Frage: Alle diese Fehler, die du hier gepostet hast, sind auch noch vorhanden, wenn du alle Plugins deaktivierst und ein Standardtheme (z.B.- Twenty-Sixteen) aktivierst? Weil es ist so, wie JABA-Hosting auch schon schreibt: Das kann eigentlich nicht sein.
     
    #16 danielgoehr, 3. Januar 2017
    Zuletzt bearbeitet: 3. Januar 2017
  17. fmt@kurpfalz

    fmt@kurpfalz Well-Known Member

    Registriert seit:
    12. Juni 2015
    Beiträge:
    70
    Zustimmungen:
    0
    Hallo danielgoehr,
    ich habe alle Plugins deaktiviert, Standardtheme geladen und trotzdem kommt der Fehler bei der Erstellung bzw. Bearbeitung von Post.
     
  18. JABA-Hosting

    JABA-Hosting Well-Known Member

    Registriert seit:
    29. März 2016
    Beiträge:
    2.440
    Zustimmungen:
    95
  19. fmt@kurpfalz

    fmt@kurpfalz Well-Known Member

    Registriert seit:
    12. Juni 2015
    Beiträge:
    70
    Zustimmungen:
    0
    Das ist richtig. Aber im Backend funktioniert es immer noch nicht vollständig.
    Siehe Bild:
    Zwischenablage04.jpg
     

    Anhänge:

  20. JABA-Hosting

    JABA-Hosting Well-Known Member

    Registriert seit:
    29. März 2016
    Beiträge:
    2.440
    Zustimmungen:
    95
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden