1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Fehler in der deutschsprachigen Anpassung?

Dieses Thema im Forum "Konfiguration" wurde erstellt von aprecon, 7. Januar 2005.

  1. aprecon

    aprecon New Member

    Registriert seit:
    7. Januar 2005
    Beiträge:
    4
    Zustimmungen:
    0
    Hallo!

    Ich habe die de_DE.mo-Datei installiert und es funktioniert auch alles wunderbar. Nur fehlt dem Monat November das große N am Anfang. Nun steht überall ovember stattdessen. Kann ich das irgendwie nachträglich bearbeiten oder ist der Fehler schon jemand anderem aufgefallen und es gibt irgendwo ein Update?

    Vielen Dank im Voraus!

    http://diehimmlischejoan.de/blog
     
  2. Woodstock

    Woodstock Well-Known Member

    Registriert seit:
    14. November 2004
    Beiträge:
    959
    Zustimmungen:
    0
    Hast du schon mal in der wp-includes/locale.php geschaut, wie der November dort aussieht?
     
  3. aprecon

    aprecon New Member

    Registriert seit:
    7. Januar 2005
    Beiträge:
    4
    Zustimmungen:
    0
    Die wp-includes/locale.php ist bei mir auf Englisch. Ist das normal? (Da sieht aber alles okeh aus.)

    Was mir auch aufgefallen ist: Wenn ich einen Eintrag schreibe und die Zeitmarke bearbeite, ist das Drop-Down-Menü für den Monat selber auch schon fehlerhaft...
     
  4. Woodstock

    Woodstock Well-Known Member

    Registriert seit:
    14. November 2004
    Beiträge:
    959
    Zustimmungen:
    0
    Die Datei an sich ist bei mir auch englisch. Nur das, was in den Klammern steht, das kannst du doch selbst definieren. Z.B.:

    Wenn du in die Klammern statt ('November') ('Wackelpudding') schreibst, dann ist das halt deine Definition für den Monat Nr. 11. Was steht dort bei dir?
     
  5. suedkind

    suedkind Well-Known Member

    Registriert seit:
    5. Oktober 2004
    Beiträge:
    1.665
    Zustimmungen:
    0
    macht das an der stelle sinn? er hat doch die deutsche .mo-datei eingebunden, da sind meines wissens die monate auch übersetzt (?)
     
  6. DogMan

    DogMan Well-Known Member

    Registriert seit:
    3. September 2004
    Beiträge:
    931
    Zustimmungen:
    0
    Mir fällt dazu nur ein, dass Deine Sprachdatei Murks ist. Mittlerweile gibt es ja eine ganze Menge von denen im Netz. Woher hast Du denn Deine? --hmm--

    Wenn alles nichts hilft, sottest Du (wie ich*) die wp-includes/locale.php bearbeiten. Wie das geht hat Perun einmal beschrieben. Hier sein Artikel bei D.Web (Anleitung steht ziemlich weit unten)

    * Ich wollte das Interface in deutsch, den Adminbereich aber in englisch)

    Gruß
    DogMan
     
  7. suedkind

    suedkind Well-Known Member

    Registriert seit:
    5. Oktober 2004
    Beiträge:
    1.665
    Zustimmungen:
    0
    echt? mir ist nur das auf http://www.ihad.de/wordpress/ bekannt
    wo gibt es den noch weitere?
     
  8. DogMan

    DogMan Well-Known Member

    Registriert seit:
    3. September 2004
    Beiträge:
    931
    Zustimmungen:
    0
    öh~
    Das kann ich Dir gerade nicht mehr zusammenstellen. Als ich mich (etwa im August) um die Übersetzung bemühte, fand ich, nachdem ich mich tief in Google und Co. eingegraben hatte, mindestens drei Stück.

    Zunächst dachte ich, vielleicht genauso, wie Du, dass auf den Seiten, die ich fand, immer von der gleichen de_DE.mo gesprochen wird.

    Mir ist dann aber aufgefallen, dass die Datei auf einer anderen Seite DE_DE.mo geschrieben wurde. Erst dachte ich noch an einen Schreibfehler, dann installierte ich beide nacheinander und stellte Unterschiede fest.

    Mittlerweile habe ich alle heruntergeschmissen, weil ich meinen Adminbereich so besser vor den recht langen deutschen Übersetzungen schützen kann, die das Layout verhunzen. Übersetzt habe ich direkt und nur dort, wo man es im Weblog als Leser sehen kann.

    Gruß
    DogMan
     
  9. DogMan

    DogMan Well-Known Member

    Registriert seit:
    3. September 2004
    Beiträge:
    931
    Zustimmungen:
    0
    Nachtrag:

    Ich glaube das hier war damals so ein Kandidat (ohne Gewähr)
     
  10. aprecon

    aprecon New Member

    Registriert seit:
    7. Januar 2005
    Beiträge:
    4
    Zustimmungen:
    0
    Vielen Dank für all eure Antworten. :D

    Ich hab noch mal bei http://www.ihad.de/wordpress/ nachgeguckt, und da gab es ein Update zu der Datei, die ich damals runtergeladen hab. Jetzt sind alle Buchstaben vorhanden (soweit ich das gesehen hab :wink: ).

    :D
     
  11. Olaf

    Olaf WPDE-Team
    Mitarbeiter

    Registriert seit:
    3. September 2004
    Beiträge:
    2.738
    Zustimmungen:
    29
    ...wir (haupsächlich Annette) arbeiten gerade an einer aktualisierten Übersetzung (WP 1.5bx abwärts kompatibel).
    Die müsste eigentlich bis zum nächsten Wochenende fertig sein.
     
  12. DogMan

    DogMan Well-Known Member

    Registriert seit:
    3. September 2004
    Beiträge:
    931
    Zustimmungen:
    0
    Haa (Beckerfaust machend) sag ich doch! :mrgreen:
     
  13. tagebuch-oase

    tagebuch-oase Member

    Registriert seit:
    13. Januar 2005
    Beiträge:
    12
    Zustimmungen:
    0
    dann setz ich mich mal ins wartezimmer :)
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden