1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Fehler: Umleitungsfehler bei wp-login

Dieses Thema im Forum "Konfiguration" wurde erstellt von Oli89, 31. August 2017.

  1. Oli89

    Oli89 Member

    Registriert seit:
    8. Februar 2017
    Beiträge:
    17
    Zustimmungen:
    0
    Hallo liebes Forum,
    ich habe ein Problem mit meiner Wordpresseite:(
    Diese habe ich zu All-Inkl umgezogen und anfangs lief alles super.
    Heute wollte ich mich einloggen, und da kam der Fehler

    "Fehler: Umleitungsfehler

    Die aufgerufene Website leitet die Anfrage so um, dass sie nie beendet werden kann.

    Dieses Problem kann manchmal auftreten, wenn Cookies deaktiviert oder abgelehnt werden."

    Hieraufhin habe ich gegooglet und sämtliche Lösungsmöglichkeiten versucht, jedoch leider ohne Erfolg.

    Die versuchten Lösungsansätze waren:

    1.Versuch
    define(‘WP_SITEURL’, ‘http://www.deine-url.de’);
    define(‘WP_HOME’, ‘http://www.deine-url.de’);

    in die WP-Config.


    2.Versuch
    define(‘RELOCATE’, true);

    in die WP-Config


    3. Versuch
    Plugin-Ordner umbenennen.

    Nun habe ich hier im Forum noch etwas von der .htaccess datei gelesen. Hier bin ich mir jedoch nicht sicher was ich genau machen soll, da diese bei mir etwas anderst aussieht.

    Inhalt meiner .htaccess des Stammordners:

    # BEGIN rlrssslReallySimpleSSL rsssl_version[2.3.9]
    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteCond %{HTTPS} !=on [NC]
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
    </IfModule>
    # END rlrssslReallySimpleSSL
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Kann mir von euch jemand weiterhelfen?
    Wäre euch echt super dankbar.

    Viele Grüße
    Oli
     
  2. Henk1060

    Henk1060 Well-Known Member

    Registriert seit:
    4. September 2014
    Beiträge:
    2.492
    Zustimmungen:
    116
    hy,

    das hast du gemacht hm... ok aber ohne https
    1.Versuch
    define(‘WP_SITEURL’, ‘http://www.deine-url.de’);
    define(‘WP_HOME’, ‘http://www.deine-url.de’);


    Aber in der htaccess mit httpS# BEGIN rlrssslReallySimpleSSL rsssl_version[2.3.9] <IfModule mod_rewrite.c> RewriteEngine on RewriteCond %{HTTPS} !=on [NC] RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L] </IfModule>


    also hast du eine ssl am server oder nicht.
     
  3. jonas96

    jonas96 Member

    Registriert seit:
    30. August 2017
    Beiträge:
    13
    Zustimmungen:
    0
    das hat bei mir geholfen. Du musst allerdings beachten, dass diese anweisungen nicht am Ende und auch nicht am Anfang der Config stehen dürfen... also am besten irgendwo in der mitte :)
     
  4. Henk1060

    Henk1060 Well-Known Member

    Registriert seit:
    4. September 2014
    Beiträge:
    2.492
    Zustimmungen:
    116
    das macht im diesen fall keinen sinn @jonas96
    Da einmal ohne SSL die seite definiert wird und dann mit mod_rewrite auf auf ssl geleitet werden soll.
    Also beides geht nicht entweder oder ;)
     
  5. Oli89

    Oli89 Member

    Registriert seit:
    8. Februar 2017
    Beiträge:
    17
    Zustimmungen:
    0
    vielen Dank für deine Antworten.
    Die Domain läuft mit ssl, die URL dazu ist https://aquarienmagazin.com/ und die URL zum Einloggen, welche nicht funktioniert ist https://aquarienmagazin.com/wp-login.php.
    Das Thema mit der Config-Datei habe ich schon an verschiedenen Positionen versucht, jedoch leider ohne Erfolg:(.

    Hier noch der Inhalt meiner config-Datei falls euch das hilft.

    <?php

    //Begin Really Simple SSL JetPack fix
    define( "JETPACK_SIGNATURE__HTTPS_PORT", 80 );
    //END Really Simple SSL
    define('WP_CACHE', false); // Added by WP Rocket
    define('DB_NAME', 'xxxxx');
    define('DB_USER', 'xxxxx');
    define('DB_PASSWORD', 'xxxxx');
    define('DB_HOST', 'localhost');
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');
    define(‘RELOCATE’, true);

    $table_prefix = 'wp_';

    define('WPLANG', 'de_DE');

    define('WP_DEBUG', false);

    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');

    require_once(ABSPATH . 'wp-settings.php');
    ?>

    Ich freue mich schon von euch zu hören.
    Vielen Dank und Gruß
    Oli
     
  6. Henk1060

    Henk1060 Well-Known Member

    Registriert seit:
    4. September 2014
    Beiträge:
    2.492
    Zustimmungen:
    116
    mal anders gefragt...
    hast du irgendwelche module installiert für dein login?

    Kann es sein das dein wp-content/plugins ordner fehlt
     
  7. SirEctor

    SirEctor WPDE-Team
    Mitarbeiter

    Registriert seit:
    28. Oktober 2008
    Beiträge:
    11.731
    Zustimmungen:
    314
    Was ist denn jetzt als Siteurl und Home eingetragen? Hast du da nur http:// eingetragen? Versuch es mal mit https://
     
  8. Oli89

    Oli89 Member

    Registriert seit:
    8. Februar 2017
    Beiträge:
    17
    Zustimmungen:
    0
    Was die Plugins angeht, so habe ich hier schonmal den kompletten Ordner rausgenommen (Per FTP gelöscht), dies hat jedoch nichts verändert weshalb ich ihn wieder hochgeladen habe.

    @SirEctor ich weis gerade nicht genau wo du meinst? Wo meinst du dass http:// oder https:// eingetragen ist?
     
  9. SirEctor

    SirEctor WPDE-Team
    Mitarbeiter

    Registriert seit:
    28. Oktober 2008
    Beiträge:
    11.731
    Zustimmungen:
    314
    Hast du es nur mit http:// versucht, oder auch mal mit https://
     
  10. Oli89

    Oli89 Member

    Registriert seit:
    8. Februar 2017
    Beiträge:
    17
    Zustimmungen:
    0
    Ich habe es gerade eben nochmals wie unten ersichtlich durchgeführt.
    Ich denke das muss doch so passen oder?


    <?php

    //Begin Really Simple SSL JetPack fix
    define( "JETPACK_SIGNATURE__HTTPS_PORT", 80 );
    //END Really Simple SSL
    define('WP_CACHE', false); // Added by WP Rocket
    define('DB_NAME', 'xxxxx');
    define('DB_USER', 'xxxxxx');
    define('DB_PASSWORD', 'xxxxxx');
    define('DB_HOST', 'localhost');
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');
    define(‘RELOCATE’, true);

    define('WP_SITEURL', 'https://aquarienmagazin.com/');
    define('WP_HOME', 'https://aquarienmagazin.com/');

    $table_prefix = 'wp_';

    define('WPLANG', 'de_DE');

    define('WP_DEBUG', false);

    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');

    require_once(ABSPATH . 'wp-settings.php');
    ?>
     
  11. Oli89

    Oli89 Member

    Registriert seit:
    8. Februar 2017
    Beiträge:
    17
    Zustimmungen:
    0
    Hat ansonsten noch jemand eine Idee an was es liegen könnte, oder was ich noch versuchen könnte?
    Weis leider selbst echt nicht mehr weiter.

    Würde mich rießig über weitere Tipps freuen.
     
  12. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.965
    Zustimmungen:
    8
    Welchen Sinn macht dieses SimpleSSL Plugin?
     
  13. Oli89

    Oli89 Member

    Registriert seit:
    8. Februar 2017
    Beiträge:
    17
    Zustimmungen:
    0
    Da ich diese Seite auch nur übernommen habe, weis ich es leider nicht:(
    Hab es jedoch gerade mal rausgenommen, jedoch leider ohne Erfolg:(.

    Ich finde es nur etwas komisch, dass ich anfangs nach der Übernahme zu meinem Hoster noch Zugang zur Webseite hatte.
    Der jetztige Fehler trat dann erst nach 1-2 Tagen auf.
     
  14. Azrael_0815

    Azrael_0815 Well-Known Member

    Registriert seit:
    7. Juli 2015
    Beiträge:
    574
    Zustimmungen:
    32
    Hast Du die URLs auch in der DB geändert oder nur in der wp-config?
     
  15. Oli89

    Oli89 Member

    Registriert seit:
    8. Februar 2017
    Beiträge:
    17
    Zustimmungen:
    0
    Ich habe sie nur in der WP-Config geändert.
    Wo müsste ich diese denn in der DB finden?
     
  16. Azrael_0815

    Azrael_0815 Well-Known Member

    Registriert seit:
    7. Juli 2015
    Beiträge:
    574
    Zustimmungen:
    32
    Nimm ein Plugin wie "Better Search Replace". Und probiere mal, was passiert, wenn Du Deine htaccess testweise löscht (Dinge wie AddHandler natürlich drin lassen).
     
  17. Oli89

    Oli89 Member

    Registriert seit:
    8. Februar 2017
    Beiträge:
    17
    Zustimmungen:
    0
    Also in der Datenbank bei den WP-Options ist "siteurl = https://aquarienmagazin.com" denke das sieht doch gut aus oder?
    Zumal der Zugriff auf die eigentliche Webseite ja funktiniert, nur eben nicht auf die WP-login.
    Gibts es zu der auch nen seperaten Eintrag in der DB?
     
  18. Azrael_0815

    Azrael_0815 Well-Known Member

    Registriert seit:
    7. Juli 2015
    Beiträge:
    574
    Zustimmungen:
    32
    Es gibt zig Einträge mit der URL, also nutze sowas wie das von mir genannte Plugin, sonst wirst Du nie alle finden :)

    Und denk dran, die htaccess zu löschen.

    Und deaktivier mal das SimpleSSL-Plugin.
     
  19. Oli89

    Oli89 Member

    Registriert seit:
    8. Februar 2017
    Beiträge:
    17
    Zustimmungen:
    0
    Bin mir gerade nur nicht sicher wie ich das mit dem Plugin machen soll.
    Ich meine ich kann es ja noch per FTP hochladen, aber ohne Zugriff auf das Wordpress kann ich dieses doch nicht starten oder?
    Sorry, aber kenne mich in der Richtung nicht besonders gut aus:(
     
  20. Azrael_0815

    Azrael_0815 Well-Known Member

    Registriert seit:
    7. Juli 2015
    Beiträge:
    574
    Zustimmungen:
    32
    Per FTP den Plugin -Ordner des Plugins umbenennen in zB SimpleSSL_old (es wird dann deaktiviert) und dann mal schauen.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden