1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Gabis Wordpress Theme - Problem mit <br>

Dieses Thema im Forum "Design" wurde erstellt von casagrande, 24. Februar 2009.

  1. casagrande

    casagrande Well-Known Member

    Registriert seit:
    25. Oktober 2008
    Beiträge:
    95
    Zustimmungen:
    0
    Ich verwende Gabis Wordpress Theme, so heisst das zumindest mein ich. Das Problem ist, wenn ich einen Beitrag erstelle, irgendwie jeder Leerzeile ignoriert wird und ich so nirgends einen Absatz machen kann. Auch wenn ich im HTML Modus direkt <br> eingebe wird es nicht übernommen. Bzw. es wird beim schreiben übernommen wenn ich es dann aber veröffentliche nicht. Jemand ne Idee?
     
  2. copernica

    copernica Well-Known Member

    Registriert seit:
    20. Oktober 2005
    Beiträge:
    319
    Zustimmungen:
    0
    Hallo casagrande,

    welches meiner Themes nutzt du denn?
     
  3. Socke

    Socke Active Member

    Registriert seit:
    22. Februar 2009
    Beiträge:
    44
    Zustimmungen:
    0
    Ich vermute mal, dass Gabi ihre Templates alle gleich aufbaut. Such diese Stelle:

    /*--- | Inhaltsbereich - allgemeing&uuml;ltige Formatierungen |---*/

    Und füge darunter das ein:

    PHP:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!

    Die Zahl kannst du variieren, je nach dem, wie hoch die den Abstand haben willst.
     
  4. casagrande

    casagrande Well-Known Member

    Registriert seit:
    25. Oktober 2008
    Beiträge:
    95
    Zustimmungen:
    0
    streetlife heisst das Theme. @Socke, der Wert die Zeile hab ich in der css gefunden, jedoch ist der Wert für den Zeilenabstand zuständig nicht für die Absätze...Mein Problem ist, dass ich meine Leerzeilen (<br>) nach dem Veröffentlichen immer weg sind, sprich aus:

    Hallo

    du da.

    wird

    Hallo
    du da.
     
  5. telekommander

    telekommander Well-Known Member

    Registriert seit:
    3. August 2005
    Beiträge:
    1.140
    Zustimmungen:
    0
    Wenn das so aussieht, ist aber ein Zeilenumbruch drin:
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Der Quellcode sollte dann so aussehen:
    HTML:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    ... oder hab ich was nicht kapiert?
     
  6. casagrande

    casagrande Well-Known Member

    Registriert seit:
    25. Oktober 2008
    Beiträge:
    95
    Zustimmungen:
    0
    ja theoretisch hast du recht, dann muss ich es umformulieren, leerzeilen verschwinden immer.
    witziger weise zeigt der editor unter der html ansicht gar keine <br> an
    mein code sieht z.b so aus
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    wird dann so dargestellt
    Zur Auswahl stehen:
    James Bond 007 - Casino Royal
    Der Patriot
    Into the Blue

    <br> die ich manuell im html modus eintrage verschwinden nach der veröffentlichung, wenn ich jedoch den Artikel mit Windows Live Writer überarbeite, bekomm ich Absätze rein, wenn ich dann wieder den gleichen Artikel mit WP überarbeite sind die Absätze nachm spiechern wieder verschwunden...??
     
  7. telekommander

    telekommander Well-Known Member

    Registriert seit:
    3. August 2005
    Beiträge:
    1.140
    Zustimmungen:
    0
    WP Einstellungen mal prüfen.
    Unter Einstellungen > Schreiben:
    "WordPress soll falsch verschachteltes XHTML automatisch korrigieren." Mal den Haken der Checkbox entfernen, falls da einer stehen sollte. Dann nochmals testen.

    ... ist aber geraten.

    Generell würde ich aber vom Live-Writer abraten. (pers. Meinung)
     
  8. casagrande

    casagrande Well-Known Member

    Registriert seit:
    25. Oktober 2008
    Beiträge:
    95
    Zustimmungen:
    0
    ne, haken war nicht gesetzt, geht aber auch mit und ohne häckchen nicht :( live writer nutz ich sonst auch nicht, nur um Absätze zu machen :)
     
  9. telekommander

    telekommander Well-Known Member

    Registriert seit:
    3. August 2005
    Beiträge:
    1.140
    Zustimmungen:
    0
    ... jetzt steh ich auf'm Schlauch.
    Werden die <br /> zu <p> ?
     
  10. casagrande

    casagrande Well-Known Member

    Registriert seit:
    25. Oktober 2008
    Beiträge:
    95
    Zustimmungen:
    0
    wenn ich von visuell auf html umswitche ist das einzige html code mäßige was ich sehe die <strong></strong>, keine <p> keine <br>, nischt, als würde der editor das was ich im Visuell Modus mache nicht übernehmen
     
  11. telekommander

    telekommander Well-Known Member

    Registriert seit:
    3. August 2005
    Beiträge:
    1.140
    Zustimmungen:
    0
    Dann wirf mal einen Blick in den Quellcode der Vorschau deines WP-Posts.
    Was der Editor macht ist mir Wurscht.
     
  12. casagrande

    casagrande Well-Known Member

    Registriert seit:
    25. Oktober 2008
    Beiträge:
    95
    Zustimmungen:
    0
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    vielleicht is das der fehler das er immer <br /> macht nur wo könnte ich das auf <br> ändern?
     
  13. telekommander

    telekommander Well-Known Member

    Registriert seit:
    3. August 2005
    Beiträge:
    1.140
    Zustimmungen:
    0
    Nein, das ist kein Fehler. Das ist XHTML.

    Sieht so aus, dass dein Fehler gar keiner ist.
    Zwei aufeinanderfolgende <br /> werden WP-Intern in ein <p> umgewandelt.
     
  14. casagrande

    casagrande Well-Known Member

    Registriert seit:
    25. Oktober 2008
    Beiträge:
    95
    Zustimmungen:
    0
    und wie bekomm ich dann ne leerzeile irgendwo rein, bei meinem anderen blog kann ich <br> so viele machen wie ich will und ich hab dann halt zig leerzeilen :confused:
     
  15. Socke

    Socke Active Member

    Registriert seit:
    22. Februar 2009
    Beiträge:
    44
    Zustimmungen:
    0
    Tut mir Leid, ich hab den falschen Coden reinkopiert.

    Ich nutze auch das Streetlife-Theme und habe es angepasst, so dass Absätze erkannt werden.

    PHP:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Das fügst du ganz am Anfang des Stylesheets bei den Dateiweiten Einstellungen ein - sollte jetzt auch der richtige Code sein :mrgreen:

    Alternativ kann man das auch jedesmal manuell regeln und im ein Editor
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    in jede Leerzeile setzen; das ist auf Dauer nur etwas anstrengend.
     
    #15 Socke, 25. Februar 2009
    Zuletzt bearbeitet: 25. Februar 2009
  16. casagrande

    casagrande Well-Known Member

    Registriert seit:
    25. Oktober 2008
    Beiträge:
    95
    Zustimmungen:
    0
    jo, das wars. danke für die ganze hilfe :D
     
  17. Socke

    Socke Active Member

    Registriert seit:
    22. Februar 2009
    Beiträge:
    44
    Zustimmungen:
    0
    Kein Problem :)
     
  18. lesen

    lesen Active Member

    Registriert seit:
    12. Juni 2008
    Beiträge:
    39
    Zustimmungen:
    0
    Das klappt, aber leider nur in reinen Textabschnitten. Problematisch ist es, wenn Bilder von Text umflossen werden, da kann man keine Leerzeilen machen. Weiß jemand eine Lösung?
     
  19. alex123

    alex123 Well-Known Member

    Registriert seit:
    4. Juni 2009
    Beiträge:
    70
    Zustimmungen:
    0
    ich versuchs nochmal an dieser stelle:

    das problem laesst sich zwar loesen, wenn man immer schoen in der html ansicht arbeitet aber was macht ein user der NUR mit der visuellen Ansicht arbeiten kann und kein html kann?

    jemand eine idee?

    danke!
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden