1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Geschütze Beiträge kommen per RSS

Dieses Thema im Forum "Allgemeines" wurde erstellt von G-Hirn, 20. Juli 2006.

  1. G-Hirn

    G-Hirn Member

    Registriert seit:
    20. Juli 2006
    Beiträge:
    10
    Zustimmungen:
    0
    Hi Leute!

    habe mit der Suchfunktion hier nichts gefunden.

    WP Version 2.0.3 / Opera 8.54 Newsfeeds
    Alle Beiträge kommen per RSS an. Auch Passwortgeschützte Beiträge.
    Das kann doch nicht in Ordnung sein.
    Kennt jemand eine Lösung?

    Gruß
     
  2. addyy

    addyy Well-Known Member

    Registriert seit:
    28. Mai 2006
    Beiträge:
    50
    Zustimmungen:
    0
    gleiches Problem

    hab das gleiche Problem, mußte RSS völlig rausnehmen.
     
  3. daniel

    daniel Member

    Registriert seit:
    6. Januar 2006
    Beiträge:
    20
    Zustimmungen:
    0
    gib mal den rrs-feed-link und bei welchem beitrag tritt das "problem" auf.
     
  4. G-Hirn

    G-Hirn Member

    Registriert seit:
    20. Juli 2006
    Beiträge:
    10
    Zustimmungen:
    0
    Hi,
    ich möchte aber RSS nicht rausnehmen. Es muss doch noch einen anderen Weg geben. Also:

    Wer hat Ahnung davon?
    Wo könnte der Fehler sein?
    Was muss geändert werden?

    Gruß
     
  5. G-Hirn

    G-Hirn Member

    Registriert seit:
    20. Juli 2006
    Beiträge:
    10
    Zustimmungen:
    0
    Habe den angeblichen "Fehler" gefunden.

    Also mit Opera passiert folgendes.
    Wenn ich den Link "Feed for posts" anklicke kommen alle Beiträge normal in den Feed-Posteingang. Der Beitrag der Passwortgeschützt ist kommt nicht. Nur eine Info das er eben geschützt ist. Sobald man nun aber in dem Beitrag das Passwort eingibt und dann auf "Feed for posts" klickt wird der geschützte Beitrag mit übermittelt.

    Na gut, im nachhinein betrachtet ist das ja auch logisch. Aber wenn man nicht daran denkt das man das Passwort schon eingegeben hat schaut man erst mal doof daher. So wie ich eben. Das ganze habe ich gerade eben mitbekommen als ich das Passwort geändert habe.

    Entschuldigung für den Lärm den ich hier gemacht habe.

    Gruß
     
  6. addyy

    addyy Well-Known Member

    Registriert seit:
    28. Mai 2006
    Beiträge:
    50
    Zustimmungen:
    0
    Problem existiert trotzdem

    hab das Problem aber trotzdem.
    Meine Seiten sind mit category access geschützt.
    Per rss konnte man allerdings trotzdem alles sehen, also mußt ich das stilllegen. Ist natürlich nicht die Lösung

    Gruß addyy
     
  7. RehaugeW

    RehaugeW Well-Known Member

    Registriert seit:
    25. November 2005
    Beiträge:
    72
    Zustimmungen:
    0
    Einmal up.
    Was kann man dagegen tun? Das Problem besteht weiterhin. Sobald ich ein passwortgeschützten Beitrag online stelle, erscheint er ohne Schutz im Feed.
    Wer kann helfen?
     
  8. jottlieb

    jottlieb Well-Known Member
    Ehrenmitglied

    Registriert seit:
    20. August 2005
    Beiträge:
    17.381
    Zustimmungen:
    0
    Als erstes solltest du auf eine aktuelle WP-Version updaten.
    Evtl. löst das dein Problem.
     
  9. RehaugeW

    RehaugeW Well-Known Member

    Registriert seit:
    25. November 2005
    Beiträge:
    72
    Zustimmungen:
    0
    Also wenn mein WP noch aktueller wäre, würde ich bei WP sitzen und die nächste Version entwickeln. :mrgreen:

    Kann es eventuell mit dem Copyrightfeed zusammenhänge`n? Anscheinend hat es auch mit der Volltextanzeige zu tun. Scheint mir jedenfalls.
     
  10. RehaugeW

    RehaugeW Well-Known Member

    Registriert seit:
    25. November 2005
    Beiträge:
    72
    Zustimmungen:
    0
    Und weiß keiner Rat????
     
  11. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.823
    Zustimmungen:
    1
    Geschützte Beiträge erscheinen bei mir auch im Feed, aber nur der Titel (mit "Geschützt:" davor) mit dem Link zum Artikel und darunter steht:
    "Es gibt keine Kurzfassung, da dies ein geschützter Beitrag ist."

    Sollen die denn ganz aus dem Feed verschwinden?
    Dann wird man das wohl programmieren müssen...

    Gruß
    Ingo
     
  12. RehaugeW

    RehaugeW Well-Known Member

    Registriert seit:
    25. November 2005
    Beiträge:
    72
    Zustimmungen:
    0
    Bei mir erscheinen die geschützten Beiträge komplett. Jeder Buchstabe ist lesbar. Und das kann nicht der Sinn von einem Passwortschutz sein, dass man den Beitrag ohne Passwort im Feed lesen kann oder? Sogar auf privat gesetzte Beiträge sind vollkommen lesbar im Feed.
     
  13. jottlieb

    jottlieb Well-Known Member
    Ehrenmitglied

    Registriert seit:
    20. August 2005
    Beiträge:
    17.381
    Zustimmungen:
    0
    Bei mir nicht.
    WP 2.2.1 DE.
     
  14. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.823
    Zustimmungen:
    1
    Werden denn die geschützten bzw. privaten Artikel wenigstens im Adminbereich (Verwalten->Beiträge) als solche angezeigt? Bei mir sieht das dann so aus:
    Geschützt: Titel des Artikels
    Auf privat setzen: Titel des Artikels - privat

    Kann aber auch sein, daß der Feedreader die Änderung nicht mitbekommen hat, falls die Artikel vorher nicht geschützt oder privat waren. WP sieht das nicht als Änderung an und sendet daher den Status "304 Not Modified", falls sich sonst nicht inhaltlich etwas geändert hat, so das gar keine neuen Daten übertragen werden.
    Eventuell mal das Neulesen erzwingen, beim Firefox z.B. mit [Shift]+Reloadbutton.

    Ansonsten würde ich mal wieder auf irgendein Plugin tippen, welches dieses Verhalten hervorruft.

    Gruß
    Ingo
     
  15. RehaugeW

    RehaugeW Well-Known Member

    Registriert seit:
    25. November 2005
    Beiträge:
    72
    Zustimmungen:
    0
    Die Artikel waren von Anfang an auf Passwort gesetzt. Ich setze meist einen leeren Beitrag online ein, schütze ihn dabei mit Passwort und editiere ihn im Anschluss mit Blogdesk. Aber auch komplett frisch geschriebene geschützte Beiträge werden bei Online schreiben auch sichtbar. Und ja sie werden als geschützt bzw. privat angezeigt.
    WP Version ist aktuellste.
     
  16. RehaugeW

    RehaugeW Well-Known Member

    Registriert seit:
    25. November 2005
    Beiträge:
    72
    Zustimmungen:
    0
    Anscheinend weiß niemand rat. :(
     
  17. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.823
    Zustimmungen:
    1
    Ja wie ich oben schon angedeutet habe, wenn irgendwas nicht so funktioniert, wie es von WP eigentlich vorgesehen ist, dürfte meist irgendein Plugin die Finger im Spiel haben.

    Außerdem wird das Passwort auch als Cookie gespeichert. Einmal eingegeben, bleibt es erstmal aktiv.

    Gruß
    Ingo
     
  18. neals

    neals Well-Known Member

    Registriert seit:
    26. September 2006
    Beiträge:
    80
    Zustimmungen:
    0
    vielleicht das FeedBurner Plugin

    Da ich früher schon ab und an von solchen Problemen gehört hatte, habe ich prophylaktisch erstmal einen Test gewagt und auch bei mir taucht das Problem auf.

    Direkt auf dem Blog funktioniert alles wie vorgesehen, aber anscheinend wird im Feed alles angezeigt ... in meinem Operabrowser bin ich weder in den WP-Admin eingeloggt noch habe ich dort irgendein Passwort für die Artikel eingegeben und doch wird dort der Textinhalt angezeigt.

    Mein Verdacht fällt auf das FeedBurner FeedSmith Plugin, aber heute komme ich nicht mehr dazu das auszutesten.

    Hat jemand vielleicht den Übeltäter schon identifizieren können?
     
  19. florox

    florox Member

    Registriert seit:
    10. Juli 2005
    Beiträge:
    8
    Zustimmungen:
    0
    Cookies löschen

    Ich habe mich zuerst auch erschrocken, als nach dem Logout der Feedreader noch die auf privat gesetzten Beiträge gelesen hat. Das hatte sich aber in dem Augenblick gelegt, in dem ich die Cookies gelöscht habe. Allerdings benutze ich 2.2.2 und dabei kein Plugin, dass etwas mit dem RSS-Feed zu tun hat.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden