1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Google Snippets: URL der Unterseiten haben .php Anhang

Dieses Thema im Forum "Konfiguration" wurde erstellt von babsi1b, 11. Juli 2018.

  1. babsi1b

    babsi1b Member

    Registriert seit:
    6. März 2013
    Beiträge:
    10
    Zustimmungen:
    0
    Ich stehe vor einem Problem, dass ich so noch nicht gehabt habe. In den Google Snippets werden die Unterseiten einer Website mit der URL plus einem .php ausgegeben. Klickt man auf den Link, erzeugt das natürlich einen 404 error.

    Mein Verdacht: Ich habe WPML aktiviert und eingerichtet, es gibt aber noch keine übersetzten Seiten (der Kunde lässt sich damit Zeit). Und in der Search Console sind die meisten Seiten, die als Crawling-Fehler angezeigt werden, solche mit einem /en/ Anhang.

    Ich habe jetzt mal WPML deaktiviert. Im nächsten Schritt würde ich die Website inkl. Unterseiten neu bei Google einreichen.

    Trotzdem interessiert mich: Hat schon mal jemand diesen Fehler gehabt und wenn ja, was war die Ursache?

    Es geht um die Seite https://www.austrianregistrars.at

    Hier der Link zur Google-Suche: https://www.google.at/search?q=austrian+registrars&rlz=1C5CHFA_enAT786AT787&oq=aus&aqs=chrome.1.69i57j69i59j69i60j69i59j69i60l2.4045j0j8&sourceid=chrome&ie=UTF-8
     
  2. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    6.539
    Zustimmungen:
    592
    Es handelt sich um alte Links aus der alten Seite (vor der Nutzung von WordPress).

    WPML nutzt /en/ oder ?lang=en aber nie ?Lg=EN o.ä.

    Wie genau lautet ein Link mit /en/ bei Google, der eine .php Endung hat?
     
  3. babsi1b

    babsi1b Member

    Registriert seit:
    6. März 2013
    Beiträge:
    10
    Zustimmungen:
    0
    Vielen Dank für dein Feedback!

    Ich hab noch einmal nachgesehen: Es gibt gar keine Links mit den WPML typischen Endungen, also sind es wohl doch alles Links aus der alten Seite.

    Und ich bin auch drauf gekommen, warum Google die alten Links in den Suchergebnissen anzeigt. Ich habe die Indexierung irrtümlicherweise gemacht, als noch die "Coming Soon Page" aktiv war. Das ist mir auch noch nie passiert. Hab die Seite jetzt neu indexiert und jetzt sollte es funktionieren.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden