1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Neuinstallation Hilfe bei Installation unter Ubuntu 13.10

Dieses Thema im Forum "Installation" wurde erstellt von fraglosfragenreich, 12. Mai 2014.

  1. fraglosfragenreich

    Registriert seit:
    12. Mai 2014
    Beiträge:
    23
    Zustimmungen:
    0
    Hallo zusammen,

    ich bin WP-Frischling und verzweifle gerade an der Installation unter Ubuntu 13.10. Meine Vermutung ist, dass irgendetwas beim Aufsetzen der Datenbanken schief gelaufen ist.

    Ich habe die folgende Installationsanleitung http://mkpotluri.wordpress.com/2014/03/09/installing-and-configuring-wordpress-on-ubuntu-13-10-server/ befolgt und scheitere an dem Schritt, dass mir im Browserfenster WP nicht angezeigt wird. Auf "sudo service apache2 restart" erhalte ich:

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Der localhost bzw 127.0.1.1 lassen sich nicht öffnen.

    Hab daher noch mal versicht LAMP zu installieren (http://ubuntuhandbook.org/index.php/2013/10/install-lamp-ubuntu-13-10-server/). Installation läuft bzw. es war schon alles auf dem neusten Stand. Dennoch läuft die Datenbank nicht. Bei http://localhost/info.php erhalte ich die Fehlermeldung:
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Vermutlich ist die Fehlerbehebung gaaanz einfach und ich steh wie ein Ochse vorm Berg.
    Hat jemand eine Idee, wie ich die Datenbank ans Laufen bekomme?

    Viele Grüße
     
  2. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.967
    Zustimmungen:
    8
    Schau mal in die /etc/hosts, ob dort u.a.

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    drin steht. Du kannst erst mal das in die /etc/apache2/httpd.conf schreiben

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
     
  3. fraglosfragenreich

    Registriert seit:
    12. Mai 2014
    Beiträge:
    23
    Zustimmungen:
    0
    Danke für die Antwort, Hille,

    also erstes ist eingetragen.
    Und die Datei /etc/apache2/httpd.conf gibt es bei mir gar nicht. Müsste es die geben??
     
  4. Melewo

    Melewo Well-Known Member

    Registriert seit:
    8. Juli 2013
    Beiträge:
    3.097
    Zustimmungen:
    0
    Lese ich heute zum ersten Mal, doch ich kenne ja auch nur das was bei mir innerhalb vom Xampp liegt:

    http://forum.ubuntuusers.de/topic/httpd.conf-oder-apache2.conf/
     
  5. fraglosfragenreich

    Registriert seit:
    12. Mai 2014
    Beiträge:
    23
    Zustimmungen:
    0
    Danke, ja Ubunuusers kenne ich. Leider helfen mir die Informationen nicht, die Verbindung herzustellen. Ich weiß nicht, wo das konkrete Problem liegt. Das eintragen des Localhosts verhindert die Fehlermeldung, die ich aber im Worst Case auch einfach ignorieren könnte. Das Hauptproblem ist die Verbindung. :(
     
  6. Melewo

    Melewo Well-Known Member

    Registriert seit:
    8. Juli 2013
    Beiträge:
    3.097
    Zustimmungen:
    0
    Du hast doch nicht nur ein Problem, wie es mir erscheint. Ich habe keine Ahnung von Ubuntu, doch ob die Datenbank läuft oder nicht läuft, sollte doch eigentlich das letzte Problem sein. Vorher solltest Du es doch zumindest erst einmal schaffen, eine ganz einfache index.html aufzurufen. Erst wenn dieser Schritt geschafft ist, eine info.php und dann erst eine einfache seite.php mit einer Verbindungskontrolle zur Datenbank. Wenn das dann alles in diesen drei Schritten geschafft ist, dann wäre der richtige Zeitpunkt um WP aufzusetzen, jedoch nicht früher.

    Oder schaue Dir ein Video an, davon gibt es reichlich viele:

    http://www.youtube.com/results?search_query=lamp+ubuntu
     
    #6 Melewo, 13. Mai 2014
    Zuletzt bearbeitet: 13. Mai 2014
  7. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.967
    Zustimmungen:
    8
    Stimmt, seit Apache 2.2 scheint es die nicht mehr zu geben. Du kannst dies auch unter /etc/apache2/sites-available/000-default.conf eintragen. Nicht vergessen, die Datei zu aktivieren (falls nicht schon geschehen)

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Ob die Dienste laufen kannst du per netstat sehen

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Dort müsste was mit apache2 stehen

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Dort müsste was mit mysqld stehen. Sollte dies so sein, laufen die Dienste bzw. sind falsch konfiguriert.

    Generell ist Ubuntu 13.10 eine Desktop Version. In wie weit diese Version für Server-Dienste geeignet ist, kann ich nicht sagen. Besser wäre in deinem Fall Ubuntu 12.04 LTS oder 14.04 LTS.

    Was erscheint denn bei

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
     
    #7 Hille, 13. Mai 2014
    Zuletzt bearbeitet: 13. Mai 2014
  8. Melewo

    Melewo Well-Known Member

    Registriert seit:
    8. Juli 2013
    Beiträge:
    3.097
    Zustimmungen:
    0
    Bei mir läuft ein Apache/2.2.21 (Win32) unter Localhost und der hat noch eine httpd.conf und keine apache2.conf, deshalb war mir das neu.
     
  9. fraglosfragenreich

    Registriert seit:
    12. Mai 2014
    Beiträge:
    23
    Zustimmungen:
    0
    Danke für die Antworten.
    Also, bei sudo netstat -tulpe | grep apache2 erhalte ich

    und bei sudo netstat -tulpe | grep mysql
    Bei http://localhost tut sich leider nix. Seite öffnet sich nicht. Keine Fehlermeldung...

    Was heißt das für mich im Klartext?
     
  10. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.967
    Zustimmungen:
    8
    Das die Dienste gestartet sind. Gib mal die Ausgabe von folgenden Sachen:

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
     
  11. fraglosfragenreich

    Registriert seit:
    12. Mai 2014
    Beiträge:
    23
    Zustimmungen:
    0
    Dankeschön.
    So, ich hab meine Distribution aktualisiert. Das Problem steht nach wie vor.
    Das sind die Ausgaben:
    sudo nslookup localhost
    sudo cat /etc/apache2/apache2.conf
    sudo cat /etc/apache2/ports.conf
    sudo cat /etc/apache2/sites-available/000-default.conf
    sudo ls /etc/apache2/sites-enabled
    Ich muss gestehen, dass mir immer noch nicht ganz klar ist, wo das Problem liegt bzw. wie ich es beheben kann.
    Any ideas?
     
  12. B-52

    B-52 Well-Known Member

    Registriert seit:
    16. März 2008
    Beiträge:
    1.092
    Zustimmungen:
    0
    das kann ja so nicht funktionieren!
    Wieso in aller Welt installierst Du über die Pakete apche2 und mysql-server eine Xammp Version? Logisch, dass hier Ubuntu steikt... Entferne doch die installerten Pakete und versuche es nochmals über Xampp.

    Gruss B-52
     
  13. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.967
    Zustimmungen:
    8
    Das hatte ich gar nicht so recht gelesen. Ja, entferne mal eines von beiden z.B. lampp.

    Ist das tatsächlich bei dir so? Im Normalfall ist es /var/www

    Gib mal folgendes noch ein

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
     
  14. B-52

    B-52 Well-Known Member

    Registriert seit:
    16. März 2008
    Beiträge:
    1.092
    Zustimmungen:
    0
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    das scheint korrekt zu sein. Bei Debian Jessie verweist dies neu ebenfalls auf diesen Pfad. Denke, Ubuntu tickt hier gleich wie Debian...

    LG B-52
     
  15. g3h

    g3h Well-Known Member

    Registriert seit:
    25. Juni 2013
    Beiträge:
    661
    Zustimmungen:
    0
    #15 g3h, 16. Mai 2014
    Zuletzt bearbeitet: 16. Mai 2014
  16. fraglosfragenreich

    Registriert seit:
    12. Mai 2014
    Beiträge:
    23
    Zustimmungen:
    0
    Danke. Hoffe, ich/wir nähern uns der Lösung des Problems :wink:

    Habe Lamp deinstalliert. Und dann "a2dissite domain.de" in die Konsole eingegeben. Bekam die Meldung
    Bin dann davon ausgegangen, dass Apache scheinbar mit LAMP deinstalliert worden ist. Habe also Apache2 wieder installiert und bekam folgendes:

    Scheinbar geht nu noch weniger als vorher, oder?

    Beim Reloaden gabs dann das:

    Und das ist der Error Log

    Hmmm :???:
     
  17. B-52

    B-52 Well-Known Member

    Registriert seit:
    16. März 2008
    Beiträge:
    1.092
    Zustimmungen:
    0
    sei mir nicht böse, aber was genau wurstelst Du da? WP lokal unter einer Debian basierten Distribution zum Laufen zu bringen, ist eine Sache von 15 Minuten. Guckst Du hier

    eine Fehlermeldung ist normalerweise da, um gelesen und angewendet zu werden ;)
     
  18. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.967
    Zustimmungen:
    8
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
     
  19. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.967
    Zustimmungen:
    8
    Möglich. Muß der TS einfach mal schauen, ob dies wirklich sein DocumentRoot ist.
     
  20. fraglosfragenreich

    Registriert seit:
    12. Mai 2014
    Beiträge:
    23
    Zustimmungen:
    0
    Hallo,

    ich hab mein System auf 14.04 geupdated. Da dabei einiges nicht rund gelaufen ist, habe ich den Rechner platt gemacht und alles neu installiert. Bei der Installtion von phpmyadmin habe ich allerdings geschlafen und vorschnell die Einstellung gewählt, dass es nicht über dbconfig-common koniguriert werden soll. Hab phpmyadmin bereits deinstalliert und neusintalliert, dabei kommen die Dialogfenster leider nicht nochmal, scheinbar werden die Einstellungen von der ersten Installtion übernommen.
    Entsprechend habe ich kein Passwort vergeben und bei "http://localhost/phpmyadmin" bekomme ich die Fehlermeldung
    Localhost also Apache2 funktionieren. Da ich nun nicht weiter munter deinstallieren und neuinstallieren möchte, frag' ich mal lieber gleich nach Rat und lasse lieber Vorsicht als Nachsicht walten.

    Vielen Dank für Eure Geduld. ;)
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden