1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

hilfe! permalink struktur bearbeitet und jetzt 403!

Dieses Thema im Forum "Konfiguration" wurde erstellt von eyetag, 12. Mai 2005.

  1. eyetag

    eyetag Well-Known Member

    Registriert seit:
    1. April 2005
    Beiträge:
    98
    Zustimmungen:
    0
    bionic, irgendwelche erkentnisse aus unserem kleinen test?
     
  2. hijacker666

    hijacker666 Well-Known Member

    Registriert seit:
    22. April 2005
    Beiträge:
    77
    Zustimmungen:
    0
    hm .. eigentlich schon ... aber warte mal ...

    bahe ... *grml*

    wieso gehen die permalinks wenn ich sie mit dem alten verzeichnis versehe ??

    das /blog/ war mein früherers verzeichnis .. so gehen sie nämlich aber wenn ich das weglasse gehen sie nimmer :shock: :?

    ich mein im grunde ist es mir so auch ned unrecht da ich die bisher vorhanden google ergebnisse weiterhin behalten kann aber trotzdem würds mich intressieren wo er das /blog/ herbekommt ?? die URL´s habe ich ja schon alle geändert oder steht da in der MySQL Datenbank nochwas :?

    2 Dinge habe ich aber doch noch schaut mal auf meine Seite www.xtase.net wenn ihr ganz unten auf Link "Vorherige Artikel" klicken wollt und wenn ihr rechts oben den Link "xtBlog-Eintrag senden" anklickt ... die gehen nicht, wie bekomme ich denn das hin ??
     
  3. suedkind

    suedkind Well-Known Member

    Registriert seit:
    5. Oktober 2004
    Beiträge:
    1.665
    Zustimmungen:
    0
    mmh ... sieht so aus, als ob das mod_rewrite nicht nutzen darfst, ich würde das mal bei deinem support erfragen
     
  4. Bionic

    Bionic Well-Known Member

    Registriert seit:
    24. April 2005
    Beiträge:
    197
    Zustimmungen:
    0
    @eyetag,
    so wie suedkind grade eben geschrieben hat, vermute ich es auch. Dein PHP hat zwar das Modul geladen, nur zum Laufen kommt es irgendwie nicht, was mir ehrlich gesagt sehr rätselhaft ist. Eine Anfrage beim Support könnte dir evt. weiterhelfen, einen Versuch ist es wert.

    @hijacker666,
    bei dir haben sich nur die URL`s verändert? Wie sahen sie vorher aus und wie sehen sie jetzt aus?
    Normalerweise müsste WP die Permalinks automatisch anpassen, sprich die RewriteBase müsste dann anders aussehen.

    Bionic
     
  5. hijacker666

    hijacker666 Well-Known Member

    Registriert seit:
    22. April 2005
    Beiträge:
    77
    Zustimmungen:
    0
    ja die URL´s haben sich geändert ...

    vorher www.xtase.net/blog
    jetzt www.xtase.net

    Die Rewrite Base schaut eh anders aus jetzt ist halt nur ein "/" drinnen ... das stimmt ja eh aber ich bekomm die beiträge über permalinks nicht zum laufen wenn ich nicht das /blog/ davorstelle ...

    ich hab keine idee mehr wo ich da noch rumspielen kann und jetzt wo man auf "ältere beiträge" und auf zusätzlich erzeugte seiten auch nimmer zurückgreifen kann ist das chaos perfekt ... :shock: :D
     
  6. Bionic

    Bionic Well-Known Member

    Registriert seit:
    24. April 2005
    Beiträge:
    197
    Zustimmungen:
    0
    Evt. hilft dir dieser Beitrag etwas:
    http://wordpress.org/docs/installation/different-address/

    Leider hat das einen kleinen Nachteil, es wird bei jedem Artikel, denn du erstellst keinen "Bearbeiten" Link mehr geben. Aber sofern dann alle Posts gehen sollten, ist das ein Manko, welches man sicherlich hinnehmen kann ;)
    Sag bescheid, ob das so klappt.

    Bionic
     
  7. hijacker666

    hijacker666 Well-Known Member

    Registriert seit:
    22. April 2005
    Beiträge:
    77
    Zustimmungen:
    0
    age :shock:

    Ausserdem kann ich das Zeug hinter dem Link gar nicht benutzen. Sowohl meine Daten als meine index.php liegen im root und wenn ich die index.php in den /blog/ lege habe ich auch nix davon dann muss ich meinen Weblog erst recht wieder so aufrufen wie ich vor ner Woche noch hatte und eigentlich nimmer haben will :?

    Das gibts ja nicht, mich würde einzig allein intressieren wo das BLOG rausbekommt das zwar die Permalinks bei den Beiträgen mit /blog/ funktionieren sollen aber wenn ich das /blog weglasse gehts nimmer.

    Schön langsam bereue ich schon das ich den ganzen Weblog von /blog/ in den Root geschoben. Denn bevor ich denn wieder in /blog/ zurückschiebe lösche ich alles und installier neu ... :shock: :?

    Ich hab jetzt mal die Permalinks aufgeschaltet so geht wenigstens alles wieder wie ich es möchte.
     
  8. ratterobert

    ratterobert Well-Known Member
    Ehrenmitglied

    Registriert seit:
    1. Januar 2005
    Beiträge:
    1.237
    Zustimmungen:
    0
    hast du die .htaccess mal in einem editor geöffnet, den gesamten inhalt gelöscht und dann die permalinkstruktur im wordpress aktualisiert?
     
  9. hijacker666

    hijacker666 Well-Known Member

    Registriert seit:
    22. April 2005
    Beiträge:
    77
    Zustimmungen:
    0
    Jep ... :)

    Ergebnis -> "You don't have permission to access /2005/05/12/oesterreich-steigt-ab/ on this server."

    Ich poste jetzt einfach mal die .htaccess die ich nachdem erstellen erhalten...

    und das ist die .htaccess wie sie zumindest bei den permalinks der Beiträge geht ... da habe ich einfach bei den permalinks /blog/ davorgepackt ...

    Gehts euch manchmal auch so das ihr vor so ner Sache hockt und denkt das es eigentlich gehen muss aber irgendwie gehts dann doch nicht ? Nein ? Mir gehts zur Zeit so ich komm einfach ned dahinter wieso der weblog mit einer linkstruktur geht und mit der anderen nicht ... :D
     
  10. hijacker666

    hijacker666 Well-Known Member

    Registriert seit:
    22. April 2005
    Beiträge:
    77
    Zustimmungen:
    0
    So jetzt bin ich schon ein bisschen schlauer geworden aber jetzt seid ihr wieder dran.

    Und zwar gehen die Permalinks bei mir überhaupt nicht wenn man die Dinger auf den Root einstellt. Jetzt meine Frage setzt dieses Permalinkszeug serverseitig irgendwelche Vorrausetzungen voraus, irgendwelche bestimmten CHMODS ??

    Keine Ahnung, die Permalinks gehen wenn ich sie über das Verzeichnis /blog/ laufen lasse aber sobald sie nur xtase.net anwählen sollen habe ich einfach keine Chance das ich die Seite dargestellt bekomme.

    Neuinstallieren hat absolut nix gebracht ...

    Oder gibts zumindest irgendwie ne Chance das ich extra erstellte Seiten oder den Link "vorherige Artikel" anders formatiert bekomme, habe dazu in der .htaccess auch schon was probiert. Keine Chance es ist wirklich zum Auszucken mit dem Ding :roll: :(
     
  11. Bionic

    Bionic Well-Known Member

    Registriert seit:
    24. April 2005
    Beiträge:
    197
    Zustimmungen:
    0
    Gehen die alten Links nur über /blog/ oder auch die neuen Links?
    Hast du probeweise mal einen Artikel nach dem Umstellen erstellt und dann Permalinks versucht?

    Die Permalinks setzen serverseitig nichts an Zugriffsrechten voraus, außer dass die .htaccess Datei beschreibbar ist.
    Bekannt sind allerdings einige Fehlfunktionen mit dem Apache 1.3 und der Permalinksstruktur des WP`s, aber da weiß ich leider auch nichts näheres.
    Bin schon seit Tagen im Supportforum von WP unterwegs und lese mir dort die ganzen Threads bezüglich Permalinks durch. Wie es scheint ist es ein oft auftretendes Problem mit den Dingern.

    Gruß Bionic
     
  12. hijacker666

    hijacker666 Well-Known Member

    Registriert seit:
    22. April 2005
    Beiträge:
    77
    Zustimmungen:
    0
    Es gehen alle Links nur über das /blog/.

    Bei dem Schema gehen die Beitragslinks ...

    und wenn ich die Beitrags-Permalinks so anpasse gehen sie nicht ...

    thats it mehr macht der Unterschied ned aus. Ach doch,nur Problem ist halt das über WP erzeugte Seiten und der Link "vorherige Artikel" durch die .htaccess ned umgewandelt wird. Ich hab keine Ahnung wieso nicht hab schon mal probeweise versucht in die .htaccess den /blog/ dazufügen aber so recht nimmt er es ned an ... :?

    Bevor ich das WP von /blog/ in den Root geschoben habe ist mir die Sache halt ned aufgefallen weil ja die ganzen Links sowieso unter /blog/ liefen und es in dem Falle kontraproduktiv gewesen wäre sie ohne /blog/ umwandeln zu lassen.

    Apache 1.3 oder eine der 1.3er Versionen habe ich ja leider ..
    -> http://www.xtase.net/info.php :D
     
  13. Bionic

    Bionic Well-Known Member

    Registriert seit:
    24. April 2005
    Beiträge:
    197
    Zustimmungen:
    0
    Kannst du mal testweise anstelle des /blog/ in den Permalinks mal /archive/ nehmen?
    Ich habe so eine Vorahnung, dass das auch gehen sollte ;)

    @eyetag,
    frag mal bei deinen Hoster nach ob er folgendes in der httpd.config drinstehen hat
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Sollte das in der Server Konfigurationsdatei nicht drinstehen, sehen die Chancen auf eine funktionierende Permalinksstruktur sehr schlecht bis gar nicht aus.
    Der Effekt dieser Option ist, dass man, falls es aktiviert ist, in jedem Ordner eine eigene .htaccess Datei haben kann. Ist dies nicht gegeben, werden die .htaccess Dateien nicht beachtet.
    Sollte es nicht drin stehen, kannste nachfragen ob er dir die Möglichkeit bieten kann und die Option aktivieren kann. Es muss auch nicht für alle Ordner aktiviert sein, du kann auch für einzelne Ordner die Freigabe von .htaccess Dateien erlauben. Einen Versuch ist es wert ;)

    Bionic
     
  14. hijacker666

    hijacker666 Well-Known Member

    Registriert seit:
    22. April 2005
    Beiträge:
    77
    Zustimmungen:
    0
    Hi !!!

    hm nein geht nicht wenn ich das /blog/ durch /archive/ ersetze ... :?

    Muss demzufolge wohl auch meine Aussage refidieren das die Permalinks mit allen Dingen gehen die man anstatt von /blog/ reinschreibt :(

    Ich vermute einfach noch das der blog von irgendwoher weiss das er den pfad /blog/ braucht um es ordentlich darstellen zu können ... aber ich habe keine ahnung mehr woher. wenn ich den Blog auch mal neu installiert habe kann man ja hoffentlich davon ausgehen das alle früheren sachen weg sind ... :)
     
  15. hijacker666

    hijacker666 Well-Known Member

    Registriert seit:
    22. April 2005
    Beiträge:
    77
    Zustimmungen:
    0
    Um die Sache hier mal abzuschliessen habe ich vor gut 2 Wochen den ganzen Blog wieder auf xtase.net/blog zurückverschoben und belasse es damit ist, ist wohl leider so das es bei meiner Serverkonfiguration unmöglich ist den Blog auf dem root laufen zu lassen :? :)
     
  16. eyetag

    eyetag Well-Known Member

    Registriert seit:
    1. April 2005
    Beiträge:
    98
    Zustimmungen:
    0
    konnte noch nichts weiteres zur mserver konfig beim hoster rausfinden.
    habe das eigenartige problem, dass sich die .htaccess nicht mehr löschen lässt.
    sobald ich nach dem löschen auf die seite gehe, wird eine neue erzeugt, die die ganze die bekannten fehler erzeugt :?
    in der admin in den permalink optionen bleibt außerdem immer der code im eingabefeld bestehen, der die defekte .htaccess erzeugt.

    was kann ich da machen?
    danke!

    et
     
  17. web-junkies

    web-junkies Well-Known Member

    Registriert seit:
    7. Juli 2005
    Beiträge:
    123
    Zustimmungen:
    0
    Das Problem habe ich auch. Ich komme nur noch auf meine Startseite. Sobald ich versuche einen Link anzuklicken, bekomme ich immer die Meldung, dass es diesen nicht gibt. Ich habe sogar die Daten von heute Mittag zurückgespielt. Ich weiss nicht weiter. Ich drehe hier noch durch. Falls jemand eine Idee hat, dann bitte immer her damit.

    Anschauen kann man sich das ganze hier:

    http://www.web-junkies.de

    Edit:

    Ich habe die MySQL-Datenbank gelöscht, umständlich über die Admin-Oberfläche alles gesichert und dann WP neu installiert. Von Permalinks werde ich erstmal die Finger lassen.
     
  18. pufaxx

    pufaxx Well-Known Member

    Registriert seit:
    5. Dezember 2004
    Beiträge:
    503
    Zustimmungen:
    0
  19. hijacker666

    hijacker666 Well-Known Member

    Registriert seit:
    22. April 2005
    Beiträge:
    77
    Zustimmungen:
    0
    Soda ich hab mein Problem wieder mal angegangen, ich mag einfach den Blog nicht mehr unter www.xtase.net/blog/ liegen lassen sondern ich möchte ihn unter www.xtase.net haben, bekomme aber bei den Permalinks wie gehabt den 403er Fehler. Vielleicht kann mir dieses mal wer weiterhelfen ... biiiitte ;)

    Man kann das ganze übrigens jetzt über www.xtase.net/index.php nachvollziehen, wenn man auf einen Beitrag oder auf eine Kategorie klickt.

    Ich hab übrigens noch immer eine 1.5er Version im Einsatz und solange ich das nicht hinbekomme, habe ich auch nicht vor upzudaten ...
     
    #59 hijacker666, 25. August 2006
    Zuletzt bearbeitet: 25. August 2006
  20. backi

    backi Member

    Registriert seit:
    7. Februar 2007
    Beiträge:
    13
    Zustimmungen:
    0
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden