1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

HTTP Fehler beim hochladen von Bildern

Dieses Thema im Forum "Allgemeines" wurde erstellt von hack4life, 24. August 2012.

Schlagworte:
  1. hack4life

    hack4life Member

    Registriert seit:
    24. August 2012
    Beiträge:
    16
    Zustimmungen:
    0
    Wie könnte ich ein höheres memory limit einstellen ?
     
  2. r23

    r23 Well-Known Member

    Registriert seit:
    9. Dezember 2006
    Beiträge:
    5.107
    Zustimmungen:
    142
    Konfiguration von zum Beispiel gd-lib und hier die Erweiterung die für png oder jpg usw....


    bei nur 45M stimmt etwas mit deiner error-Log Konifiguration nicht. mit 45 M hast du leider nicht nur ein ein Bild upload Problem. Deine Bilder sind vermutlich viel zu groß für den kleinen Speicher.

    define('WP_MEMORY_LIMIT', '256M');

    in die wp-config eintragen... evtl. darfst du ja den Wert ändern... Wenn nicht, musst du dich an deinen Provider wenden...
     
  3. r23

    r23 Well-Known Member

    Registriert seit:
    9. Dezember 2006
    Beiträge:
    5.107
    Zustimmungen:
    142
    Besorge dir einen neuen Viren Scanner und prüfe den "anderen PC".

    Welchen Browser verwendst du? Welches Betriebsystem?
     
  4. hack4life

    hack4life Member

    Registriert seit:
    24. August 2012
    Beiträge:
    16
    Zustimmungen:
    0
    Konfiguration:
    [TABLE="width: 600"]
    [TR]
    [TD="class: e"]GD Support [/TD]
    [TD="class: v"]enabled [/TD]
    [/TR]
    [TR]
    [TD="class: e"]GD Version [/TD]
    [TD="class: v"]bundled (2.0.34 compatible) [/TD]
    [/TR]
    [TR]
    [TD="class: e"]FreeType Support [/TD]
    [TD="class: v"]enabled [/TD]
    [/TR]
    [TR]
    [TD="class: e"]FreeType Linkage [/TD]
    [TD="class: v"]with freetype [/TD]
    [/TR]
    [TR]
    [TD="class: e"]FreeType Version [/TD]
    [TD="class: v"]2.2.1 [/TD]
    [/TR]
    [TR]
    [TD="class: e"]GIF Read Support [/TD]
    [TD="class: v"]enabled [/TD]
    [/TR]
    [TR]
    [TD="class: e"]GIF Create Support [/TD]
    [TD="class: v"]enabled [/TD]
    [/TR]
    [TR]
    [TD="class: e"]JPEG Support [/TD]
    [TD="class: v"]enabled [/TD]
    [/TR]
    [TR]
    [TD="class: e"]libJPEG Version [/TD]
    [TD="class: v"]6b [/TD]
    [/TR]
    [TR]
    [TD="class: e"]PNG Support [/TD]
    [TD="class: v"]enabled [/TD]
    [/TR]
    [TR]
    [TD="class: e"]libPNG Version [/TD]
    [TD="class: v"]1.2.10 [/TD]
    [/TR]
    [TR]
    [TD="class: e"]WBMP Support [/TD]
    [TD="class: v"]enabled [/TD]
    [/TR]
    [TR]
    [TD="class: e"]XBM Support [/TD]
    [TD="class: v"]enabled [/TD]
    [/TR]
    [/TABLE]



    Ich habe auch schon andere Bilder hochgeladen, hat auch ohne Probleme funktioniert. Die Bilder sind in Artikel eingebunden.



    Ich habe die wp-config entsprechend aktualisiert und auf dem Server aktualisiert, anschließend erneut die phpinfo datei aufgerufen, jedoch steht bei memory_limit noch immer 45M
     
  5. infected

    infected Well-Known Member

    Registriert seit:
    9. Juli 2006
    Beiträge:
    9.816
    Zustimmungen:
    1
    Die dann aber vermutlich kleiner waren... Die Bilder werden zur Verarbeitung in den Speicher geladen (genau wie auf Deinem Desktop PC). Wenn WP inkl. Sprachdatei, Themes und aktivierten Plugins schon nahe an den 45MB ist, dann macht der Server je nach Größe des Bildes zu. Je nach Serverkonfiguration erhält man dann aber auch eine entsprechende Fehlermeldung (Out of memory oder Allowed memory exhausted).

    Dann wende Dich an Deinen Hoster.

    Last but not least: Du hast ja mit Sicherheit schon alles probiert, was in diesem Posting zum Thema HTTP Error on image upload vorgeschlagen wurde?!
     
  6. hack4life

    hack4life Member

    Registriert seit:
    24. August 2012
    Beiträge:
    16
    Zustimmungen:
    0
    Ja, habe alle Tipps ausprobiert aber hat nicht geholfen.

    Ich kann im Kundencenter bei der Verwaltung vom Webspace das Memory_Limit um 25% eröhen (also auf 56M) und habe anschließend probiert ein Bild hochzuladen. Es funktioniert ! :smile:

    Danke an alle die mir geholfen haben! :)
     
  7. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.896
    Zustimmungen:
    18
    Was auch noch helfen könnte, ist das Plugin 123 Image Resize. Damit kann praktisch der gesamte zur Verfügung stehende PHP-Speicher von Wordpress für die Verarbeitung eines Bildes verwendet werden.

    Gruß
    Ingo
     
  8. hack4life

    hack4life Member

    Registriert seit:
    24. August 2012
    Beiträge:
    16
    Zustimmungen:
    0
    Werde ich mir mal anschauen.
     
  9. onlinemarketing-berlin

    Registriert seit:
    11. Juli 2012
    Beiträge:
    11
    Zustimmungen:
    0
    Hallo,ich habe manchmal auch das Problem,
    es liegt aber nicht an einem der oben beschriebenen Problemen sondern viel simpler am Browser / Flash.

    MEINE LÖSUNG:Mit einem anderen Browser geht es ohne Probleme bzw. noch simpler:
    Du benutzt den Mehrdateienuploader. Treten Probleme auf? Benutze dann stattdessen den Browser Uploader."mit dem alten Standard "1 File je upload" klappt es ohne Probleme. Nur der "Multifileuplaoder" macht hier Probleme, der wie ich glaube mit Flash läuft.

    Gruß Matthias :)
     
  10. Wilma

    Wilma New Member

    Registriert seit:
    19. Oktober 2014
    Beiträge:
    1
    Zustimmungen:
    0
    Danke! Das hat wunderbar funktioniert. :)
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden