1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Im Editor ist ein unerwarteter Fehler aufgetreten

Dieses Thema im Forum "Installation" wurde erstellt von michoubonn, 24. Juli 2021.

  1. michoubonn

    michoubonn Well-Known Member

    Registriert seit:
    16. März 2011
    Beiträge:
    114
    Zustimmungen:
    1
    Ihr Lieben,

    das nächste Problem. Wieder eines, das ich nicht kenne: Wenn ich versuche, einen Beitrag oder eine Seite zu erstellen oder zu bearbeiten, dann erhalte ich die Fehlermeldung:

    TypeError: Cannot destructure property 'mode' of 'Object(...)(...)' as it is undefined.
    at qs (https://hendrike-applebloom.de/wp-includes/js/dist/edit-post.min.js?ver=1eb14b17cd9ee51cd7e6f98652830641:49:126368)
    at we (https://hendrike-applebloom.de/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.13.1:84:293)
    at zj (https://hendrike-applebloom.de/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.13.1:226:496)
    at Th (https://hendrike-applebloom.de/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.13.1:152:223)
    at tj (https://hendrike-applebloom.de/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.13.1:152:152)
    at Te (https://hendrike-applebloom.de/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.13.1:146:151)
    at https://hendrike-applebloom.de/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.13.1:61:68
    at unstable_runWithPriority (https://hendrike-applebloom.de/wp-includes/js/dist/vendor/react.min.js?ver=16.13.1:25:260)
    at Da (https://hendrike-applebloom.de/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.13.1:60:280)
    at Pg (https://hendrike-applebloom.de/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.13.1:61:14)

    Klicke ich aufeine der Optionen Wiederherstellung versuchen oder Beitragstext kopieren, dann passiert nichts, die Seite bleibt weiß.
    Die Installation ist brandneu, aber schon das zweite Mal aufgesetzt (dazu gibt es einen Beitrag von heute). Ich habe noch keinen Beitrag verfasst oder kopiert, sondern nur das Theme eingerichtet.
     
  2. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    9.291
    Zustimmungen:
    1.154
    Deaktiviere alle Plugins und versuche es auch mit einem Twenty XXX Standardtheme. Leere die Browser Caches zwischen allen Umstellungen.

    Generell: Evtl. ist Dein Theme nicht kompatibel zur aktuell genutzten WordPress Version 5.8, versuche es damit testweise auch mit dem Classic Editor Plugin und mit dem Classic Widgets Plugin.
     
  3. michoubonn

    michoubonn Well-Known Member

    Registriert seit:
    16. März 2011
    Beiträge:
    114
    Zustimmungen:
    1
    Ich habe die Konstellation auf demselben Server unter einem anderen Domainnamen und es läuft problemlos. Es ist hier irgendwie der Wurm drin.
    Ich probiere es mit Twenty, wäre aber keine Lösung :(

    Aber es macht keinen Unterschied. Habe alle Twenties durch, aber die Fehlermeldung bleibt bestehen. Ich habe auch den betreffenden Ordner noch einmal hochgeladen, macht auch keinen Unterschied. Das habe ich noch nie erlebt ...
     
  4. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    9.291
    Zustimmungen:
    1.154
    Es läuft derzeit ein Plugin DSGVO All in one for WP, das lt. eigenen Angaben nur bis WordPress 5.7.1 getestet ist, verwendet wird aber WordPress 5.8.
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Stelle die Kompatibilität aller verwendeten Komponenten zur verwendeten WordPress Version sicher.

    Gerade WordPress 5.8 bringt umfangreiche Änderungen mit, was viele mögliche Probleme in sich birgt, siehe auch die entspr. Release Notes mit Details und weiterführenden Links.

    Evtl. ist das Problem auch weiterhin in unvollständigen oder defekten Uploads des WordPress Core zu suchen, das hattest Du ja schonmal.
     
    michoubonn gefällt das.
  5. michoubonn

    michoubonn Well-Known Member

    Registriert seit:
    16. März 2011
    Beiträge:
    114
    Zustimmungen:
    1
    Ok, eine Lösung scheine ich gefunden zu haben - das Gutenbergplugin installieren hat Erfolg gebracht. Zumindest kann ich jetzt die Seiten und Beiträge aufrufen und bearbeiten. Ob ich sie auch speichern kann und was ich dann zu sehen bekomme, bleibt noch spannend ...
     
  6. michoubonn

    michoubonn Well-Known Member

    Registriert seit:
    16. März 2011
    Beiträge:
    114
    Zustimmungen:
    1
    Stelle die Kompatibilität aller verwendeten Komponenten zur verwendeten WordPress Version sicher.

    Gerade WordPress 5.8 bringt umfangreiche Änderungen mit, was viele mögliche Probleme in sich birgt, siehe auch die entspr. Release Notes mit Details und weiterführenden Links.

    Evtl. ist das Problem auch weiterhin in unvollständigen oder defekten Uploads des WordPress Core zu suchen, das hattest Du ja schonmal.
    [/QUOTE]
    Ah, auf der Pluginseite stand eben noch, es sei kompatibel. Dann muss ich mal nach einem anderen schauen :)

    Habe es deaktiviert und in der Tat geht es jetzt auch ohne Gutenbergplugin. Ich habe das echt nicht bemerkt eben, dabei bin ich da immer sehr hinterher, dass ich alles aktuell halte. Danke dir schon wieder! (Bis nachher ... ich bin soo optimistisch gerade :D )
     
    #6 michoubonn, 24. Juli 2021
    Zuletzt von einem Moderator bearbeitet: 26. Juli 2021
  7. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    9.291
    Zustimmungen:
    1.154
    Für Mitleser: Das Gutenberg Plugin macht alles noch viel experimenteller, es ist für einen Einsatz in produktiven Websites nicht gedacht sondern dient zum Testen neuer zukünftiger Funktionen.
     
    michoubonn gefällt das.
  8. michoubonn

    michoubonn Well-Known Member

    Registriert seit:
    16. März 2011
    Beiträge:
    114
    Zustimmungen:
    1
    Stimmt. Wäre bei dieser Seite jetzt nicht von Bedeutung, ich wollte nur sehen, ob es den Editor quasi repariert - was es getan hat, wieso auch immer. Ist aber wieder ausgestellt.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden