1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Index.php wird nicht immer richtig geladen

Dieses Thema im Forum "Konfiguration" wurde erstellt von Siflu, 5. August 2012.

  1. Siflu

    Siflu New Member

    Registriert seit:
    5. August 2012
    Beiträge:
    4
    Zustimmungen:
    0
    Guten Tag zusammen

    Für eine Schulzeitung habe ich vor kurzem eine Wordpress-Seite eingerichtet und dafür
    selber ein Template erstellt.
    Es existieren also die Dateien index.php, header.php, footer.php, comments.php, page.php, sidebar.php

    In der Sidebar werden die statischen Seiten aufgelistet, was auch wunderbar funktioniert.
    In der index.php hole ich mir mittels folgendem Code die entsprechenden Seiteninhalte:
    PHP:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Auch das Anzeigen der Inhalte funktioniert gut.
    Nun habe ich aber leider das Problem, dass der Content-Bereich meiner Seite folgendermassen aufgebaut ist:
    linke Navigation - linker Content Bereich (main-Bereich) - rechter Content Bereich (sidebar)
    Sobald ich eine Page in der Sidebar anklicke, verschwindet die linke Navigation unerklärlicherweise :eek:

    Wenn ich mir den Quellcode anschaue, ist die linke Navigation dort auch nicht vorhanden.
    Wenn jedoch keine Seite geladen ist (ich habe die Hauptseite momentan so eingerichtet, dass kein Beitrag geladen wird), dann wird die linke Navigation richtig angezeigt (hier stimmt der Quellcode dann auch).

    Damit ihr seht, was ich genau meine:
    Richtig: http://schulkreisel.ch/
    Falsch: http://schulkreisel.ch/?page_id=214

    Habt ihr evtl. eine Idee, an was das liegen könnte?

    Ich würde mich sehr über eure Antworten freuen.

    Vielen Dank und liebe Grüsse
    Siflu
     
  2. Siflu

    Siflu New Member

    Registriert seit:
    5. August 2012
    Beiträge:
    4
    Zustimmungen:
    0
    Entschuldigt für den Doppelpost, aber das Problem ist ziemlich dringend..
    Hat niemand eine Idee, an was das liegen könnte?
    Mir gehen langsam leider die Ideen aus

    Gruss Siflu
     
  3. Michi91

    Michi91 Well-Known Member

    Registriert seit:
    8. November 2008
    Beiträge:
    1.747
    Zustimmungen:
    1
    wird die sidebar.php den in der page.php überhaupt geladen? vergleiche mal index.php und page.php bzgl der sidebar integration
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden