1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Installations Problem bei 1&1: Warning: Cannot modify header information

Dieses Thema im Forum "Installation" wurde erstellt von Chris_p, 26. Januar 2007.

  1. Chris_p

    Chris_p Member

    Registriert seit:
    26. Januar 2007
    Beiträge:
    5
    Zustimmungen:
    0
    Hallo Forum :)
    Jetzt habe ich eine gute Stunde in alten Threads verbacht, aber der einzige der in meine Richtung ging blieb ohne Lösung.
    Eventuell hab ich ja Glück und inzwischen gibt es Infos zu dem Problem.

    Eckdaten:
    Ich habe Wordpress 2.07 gestern von wordpress.de gezogen und auf einen 1und1 Webspace (1&1 Home 5.0) per ftp hochgeladen. Beim Aufrufen der admin.php kam eine Fehlermeldung.
    Da drunter war der Startscreen von Wordpress zu sehen. Ich konnte die Installation durchführen, steckte dann aber fest weil nur noch die Fehlermeldung kam.
    Nach etwas Internet Suche habe ich wordpress deinstalliert und von php 4.0 auf php 5.0 gewechselt. Ergebnis unverändert.
    Hier der Fehler im ganzen:
    Warning: Cannot modify header information - headers already sent by (output started at /homepages/41/d181531525/htdocs/wordpress/wp-config.php:23) in /homepages/41/d181531525/htdocs/wordpress/wp-admin/install.php on line 19

    bei Aufruf der Adresse ...wp-admin/install.php
    Plugins sind zu diesem Zeitpunkt natürlich noch keine Installiert.
    Ich hab dann noch einmal die Ordner Atribute auf 777 gestellt (von 755).
    Auch keine Änderung.

    Ich bin verblüfft und da ich eh ein eigenes wordpress theme entwerfen muß, habe ich die gleiche wordpress Version noch einmal lokal installiert.
    Tadellos. Ich kann alles ändern und einstellen.

    Hier übrigens meine config:
    PHP:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Wenn mir jetzt doch noch jemand helfen könnte wäre ich SEHR dankbar.
    :)
    Grüße, Chris
     
    #1 Chris_p, 26. Januar 2007
    Zuletzt von einem Moderator bearbeitet: 26. Januar 2007
  2. Umpire

    Umpire Member

    Registriert seit:
    26. Januar 2007
    Beiträge:
    12
    Zustimmungen:
    0
    installiere mal die 2.1 version :)
     
  3. Chris_p

    Chris_p Member

    Registriert seit:
    26. Januar 2007
    Beiträge:
    5
    Zustimmungen:
    0
    Hab ich auch schon überlegt.
    Ich kann der zukünftigen Nutzerin aber leider keine eng. Version zumuten.
    Arbeitet wer an der Übersetzung? Gibt es einen vorraussichtlichen Termin?

    Grüße, Chris.

    Nachtrag: Zu mal ja einige bereits wordpress bei 1&1 nutzen.
    Ja die sogar selber wordpress anbieten, wenn auch mit Einschränkungen.
     
    #3 Chris_p, 26. Januar 2007
    Zuletzt bearbeitet: 26. Januar 2007
  4. Kopfgeldjaeger

    Kopfgeldjaeger Active Member

    Registriert seit:
    1. Januar 2007
    Beiträge:
    29
    Zustimmungen:
    0
    In Deutsch soll dat danze dieses WE rauskommen...
     
  5. Chris_p

    Chris_p Member

    Registriert seit:
    26. Januar 2007
    Beiträge:
    5
    Zustimmungen:
    0
    Gut warte ich mal bis Montag.
    Obwohl ich so etwas hasse und die Chance das es immer noch nicht klappt sehr groß ist.
    Wie gesagt, den eigentlichen installer hab ich hier noch nicht mal ausgeführt.

    Chris
     
  6. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.879
    Zustimmungen:
    7
    Kann es sein, das am Ende der wp-config.php, also hinter dem schließenden ?> noch ein paar Leerzeichen oder Leerzeilen stehen?

    Falls ja, diese einfach mal löschen.

    Gruß
    Ingo
     
  7. Chris_p

    Chris_p Member

    Registriert seit:
    26. Januar 2007
    Beiträge:
    5
    Zustimmungen:
    0
    Leider nein.
    Dieser Rat wird hier ja auch in diversen threads immer wieder gegeben.
    Aber, erstens hab ich ja meinen config text oben gepostet und zweitens läuft es ja lokal mit einer Datei die sich nur in den Daten/passwörtern unterscheidet.

    Chris
     
  8. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.879
    Zustimmungen:
    7
    Hmm, achso. Na zumindest deutet der Fehler aber darauf hin und ist genau so bei mir reproduzierbar.

    Vielleicht liegt es ja auch am Format beim speichern (z.B. UTF-8 ) oder so. Das sieht dann zwar im Editor so aus, als stehe da nichts mehr, kann aber trotzdem noch zusätzliche Bytes enthalten. Wenn ich z.B. mit dem Notepad++ als UTF-8 speichere, bekomme ich auch so eine ähnliche Meldung, nur meckert er schon bei Zeile 1 der wp-config.php:1

    Mein Blog bei 1und1 läuft übrigens ohne Probleme :)

    Gruß
    Ingo
     
  9. Chris_p

    Chris_p Member

    Registriert seit:
    26. Januar 2007
    Beiträge:
    5
    Zustimmungen:
    0
    Jetzt kommen wir der Sache eventuell doch näher.
    Ich nutze auch notepad++
    Ich probiere mal Varianten aus und meld mich dann wieder.


    Nachtrag:
    Done!

    Das war es.
    Wäre ich ja im Leben nicht drauf gekommen.

    DANKE!
    :)
     
    #9 Chris_p, 26. Januar 2007
    Zuletzt bearbeitet: 26. Januar 2007
  10. MarcusS81

    MarcusS81 New Member

    Registriert seit:
    10. Januar 2009
    Beiträge:
    2
    Zustimmungen:
    0
    wie habt ihr das denn nun gelöst?

    hallo!

    ich benutze den microsoft editor!
    bei mir wird auch die wp_config.php:1 angezeigt!

    unter welchen einstellungen habt ihr die datei gespeichert?

    gruss
    MarcusS81

    HAT SICH ERLEDIGT - IM ANSI-FORMAT UND NICHT IM UTF8 FORMAT SPEICHERN!!!
     
    #10 MarcusS81, 10. Januar 2009
    Zuletzt bearbeitet: 10. Januar 2009
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden