1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

WP 5.1 Komisches Verhalten bei Datenbank intigration

Dieses Thema im Forum "Installation" wurde erstellt von Tobiasp, 20. April 2019.

  1. Tobiasp

    Tobiasp Well-Known Member

    Registriert seit:
    16. Juni 2018
    Beiträge:
    50
    Zustimmungen:
    1
    Guten Tag,

    Ich habe einige Probleme mit einer Wordpress Installation, ich möchte aufgrund eines Domainwechsels eine Datenbank mit Beiträgen Importieren.

    Host: Plesk

    Ich habe jetz die Alte Datenbank Importiert, die alten Beiträge sind aber nicht Vorhanden. Wenn ich einen neuen erstelle ist das kein Problem, der wird aber nicht in der Datenbank gespeichert.
    Ich möchte einfach nur die Datenbank bzw. die Beiträge in eine neue Installation intigirieren. Nur leider funktioniert nichts. Hat jemand einen Rat wie das funktionieren könte?

    MFG
     
  2. SirEctor

    SirEctor Well-Known Member
    Ehrenmitglied

    Registriert seit:
    28. Oktober 2008
    Beiträge:
    12.341
    Zustimmungen:
    420
    Du exportierst direkt über das alte WordPress die Beiträge und nutzt im neuen WordPress die Import-Funktion. Direkt über die Datenbank wirst du Schwierigkeiten haben.
     
  3. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    9.291
    Zustimmungen:
    1.154
    Das deutet darauf hin, dass Du ggf. in die falsche Datenbank schaust.
     
  4. timmehosting

    timmehosting Member

    Registriert seit:
    18. April 2019
    Beiträge:
    8
    Zustimmungen:
    0
    Überprüfe mal Deine Datenbankeinstellungen in der wp-config.php, vermutlich stimmen die nicht.
     
  5. Tobiasp

    Tobiasp Well-Known Member

    Registriert seit:
    16. Juni 2018
    Beiträge:
    50
    Zustimmungen:
    1
    Das habe ich auch schon nachgeguckt. Allerdings scheint es richtig.
    Eintrag der Aktuellen Wordpress Installation:
    [​IMG]
    Datenbank:
    [​IMG]
     
  6. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    9.291
    Zustimmungen:
    1.154
    Wie genau wurde der Export/Import gemacht? Welche Tabellen? Hast Du Einträge in Tabellen der alten Datenbank mit bestehenden Einträgen in Tabellen der neuen Datenbank vermischt? Das geht bei WordPress nicht. Evtl. gibt es dadurch doppelte IDs oder fehlerhafte sonstige Bezüge und damit unabsehnbare Probleme.
     
  7. Tobiasp

    Tobiasp Well-Known Member

    Registriert seit:
    16. Juni 2018
    Beiträge:
    50
    Zustimmungen:
    1
    Ich habe einfach das Datenbank Backup der alten Installation Importiert via Plesk.
     
  8. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    9.291
    Zustimmungen:
    1.154
    Wurden die Tabellen dabei vorher gelöscht?

    Enthält das Backup Zeilen wie DROP TABLE IF EXISTS `1_comments`; CREATE TABLE `1_comments` ... usw.?
     
  9. Tobiasp

    Tobiasp Well-Known Member

    Registriert seit:
    16. Juni 2018
    Beiträge:
    50
    Zustimmungen:
    1
    Sollte bei dem Import so sein, war sonst auch immer so. Der Import hat vorher auch schon bei einer anderen Installation funktioniert.
     
  10. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    9.291
    Zustimmungen:
    1.154
    Das ist nicht zwangsläufig so, daher stellt sich diese Frage. Nach welcher Spalte ist der Screenshot sortiert? Sortiere den mal nach ID aufsteigend und schau auf die letzte Seite, findest Du dort Deinen o.g. "neu erstellten Beitrag?"

    Wenn Du sichergehen willst, lösche alle Tabellen der Datenbank und spiele die .sql Datei aus dem Backup neu ein und lösche alle WordPress-Dateien auf dem Server und spiele die Dateien aus dem Backup neu ein, mit entspr. Anpassung der wp-config.php bzgl. Datenbank nach dem Einspielen.
     
  11. Tobiasp

    Tobiasp Well-Known Member

    Registriert seit:
    16. Juni 2018
    Beiträge:
    50
    Zustimmungen:
    1
    Egal wie ich die Spalte Sortiere, der "neue Beitrag" Taucht nicht auf.
     
  12. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    9.291
    Zustimmungen:
    1.154
    Wenn der Beitrag im Backend von WordPress erscheint, aber nicht in der Datenbank, und wenn Du andere Beiträge in der Datenbank siehst, aber nicht im Backend von WordPress, dann schaust Du wie oben bereits vermutet in die falsche Datenbank.

    Nach welcher Spalte ist der Screenshot sortiert?
     
  13. Tobiasp

    Tobiasp Well-Known Member

    Registriert seit:
    16. Juni 2018
    Beiträge:
    50
    Zustimmungen:
    1
    Ich werde das nachher neu Installieren. Aber wo ist dann die richtige Datenbank. Das ist die einzige mit dem Namen Benutzer PW, und sie ist in der WP-Config eingetragen.
     
  14. timmehosting

    timmehosting Member

    Registriert seit:
    18. April 2019
    Beiträge:
    8
    Zustimmungen:
    0
    Zeigt denn die Domain, über die Du die neue WP-Installation aufrufst, auf das Verzeichnis, in dem Du die wp-config.php geprüft hast? Evtl. zeigt die Domain ja auf einen anderen Document Root oder sogar einen ganz anderen Server.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden