1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

WP 4.7 Links in Twenty Seventeen nicht mehr unterstreichen

Dieses Thema im Forum "Konfiguration" wurde erstellt von Issmitlust, 7. Februar 2017.

  1. Issmitlust

    Issmitlust Well-Known Member

    Registriert seit:
    5. Januar 2017
    Beiträge:
    65
    Zustimmungen:
    0
    Hi,

    ich werde noch wahnsinnig. Die Links im Theme Twenty Seventeen sollten eigentlich nicht unterstrichen werden. Werden sie aber.

    In der CSS steht alles auf text-decoration:none.
    Ich habe zusätzlich span-Klassen um die Links gelegt, .txtlink a {text-decoration:none;}, habe in die Links selbst <a ...><span style="text-decoration:none!important">Anker </span></a> hineingesetzt - nix funktioniert.

    Im Safari "Element untersuchen" wird mir angezeigt, dass die Links über @media unterstrichen werden - was ich aber nicht finde.

    HILFE :)

    Weiß jemand, wie ich das loswerde?

    Beispielseite: http://rauchenistbloed.de/start/rauchen-aufhoeren/
     
    #1 Issmitlust, 7. Februar 2017
    Zuletzt bearbeitet: 7. Februar 2017
  2. Henk1060

    Henk1060 Well-Known Member

    Registriert seit:
    4. September 2014
    Beiträge:
    3.020
    Zustimmungen:
    189
    schau mal in deine style.csss zeile 1171

    .entry-content a


    • -webkit-box-shadow: inset 0 -1px 0 rgba(15, 15, 15, 1);
    • box-shadow: inset 0 -1px 0 rgba(15, 15, 15, 1);
    • -webkit-transition: color 80ms ease-in, -webkit-box-shadow 130ms ease-in-out;
    • transition: color 80ms ease-in, -webkit-box-shadow 130ms ease-in-out;
    • transition: color 80ms ease-in, box-shadow 130ms ease-in-out;
    • /* transition: color 80ms ease-in, box-shadow 130ms ease-in-out, -webkit-box-shadow 130ms ease-in-out; */


    }
     
  3. Henk1060

    Henk1060 Well-Known Member

    Registriert seit:
    4. September 2014
    Beiträge:
    3.020
    Zustimmungen:
    189
    und zeile 194
    .colors-custom .entry-content a,
     
  4. Issmitlust

    Issmitlust Well-Known Member

    Registriert seit:
    5. Januar 2017
    Beiträge:
    65
    Zustimmungen:
    0
    Danke, @Henk! Ehrlich gesagt, verstehe ich die inset ... -webkit-box-shadow - Angaben nicht so gut. Ich habe sie aber mal testweise auskommentiert - das macht aber keinen Unterschied. Und Zeile 194 ist bei mir: input {overflow: visible;}
    .colors-custom finde ich der style.css gar nicht. Hm ...
     
  5. Der Gerd

    Der Gerd Well-Known Member

    Registriert seit:
    4. Juli 2007
    Beiträge:
    70
    Zustimmungen:
    0
    Habe das gleiche Problem und bekomme diesen blöden Unterstrich nicht weg. Hat keiner eine Lösung?
     
  6. Henk1060

    Henk1060 Well-Known Member

    Registriert seit:
    4. September 2014
    Beiträge:
    3.020
    Zustimmungen:
    189
    ich kann nur das sagen was ich sehe ,))

    hier noch mal was zum sehen.
    Alles andere sollte man sich auch selbst erlernen und googlen ;)

    links2.jpg

    links1.JPG
     
  7. Der Gerd

    Der Gerd Well-Known Member

    Registriert seit:
    4. Juli 2007
    Beiträge:
    70
    Zustimmungen:
    0
    Ja so schaut es im Quelltext aus, in der style.css aber leider ganz anders. Asche auf mein Haupt, anscheinend werde ich zu alt für so was.
     
  8. Henk1060

    Henk1060 Well-Known Member

    Registriert seit:
    4. September 2014
    Beiträge:
    3.020
    Zustimmungen:
    189
    sehe gerade das die zeile 194 direkt im html code ausgeben wird.
    hast das theme die möglichkeit einer custom css... zum überschreiben... wenn ja....

    dann versucht das

    colors-custom .entry-content a {
    box-shadow: inset 0 0px 0 #f84d3b;
    -webkit-box-shadow: inset 0 0px 0 #f84d3b;
    }
     
  9. Edi

    Edi Well-Known Member

    Registriert seit:
    26. Juli 2006
    Beiträge:
    3.728
    Zustimmungen:
    1
  10. Der Gerd

    Der Gerd Well-Known Member

    Registriert seit:
    4. Juli 2007
    Beiträge:
    70
    Zustimmungen:
    0
    Hallo Edi,

    ich gebe Dir Recht, die Text-Links sollten schon unterstrichen sein. Leider habe ich diesen Unterstrich aber auch unter Fotos und Grafiken die eine Verlinkung haben und das stört der Optik. Über eine Lösung dieses Problems würde ich mich jedenfalls sehr freuen. Alle bisherigen Vorschläge führten nicht zum gewünschten Erfolg.
     
  11. Der Gerd

    Der Gerd Well-Known Member

    Registriert seit:
    4. Juli 2007
    Beiträge:
    70
    Zustimmungen:
    0
    Problem gelöst!
     
  12. Henk1060

    Henk1060 Well-Known Member

    Registriert seit:
    4. September 2014
    Beiträge:
    3.020
    Zustimmungen:
    189
    dann teile doch deine Lösung ;)
     
  13. Edi

    Edi Well-Known Member

    Registriert seit:
    26. Juli 2006
    Beiträge:
    3.728
    Zustimmungen:
    1
    Der Code sollte funktionieren. Oder hast Du ein Beispiel, wo es nicht geht?
     
  14. Der Gerd

    Der Gerd Well-Known Member

    Registriert seit:
    4. Juli 2007
    Beiträge:
    70
    Zustimmungen:
    0
    Hier habe ich die Werte verändert und schon war die Linie unter den Fotos verschwunden.

    .widget a img {
    -webkit-box-shadow: 0 10px 0px 0px #fff;
    box-shadow: 0 10px 0px 0px #fff;
    }
     
  15. Edi

    Edi Well-Known Member

    Registriert seit:
    26. Juli 2006
    Beiträge:
    3.728
    Zustimmungen:
    1
    Die Frage beziehungsweise Feststellung lautete halt: "Die Links im Theme Twenty Seventeen sollten eigentlich nicht unterstrichen werden." ;)
     
  16. Issmitlust

    Issmitlust Well-Known Member

    Registriert seit:
    5. Januar 2017
    Beiträge:
    65
    Zustimmungen:
    0
    Entschuldigung, dass ich erst jetzt antworte - ich habe an der falschen Stelle nachgesehen und dachte, der Thread ging nicht weiter. Ging er aber doch.
    Danke euch!

    Ich habe allerdings alle vorgeschlagenen Lösungen versucht - so wie es aussieht, ist der Unterstrich in das Theme hinein gelötet. :) Verflixt.
    Oder, Henk, in deinem Screenshot, wie hast du das hinbekommen, dass nicht unterstrichen wurde? Wahrscheinlich mit dem vorgeschlagenen Code - der bei mir aber nichts bewirkt.

    Accessibility ist ein Thema, richtig. Ich habe selbst schon Blinde am Computer geschult, deren Programme geben den Link auch ohne Unterstrich aus.
     
  17. chezzone

    chezzone Well-Known Member

    Registriert seit:
    10. September 2016
    Beiträge:
    79
    Zustimmungen:
    0
    @Issmitlust: Probier mal folgendes im CSS

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
     
  18. Issmitlust

    Issmitlust Well-Known Member

    Registriert seit:
    5. Januar 2017
    Beiträge:
    65
    Zustimmungen:
    0
    @chezzone JAAAA! Danke dir. Funktioniert. :D
     
  19. Issmitlust

    Issmitlust Well-Known Member

    Registriert seit:
    5. Januar 2017
    Beiträge:
    65
    Zustimmungen:
    0
    Sorry, chezzone, darf ich nochmal? Wie komme ich denn jetzt an die Gestaltung der Hover-Unterstreichung heran? Ich habe es so versucht:
    PHP:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Wieder ändert sich der Strich nicht ...
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden