1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

WP 4.3 Media-Upload nicht möglich

Dieses Thema im Forum "Konfiguration" wurde erstellt von rollo27, 17. März 2016.

Schlagworte:
  1. rollo27

    rollo27 Member

    Registriert seit:
    22. Juli 2015
    Beiträge:
    23
    Zustimmungen:
    0
    Moin!

    Diese Fehlermeldung dürfte für einige bekannt sein, wenn Bilder etc über "Medien" hochgeladen werden sollen:

    "Das Verzeichnis uploads/2016/03 kann nicht angelegt werden. Ist das übergeordnete Verzeichnis durch den Server beschreibbar?"


    Der übliche Rat, dem Verzeichnis wp-content/uploads könnten die notwendigen Rechte fehlen und man müsse die eben auf 777 setzen, ist ja richtig. Was aber, wenn die Rechte stimmen und sogar das genannte Verzeichnis schon existiert?

    Dass PHP recht alt ist (5.4.45), dürfte jetzt sicher erstmal zweitrangig sein. Es handelt sich insgesamt um eine recht ungepflegte Installation, deren "Erfinder" nicht mhr greifbar ist, aber Uploads gingen bis zum Oktober.

    Ich hoffe auf Tipps! Danke,
    Ralph
     
  2. rollo27

    rollo27 Member

    Registriert seit:
    22. Juli 2015
    Beiträge:
    23
    Zustimmungen:
    0
    Ich antworte mir gleich mal selber, denn 10 Minuten später habe ich die Lösung gefunden :). Darauf gebracht hat mich dieser alte Beitrag eines gewissen Thomas.

    Unter Einstellungen/Medien steht der Pfad zum Uploads-Ordner. Aus mir unbekannten Gründen stand dort der absolute Pfad auf dem Server, also sowas wie /home/www/.../wordpress/wp-content/uploads. Die Vorgabe (steht darunter) heißt aber wp-content/uploads. Das habe ich ersetzt und schwupps, erledigt. Wieso das früher mal gegangen sein soll, weiß ich nicht.
     
  3. Monika

    Monika Well-Known Member
    Ehrenmitglied

    Registriert seit:
    4. Juni 2005
    Beiträge:
    14.126
    Zustimmungen:
    1
    da seit etlichen WP Versionen diese INFO über den Pfad des UploadOrdners nicht mehr unter Dashboard => Einstellungen ==> Medien steht empfehl ich dringendst ein Update :)
     
  4. rollo27

    rollo27 Member

    Registriert seit:
    22. Juli 2015
    Beiträge:
    23
    Zustimmungen:
    0
    Ich bin dabei, muss "nur" die zahlreichen Plugins prüfen, ob die dann noch gehen. Und PHP hochsetzen (5.6 sollte reichen?).

    Da wird mir auch klar, warum ich nicht nach dieser Option geguckt habe. Ich kenne sie nicht, hatte bisher nur mit jüngeren Versionen zu tun. Danke für den Hinweis!
     
  5. wolfen

    wolfen New Member

    Registriert seit:
    29. März 2016
    Beiträge:
    1
    Zustimmungen:
    0
    hallo, habe die selbe fehlermeldung. habe die neueste version von wp installiert, allerdings auf einem local host. da ich neuling bin würde ich gerne wissen, wo ich denn die einstellung vornehmen kann? besonders, wo ich rechte einstellen kann.
    vielen dank!
     
  6. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.965
    Zustimmungen:
    8
    Unter was hast du denn dein lokales WordPress zu laufen, xampp?
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden