1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Menüanzeige fehlerhaft

Dieses Thema im Forum "Design" wurde erstellt von Leo_20, 18. Januar 2024.

  1. Leo_20

    Leo_20 New Member

    Registriert seit:
    17. Januar 2024
    Beiträge:
    1
    Zustimmungen:
    0
    Hallo zusammen,

    ich habe ein Problem, bei dem ich einfach nicht weiterkomme... Vielleicht hat ja jemand eine Lösung? Ich komme mit Google, Ausprobieren und Co. einfach nicht weiter, obwohl ich es schon seit Tagen immer wieder versuche.... Die Website wurde von jemand anderem erstellt und dann auch ein paar Jahre gehostet. Seitdem wurde daran nichts mehr gemacht.

    Folgendes Problem:
    Ich habe unsere Seite von PHP 7.3 auf PHP 7.4 umgestellt (eigentlich wollte ich auf 8.0 umstellen, aber habe irgendwann bei ständiger Fehlermeldung aufgegeben). Danach waren eigentlich nur noch Codes auf der Seite sichtbar und vom alten Design gar nichts mehr über. So schlimm ist das nicht, weil ich die Seite eh neu gestalten wollte.

    Leider betrifft das auch den Header und Folter. Unterhalb des Copyright Schriftzuges geht die Website mit Logo und Main-Menü weiter (alles Links), was ja definitiv nicht so sein soll. Ich habe wirklich alles probiert, kriege es aber nicht weg... Das gleiche habe ich im Header. Unter unserem Logo sind 3 Worte zu sehen, die da nichts zu suchen haben. Auch diese bekomme ich leider nicht weg. Zusätzlich ist das Main-Menü falsch formatiert. In meiner Vorschau stimmt immer alles (bin über Design > Header und über Theme Options gegangen), aber online ändert sich nichts.

    Ich weiß nicht, ob das wichtig für's Problem ist, aber gelegentlich kriege ich die gleiche Fehlermeldung, wie beim Update auf PHP 8.0 (dann halt nur kurz, ich kann es durch zurückklicken wegmachen). Es erscheint dann "Ihre Website weist einen kritischen Fehler auf ...". Ich weiß leider wirklich nicht mehr weiter....

    Hier noch ein paar Hintergrundinfos:
    Website: https://www.emc-plan.de
    Theme: Good Energy

    Danke schon einmal vorab :)
     
  2. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    11.585
    Zustimmungen:
    1.749
    1. Generell: Bei Darstellungsproblemen immer zuerst sämtliche Cache- bzw. Optimierungsplugins deaktivieren, derzeit ist eines aktiv, das CSS und Scripts statisch zusammenfasst.
    2. Theme aktualisieren, installiert 1.7, aktuell wäre 1.7.5, dafür ggf. Theme Support ansprechen.
    3. PHP Fehlermeldung bzw. "kritischen Fehler" Ursache weiter eingrenzen: Deaktivere temporär der Reihe nach die Plugins oder schau ins Error Log des Servers beim Hosting oder Einblick über das Aktivieren via WP_DEBUG.
    4. "3 Worte", Theme Einstellungen /Customizer prüfen, könnte lt. CSS eine Logo Text bzw. Logo Slogan Einstellung sein.
     
    Leo_20 gefällt das.
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden