1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Mit Child-Theme ist Startseite kaputt

Dieses Thema im Forum "Design" wurde erstellt von cave2596, 25. April 2018.

  1. cave2596

    cave2596 Member

    Registriert seit:
    31. Januar 2015
    Beiträge:
    10
    Zustimmungen:
    0
    Hallo ihr Profis,

    ich habe nach dieser Anleitung
    https://codex.wordpress.org/Child_Themes
    ein Child-Theme zu TwentySeventeen erstellt, um damit ein Widget als Seitenleiste einzubinden.
    Das hat auch wunderbar funktioniert, nur ist mit dem Child-Theme meine Startseite kaputt gegangen.
    Um zum Inhalt der Startseite zu kommen, muss man ewig nach unten Scrollen und der Text ist auch nicht mittig, wie auf allen anderen Seiten.

    Weiß jemand, was ich dabei falsch gemacht habe?

    Auch wenn ich meine Änderung bezüglich des Widgets rückgängig mache, ist der Fehler vorhanden.
    Ich hatte auch schon versucht, mit einem Plugin solch ein Child-Theme zu erstellen.
    Auch wenn ich dort noch nichts geändert habe, ist die Startseite so komisch.
    Der Fehler tritt also immer auf, wenn ich ein Child-Theme nutze.

    Hier ein Link zu dem Blog:
    http://cave2596.tk/wp/
    Schon einmal vielen Dank für Deine Unterstützung!

    Einen tollen Tag noch
    cave2596
     
  2. maxe

    maxe WPDE-Team
    Mitarbeiter

    Registriert seit:
    1. Mai 2008
    Beiträge:
    19.235
    Zustimmungen:
    193
    hast du evtl. in der style.css das padding-top für .panel-content .wrap verändert? Das steht bei dir auf 60em.
     
  3. SirEctor

    SirEctor WPDE-Team
    Mitarbeiter

    Registriert seit:
    28. Oktober 2008
    Beiträge:
    11.797
    Zustimmungen:
    330
    Hast du am .panel-content .wrap etwas geändert? Bei steht dort ein Wert von 60em für padding-top. Normal wären 6em.
     
  4. cave2596

    cave2596 Member

    Registriert seit:
    31. Januar 2015
    Beiträge:
    10
    Zustimmungen:
    0
    Oha, eigentlich habe ich nicht in Erinnerung, das Theme bearbeitet zu haben.
    (Deshalb ja das Child-Theme).
    Nun habe ich TwentySeventeen einfach neu installiert und der Fehler ist behoben.
    D.h. anscheinend war da wirklich etwas falsch.

    Herzlichen Dank für diese superschnelle Antworten!
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden