1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

WP <5.0 Multi-Untersite nicht aufrufbar

Dieses Thema im Forum "Konfiguration" wurde erstellt von Kurt Singer, 29. Mai 2018.

  1. Kurt Singer

    Kurt Singer Well-Known Member

    Registriert seit:
    28. Mai 2017
    Beiträge:
    1.305
    Zustimmungen:
    161
    Ich habe zu meinem Problem zwar zwei ähnliche Themen gefunden, wobei aber nur die Auswirkungen, nicht die Ursachen die gleichen sind.

    Ich habe diese Site zu einer Multisite umfunktioniert. Weil es eine bestehende Site ist, mußte ich Subdomains wählen.

    Ich habe dazu die wp-config.php und die .htaccess entsprechend geändert, bemi Provider auch das SSL-Zertifikat für die Domain inkl. Subdomains eingerichtet.
    Vor der Umstellung habe ich alle PlugIns deaktiviert, nach der Umstellung die Permalinks neu gespeichert.
    Die 1. Untersite soll sein https://blog.ehrenbreitstein.de

    In der Netzwerkverwaltung wird diese Site auch angezeigt, aber ich kann sie weder als Website aufrufen noch zum Dashboard wechseln. In allen Fällen wird nur eine weiße Seite angezeigt.
    Die Datenbank zeigt eine wp_2-Datenbank, ich kann auch z.B. die wp_2_options aufrufen und einsehen. Dort habe ich auch die angelegte Adresse geändert von http:// in https://

    Eine Fehlermeldung lautet: Fehlercode: SSL_ERROR_INTERNAL_ERROR_ALERT

    Bisher blieb alles ohne Erfolg. Was habe ich übersehen?
     
  2. Kurt Singer

    Kurt Singer Well-Known Member

    Registriert seit:
    28. Mai 2017
    Beiträge:
    1.305
    Zustimmungen:
    161
    Ich stelle gerade zu meinem Entsetzen fest, daß außer der Homesite keinerlei Unterseite aufrufbar ist, ob Subdomain oder Unterseite im Ordner :eek::eek::eek:
     
  3. Kurt Singer

    Kurt Singer Well-Known Member

    Registriert seit:
    28. Mai 2017
    Beiträge:
    1.305
    Zustimmungen:
    161
    Das lag an der Umbenennung der .htaccess und ist behoben.
     
  4. Kurt Singer

    Kurt Singer Well-Known Member

    Registriert seit:
    28. Mai 2017
    Beiträge:
    1.305
    Zustimmungen:
    161
    Ich versuchs nochmal mit einer Zusatzinformatione:

    Das ist die neue .htaccess. Ob da vielleicht ein Fehler drin ist?

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    # END WordPress
     
  5. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    9.431
    Zustimmungen:
    1.212
    Unter der "blog." Subdomain erscheint hier eine Sedoparking-Werbung Seite, also ist die Subdomain im 1&1 Backend offenbar nicht korrekt zugeordnet.
     
  6. Kurt Singer

    Kurt Singer Well-Known Member

    Registriert seit:
    28. Mai 2017
    Beiträge:
    1.305
    Zustimmungen:
    161
    Hi, danke. Wenn ich auf den http://-Sites eine weitere der Multisites anlege, muß ich nichts zuordnen. Ich lege die Site an und kann sie aufrufen und bearbeiten. Nur hier ist das nicht der Fall. Und das brachte mich halt auf die Idee, daß das am https:// liegt. Aber was?
     
  7. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    9.431
    Zustimmungen:
    1.212
    Nochmal: Die "blog." Subdomain zeigt bei 1&1 auf eine Platzhalter-Werbeseite, nicht auf WordPress.
     
  8. Kurt Singer

    Kurt Singer Well-Known Member

    Registriert seit:
    28. Mai 2017
    Beiträge:
    1.305
    Zustimmungen:
    161
    Ja, und ich weiß nicht, wie ich das ändern kann. die blog-Subdomain erscheiint bei 1&1 nicht, da kann ich also auch nichts zuordnen.
     
  9. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    9.431
    Zustimmungen:
    1.212
  10. Kurt Singer

    Kurt Singer Well-Known Member

    Registriert seit:
    28. Mai 2017
    Beiträge:
    1.305
    Zustimmungen:
    161
    Hab ich schon - Wordpress gehört nicht zum Support, sagte man mir.
     
  11. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    9.431
    Zustimmungen:
    1.212
    Deine Frage hat nichts mit WordPress zu tun, sondern besteht darin, wie Du die "blog." Subdomain auf einen Ordner zeigen lassen kannst...
     
  12. Kurt Singer

    Kurt Singer Well-Known Member

    Registriert seit:
    28. Mai 2017
    Beiträge:
    1.305
    Zustimmungen:
    161
    Nun, es gibt eben keine Subdomain, sondern eine Multisite mit einer Unterseite.
    Aber egal, ich hab die Multisite gelöscht und richte den Blog jetzt mit einer eigenen WP-Installation ein. Danke trotzdem.
     
  13. helix

    helix Well-Known Member

    Registriert seit:
    28. Juli 2011
    Beiträge:
    1.808
    Zustimmungen:
    27
    Das könnte ein Hinweis darauf sein, dass du unter http sogenannte wildcard-Subdomains hast und unter https nicht.

    OffTopic: Jetzt hast du das Problem ja anders gelöst – vielleicht gut so. Soweit ich sehe, sind hier im Forum nicht so fürchterlich viele, die eine Multi-Installation betreiben, schon erst recht nicht als Sandkiste, dass man einfach kurz was ausprobieren kann. Ich hatte mal eine und hab vor ein paar Jahren das Ding platt gemacht (zugunsten von Einzelinstallationen), weil ich den Vorteil nicht mehr so recht sehen konnte. Je länger es zurückliegt, dass man sowas mal hatte, desto schwieriger wird es, was Vernünftiges dazu sagen zu können. Manches ändert sich. Und manches (mehr) erinnert man einfach nicht mehr richtig.

    Gruß
    helix
     
    Kurt Singer gefällt das.
  14. Kurt Singer

    Kurt Singer Well-Known Member

    Registriert seit:
    28. Mai 2017
    Beiträge:
    1.305
    Zustimmungen:
    161
    Die anderen http-Sites habe ich immer mit Unterordnern und nicht mit Subdomains angelegt. Ich finde Multisites praktisch, weil ich eine Reihe von kostenpflichtigen Domainnamen kündigen konnte und die vielen Seiten (alleine derzeit reduzierte 13 für Thailand) unter wenigen Domains einrichte.

    Aber ich kann nicht einsehen, daß bei Wordpress unter https:// solche Probleme bei Multisites auftauchen, und ich werde weiter meine Versuche machen.
     
  15. helix

    helix Well-Known Member

    Registriert seit:
    28. Juli 2011
    Beiträge:
    1.808
    Zustimmungen:
    27
    Ah, wir nähern uns …
    Es ist natürlich ein Unterschied, ob man eine Multisite mit Unterordnern oder mit Subdomains aufbaut.

    Dann liegt es mit 99% Wahrscheinlichkeit nicht an https, sondern daran, dass du deine Subdomains auf den richtigen Ordner („in dem WordPress liegt“) zeigen lassen musst.
    Wenn du weiter probieren willst: es gibt bei 1&1 in der Konfigurationsoberfläche einen Punkt „webspace verbinden“, dort solltest du weiter kommen.

    Es sind auch Subdomains nicht zwingend an Multi-Installationen gebunden: du kannst auch eine Subdomain anlegen und darauf eine eigene WordPress-Installation am Laufen haben. Dann Subdomain auf eingenen Ordner mit eigener WP-Installation zeigen lassen.

    Gruß
    helix
     
  16. Kurt Singer

    Kurt Singer Well-Known Member

    Registriert seit:
    28. Mai 2017
    Beiträge:
    1.305
    Zustimmungen:
    161
    Ich habe jetzt bei 1&1 wirklich alles durchforstet. Es existiert keine "blog."-Subdomain, also kann ich sie auch nicht auf einen Ordner zeigen lassen, wie hier mehrfach mit Nachdruck vorgeschlagen wird. Mit "Webspace verbinden" habe ich einige Seiten richtig geroutet, aber hier scheint etwas anderes vorzuliegen. Die Wordpress-Multisite sollte doch nach meinem Verständnis beim Anlegen in Ordnern oder, wenn es bereits bestehende Websites sind, in Subdomains alles selbst richtig erstellen, tut es aber in meinem Fall nicht.

    Aber bevor ich mir weiter Prügel einhandele kaufe ich lieber neue Domains dazu o_O
     
  17. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    9.431
    Zustimmungen:
    1.212
  18. Kurt Singer

    Kurt Singer Well-Known Member

    Registriert seit:
    28. Mai 2017
    Beiträge:
    1.305
    Zustimmungen:
    161
    Sehe jetzt keine Frage o_O
     
  19. Kurt Singer

    Kurt Singer Well-Known Member

    Registriert seit:
    28. Mai 2017
    Beiträge:
    1.305
    Zustimmungen:
    161
    Nun habe ich festgestellt, daß wohl als Rest des Multisiteversuches in der Datenbank einige Zeilen übrig geblieben sind, welche mit wp_2_ beginnen. Das sind ja wohl Reste eines Siteanlageversuches. Natürlich traue ich mich nicht, die etwa zu löschen oder so. Was mache ich damit?
     
  20. helix

    helix Well-Known Member

    Registriert seit:
    28. Juli 2011
    Beiträge:
    1.808
    Zustimmungen:
    27
    Dann lege die Subdomain blog.~ an! In der Webspace-Konfigurationsoberfläche … *)

    Die „normale“ Reihenfolge (was ist schon normal …) ist:
    * In der Konfigurationsoberfläche Subdomain anlegen
    * Subdomain auf den Ordner verweisen lassen, in dem WordPress (die Multisite) liegt
    * Innerhalb der Multi-Installation die neue Sub-Seite mit der neuen Subdomain anlegen

    Was die Datenbank angeht:
    * Datenbank-Backup machen – komplett.
    * die vermutlich-nicht-mehr-gebrauchten Tabellen löschen
    * testen, ob alles geht, wie es soll
    *wenn ja: alles gut
    * wenn nein, Backup zurückspielen
    * ggf. mal eines dieser Datenbank-Bereinigungs-PlugIns näher ansehen, z.B. wp-Sweep (wenn das so heißt …) => wahrscheinlich ist „händisch“ in der Datenbank rumfuddeln schon deswegen sicherer, weil man da nur soviel rauslöscht, wie man weiß, dass man ohne Verrenkungen wieder zurückspielen kann, also man „weiß“ irgendwie eher, was man tut …

    *) Wenn der Topf nun aber ein Loch hat? …

    Gruß
    helix
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden