1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Multipage-Umzug, falsche Pfade?

Dieses Thema im Forum "Blog-Netzwerk" wurde erstellt von KuniT, 12. Mai 2019.

  1. KuniT

    KuniT Active Member

    Registriert seit:
    9. August 2014
    Beiträge:
    28
    Zustimmungen:
    0
    Moin moin,

    ich habe jetzt tagelang ausprobiert und recherchiert. Jetzt habe ich keine Idee mehr... vielleicht kann mir jemand helfen?

    Ich habe eine Multisite von einem Server zum anderen umgezogen, mittlerweile alle Updates ausgeführt, die zu Fehlermeldungen wegen php-Version geführt hatten und diverse Pfadvarianten in .htaccess und wp-config.php ausprobiert. Jetzt sehe ich den Wald vor lauter Bäumen nicht mehr.

    Der Domainname ist identisch geblieben. (example.com)
    WordPress habe ich auch wieder im Unterverzeichnid /WP installiert (example.com/WP)
    Es gibt 3 Sites.

    1.) Backup erstellt mit BackWPup + Download aller WP-Dateien
    2.) Einrichten einer neuen Datenbank mit selben Datenbanktabellen-Präfix auf neuem Server
    3.) Neue Datenbankwerte in wp-config.php eingetragen, neue Sicherheitsschlüssel eingetragen
    4.) WP-Dateien mittels FileZilla hochgeladen
    5.) nach diversen Fehlermeldungen Update von WP (5.2) und aller Plugins
    6.) Webspace mit php 7.2

    Jetzt wird mir folgendes angezeigt:
    Eingabe "example.com" -> defaultseite vom Hoster
    Eingabe "example.com/WP/" -> Site 1 korrekt
    Eingabe "example.com/WP/mobil" -> Site 2 korrekt
    Eingabe "example.com/WP/screen" -> Site 3 korrekt

    Bei Eingabe von "example.com" soll mir Site 2 angezeigt werden. Das war beim alten Hoster ok.

    Webspace ist verknüpft mit Hauptverzeichnis /.

    .htaccess:
    RewriteEngine On
    RewriteBase /WP/
    RewriteRule ^index\.php$ - [L]

    wp-config.php:
    define('WP_ALLOW_MULTISITE', true);
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'www.example.com');
    define('PATH_CURRENT_SITE', '/WP/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    Pfade im Backend: URL
    www.example.com/WP
    www.example.com/WP/mobil
    www.example.com/WP/screen

    Pfade in der Datenbank
    Tabelle options: siteurl -> www.example.com/WP/mobil
    home -> www.example.com/WP/mobil
    Tabelle blogs: blog_ID 1: Domain -> www.example.com Path -> /WP/
    blog_ID 3: Domain -> www.example.com Path -> /WP/mobil/
    blog_ID 4: Domain -> www.example.com Path -> /WP/screen/

    Was übersehe ich?
    Sonnige Grüße
    KuniT
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden