1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

MyGallery bleibt weiß

Dieses Thema im Forum "Plugins und Widgets" wurde erstellt von bjoernb, 26. Januar 2007.

  1. bjoernb

    bjoernb Member

    Registriert seit:
    26. Januar 2007
    Beiträge:
    14
    Zustimmungen:
    0
    Hallo,
    habe das MyGalery Plugin lt. Anweisung installiert, aber nach dem aktivieren erhalte ich nur weiße bildschirme im menü, egal welchen Punkt ich auswähle (siehe Screenshot). Wordpress=Version 2.1

    Mein Sever ist we folgt konfiguriert:
    PHP 4.4.2 und PHP 5.1.2
    Safe_mode off
    FreeType 2.1.10
    ImageMagick 6.2.5
    Mysql 4.1.18
    GDlib 2.0.33 mit GIF und JPG
    Perl 5.8.7
    Apache 1.3.34 + mod_rewrite
    PHPMyAdmin 2.6.4

    Was kann man tun?

    EDIT: Ich habe übrigens Wordpress komplett neu installiert (engl. 2.1 + Sprachdatei, verglichen mit z.B. Jommla befinden sich wenige Tabellen in der DB, vielleicht liegt da der Fehler) - Vielleicht sollte ich auch die am WE erscheinde Deutsche V 2.1 installieren?
     
    #1 bjoernb, 26. Januar 2007
    Zuletzt bearbeitet: 26. Januar 2007
  2. tboggi

    tboggi Well-Known Member

    Registriert seit:
    8. Februar 2006
    Beiträge:
    473
    Zustimmungen:
    0
    Ich würde im im Zweifelsfall an den Autor, Thomas, wenden.

    Unter: www.wildbits.de
     
  3. bjoernb

    bjoernb Member

    Registriert seit:
    26. Januar 2007
    Beiträge:
    14
    Zustimmungen:
    0
    Okay ich hab ihm jetzt eine email geschrieben aber ist er auch nicht hier auf dem board unterwegs? ich kann mir echt nur vorstellen dass es an der neuinstallation von WP 2.1 liegt...
     
  4. fym

    fym Well-Known Member

    Registriert seit:
    4. Januar 2005
    Beiträge:
    161
    Zustimmungen:
    0
    Das gleiche Problem hatte ich hier aufm lokalen Webserver auch. Schau mal in deine Datenbank, ob überhaupt alle 3 von myGallery benutzen Tabellen vorhanden sind (*_mygallery, *_mygprelation und *_mypictures) - bei mir wurden die nämlich nur zum Teil erstellt (nur *_mygallery).
     
  5. bjoernb

    bjoernb Member

    Registriert seit:
    26. Januar 2007
    Beiträge:
    14
    Zustimmungen:
    0
    stimmt da liegt wohl der fehler. Ich habe GAR KEINE Tabelle von Mygallery...
     
  6. scav

    scav Well-Known Member

    Registriert seit:
    27. Januar 2007
    Beiträge:
    48
    Zustimmungen:
    0
    Ich schließe mich dir an, ebenfalls KEINE Tabellen. Vielleicht nützt es etwas, das Installationsscript manuell aufzurufen?

    Edit: Nein, tut es nicht ;)
     
    #6 scav, 28. Januar 2007
    Zuletzt bearbeitet: 28. Januar 2007
  7. bjoernb

    bjoernb Member

    Registriert seit:
    26. Januar 2007
    Beiträge:
    14
    Zustimmungen:
    0
    hmm jetzt müsste man wissen obs an WP oder MG liegt... Ich vermute mal eher das irgendwelche SQL-Skripte nicht richtig ausgeführt werden, warum auch immer...Anscheinend hat es aber bei den Usern keine Probleme gegeben, die ein Update von WP 2.0.7 auf 2.1. gemacht haben. Da waren die Tabellen wohl schon von der 2.0.7er vorhanden...
     
  8. Potheen

    Potheen Member

    Registriert seit:
    8. Januar 2007
    Beiträge:
    5
    Zustimmungen:
    0
    Mir fehlt auch eine Tabelle

    wie kann ich die Tabelle wp_mygallery "von Hand" anlegen?
     
  9. fym

    fym Well-Known Member

    Registriert seit:
    4. Januar 2005
    Beiträge:
    161
    Zustimmungen:
    0
    Hier mal eine exportierte Tabellenstrukturen mitsamt Eintrag "mygalleryoptions" in der Options-Tabelle. Hat Wordpress ein anderes Präfix als "wp_" bei euch, muss das dentsprechend geändert/angepasst werden. Vielleicht hilft es ja jemanden und bringt das Plugin zum Laufen :)

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    ~fym
     
  10. bjoernb

    bjoernb Member

    Registriert seit:
    26. Januar 2007
    Beiträge:
    14
    Zustimmungen:
    0
    @ Fym: Danke für den Code, aber das hat leider auch nichts gebracht (hab die Prefixe auch richtig umbenannt..)
     
  11. scav

    scav Well-Known Member

    Registriert seit:
    27. Januar 2007
    Beiträge:
    48
    Zustimmungen:
    0
    Gibt es in Wordpress vielleicht eine Art Debug-Mode für Plugins? Ich konnte da auf die Schnelle nichts finden.

    Edit: Meine Errorlogs bleiben leer, ich habe leider keinerlei Anhaltspunkte wieso das ganze nicht funktioniert...
    Edit2: Ich vermute mittlerweile einfach mal, das es mit WP 2.1 zusammenhängt?

    Edit3: Ist es korrekt, dass die Datei mygallerytmpl.php im ordner "plugins" liegt, also auf der gleichen Ebene wie der Ordner "mygallery"?
     
    #11 scav, 28. Januar 2007
    Zuletzt bearbeitet: 28. Januar 2007
  12. crios

    crios New Member

    Registriert seit:
    5. Juni 2006
    Beiträge:
    4
    Zustimmungen:
    0
    die mygallerytmpl.php ist für dein theme als template gedacht soweit ichd as weiß.

    Schätze das alles liegt mit wp2.1 und mg zusammen, wp soll ja einiges an der db anbindung und so verändert haben. Müssen wir wohl warten, auch wenns mich gerade echt aufregt ;)
     
  13. bjoernb

    bjoernb Member

    Registriert seit:
    26. Januar 2007
    Beiträge:
    14
    Zustimmungen:
    0
    entweder das, oder 2.0.7 installieren, dann MG dann Update auf 2.1. das scheint mir aber eher unsauber deswegen warte ich lieber :?
     
  14. scav

    scav Well-Known Member

    Registriert seit:
    27. Januar 2007
    Beiträge:
    48
    Zustimmungen:
    0
    Die aktuelle Beta habe ich übrigens auch schon (erfolglos) ausprobiert.

    Wann kommt denn die einmalige Installation? Nach Aktivierung des Plugins?
     
  15. alex.rabe

    alex.rabe Well-Known Member

    Registriert seit:
    18. November 2006
    Beiträge:
    243
    Zustimmungen:
    0
    Also mir kommt das alles spanisch vor...

    Ich hab jetzt drei Blogs auf Wp2.1 +myGallery umgerüstet und keine Probleme gehabt.
    Zudem hab ich mal ein komplett leeres WP2.1 under meinen lokalen Horst aufgesetzt und auch dann tritt der Fehler hier nicht auf.

    Wer Lust hat kontaktiert mich mal per PN und schickt mir einen Zugang zu seinem Wordpress, mich würde auch mal interessieren woran das liegen kann...
     
  16. bjoernb

    bjoernb Member

    Registriert seit:
    26. Januar 2007
    Beiträge:
    14
    Zustimmungen:
    0
    So ich hab jetzt die auf der Hauptseite angekündigte Version 2.1 Deutsch runtergeladen. Das ist aber noch eine 2.0.7er Version. Jedenfalls lässt sich MG auf der 2.0.7er WP-Installation völlig problemlos installieren auf einer "frischen"2.1 nicht ! Das kann aber nicht nur bei mir so sein...
     
  17. venus

    venus Well-Known Member

    Registriert seit:
    13. Januar 2007
    Beiträge:
    684
    Zustimmungen:
    0
    :confused:
    hab nur mal schnell reingeschaut:
    PHP:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
     
  18. bjoernb

    bjoernb Member

    Registriert seit:
    26. Januar 2007
    Beiträge:
    14
    Zustimmungen:
    0
    stimmt das wurde jetzt aktualisiert, ich war wohl zu schnell :)
     
  19. bjoernb

    bjoernb Member

    Registriert seit:
    26. Januar 2007
    Beiträge:
    14
    Zustimmungen:
    0
    Jetzt hab ich die 2.0.7 wieder gelöscht und 2.1 DE-Edition installiert. Wieder gleiches Problem: MyGallery lässt sich nach dem aktivieren nicht installieren...
     
  20. crios

    crios New Member

    Registriert seit:
    5. Juni 2006
    Beiträge:
    4
    Zustimmungen:
    0
    macht euch nicht verrückt, wartet bis es ein update seitens mygallery gibt!
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden