1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

myGallery zerschießt index.php

Dieses Thema im Forum "Plugins und Widgets" wurde erstellt von dino, 2. Dezember 2006.

  1. dino

    dino Well-Known Member

    Registriert seit:
    24. Juni 2006
    Beiträge:
    96
    Zustimmungen:
    0
    hallo,

    benutze wordpress 2.0.5, php safe mode ist aus und bisher hat auch alles mit myGallery geklappt, bis vor einigen tagen ein mysql error aufgetaucht ist. hab rausgefunden, dass das daran lag, dass das plugin irgendwie "deaktiviert" wurde - wenn ich im admin menü auf "myGallery" ging, kam wieder "installation". irgendwie komisch. ich habs dann wieder installiert aber dadurch wurde die startseite zerschossen - siehe hier. der rest geht noch, wie man zum beispiel hier oder hier sehen kann. der fehler tritt nur bei der index.php auf. habe jetzt myGallery 1.2 installiert, hatte davor 1.3b7. aber das hat im großen und ganzen nichts geändert. :(

    wo liegt das problem? danke für eure hilfe!

    dino

    edit: achso, es liegt nicht an dem zufallsbild, das rechts in der sidebar angezeigt wird (werden sollte), denn da habe ich jetzt mal den code aus der sidebar.php rausgenommen. kann es evtl. auch am server liegen?

    edit²: was ich gerade rausgefunden habe: es liegt auch nicht an meinem wordpress-theme (orangesky), denn bei anderen themes tritt der gleiche fehler auf. lediglich im ganz alten wordpress classic gehts, aber auch im normalen wordpress standard theme wirds zerschossen.
     
    #1 dino, 2. Dezember 2006
    Zuletzt bearbeitet: 3. Dezember 2006
  2. dino

    dino Well-Known Member

    Registriert seit:
    24. Juni 2006
    Beiträge:
    96
    Zustimmungen:
    0
    ahnung, anyone? :(
     
  3. mfitzen

    mfitzen Well-Known Member

    Registriert seit:
    9. Juli 2006
    Beiträge:
    9.818
    Zustimmungen:
    2
    Also der erste Link (der angeblich zerschossen sein soll) sieht bei mir ganz vernünftig aus.
     
  4. dino

    dino Well-Known Member

    Registriert seit:
    24. Juni 2006
    Beiträge:
    96
    Zustimmungen:
    0
    benutzt du den IE? in dem gehts. versuchs mal mit firefox (falls du den hast). im IE wird nur die sidebar komplett zerstört. im firefox ists der rest.

    btw, geile sig ;)
     
    #4 dino, 3. Dezember 2006
    Zuletzt bearbeitet: 3. Dezember 2006
  5. mfitzen

    mfitzen Well-Known Member

    Registriert seit:
    9. Juli 2006
    Beiträge:
    9.818
    Zustimmungen:
    2
    Ups sorry, mein Fehler. Ich wusste nicht wie das Theme richtig aussieht. Hatte mir Deine Seite im FF angesehen und da sah eigentlich alles recht ordentlich aus. Nachdem ich dann jetzt mal den IE ausgegraben hab, sehe ich auch den Unterschied :D So auf Anhieb kann ich nicht sagen woran es liegen könnte. Wieso eigentlich index2.php? Funktioniert es denn wenn Du die Galerie löscht (also auch die DB-Einträge)?
     
  6. dino

    dino Well-Known Member

    Registriert seit:
    24. Juni 2006
    Beiträge:
    96
    Zustimmungen:
    0
    index2.php, damit ich hier mein Problem schildern kann und besucher nicht auf anhieb geschockt sind - schau dir doch mal die index.php an ;) das hab ich mit absicht so gemacht, daran liegts aber auch nicht. löschen? es reicht schon, wenn ich das plugin deaktiviere. löschen würde ich es ungern .. das einbauen der galerie hat mich bestimmt 5 stunden reine arbeitszeit gekostet. :(

    edit: mist, hab bemerkt, dass es mit index2.php nicht klappt. hab das ganze jetzt mal wieder zurückgestellt, also wieder direkt hier drauf zugreifen .. danke.
     
    #6 dino, 3. Dezember 2006
    Zuletzt bearbeitet: 3. Dezember 2006
  7. Ilona

    Ilona Well-Known Member

    Registriert seit:
    17. November 2005
    Beiträge:
    84
    Zustimmungen:
    0
    Falls deine Sidebar "floatet", könnte es damit damit zu tun haben, worum es in diesem Thread ging: http://forum.wordpress-deutschland.org/showthread.php?t=8148&page=2

    Da steht auch, wie man es eventl. lösen kann.

    Wie gesagt, vielleicht. Die CSS aus MyGallery beisst sich wahrscheinlich mit der CSS deines Themes.
     
  8. dino

    dino Well-Known Member

    Registriert seit:
    24. Juni 2006
    Beiträge:
    96
    Zustimmungen:
    0
    Danke, Ilona, aber ich bezweifle, dass es an einem einzelnen Theme liegt, weil das Problem bei allen meiner Themes auftaucht (also auch den Standard-Wordpress Themes, bis auf Wordpress Classic, da klappts). Ich glaube eher es liegt irgendwo am CSS von myGallery .. jetzt ist nur die Frage, wo .. bisher hat ja eigentlich immer alles super funktioniert und nur jetzt kommt auf einmal dieser Fehler.
     
  9. Ilona

    Ilona Well-Known Member

    Registriert seit:
    17. November 2005
    Beiträge:
    84
    Zustimmungen:
    0
    Merkwürdige Sache das... Müsste aber zu fixen sein. Folgendes: Wenn ich deine Seite durch den Validator schicke, kriege ich mal eben 19 Fehler. Hast du da schon mal angesetzt?
     
  10. dino

    dino Well-Known Member

    Registriert seit:
    24. Juni 2006
    Beiträge:
    96
    Zustimmungen:
    0
    hui .. danke, das habe ich noch gar nicht probiert. werde mich da mal ranhalten. danke!!

    edit: habs!! ach du meine güte, jetzt weiß ich, worans lag. hatte die bilder in einem post mit <!--- auskommentiert, dabei also einen - zu viel gesetzt. das war's. jetzt fixx ich gleich noch die anderen probleme, die ich dank validator gefunden habe. wow, danke vielmals, ilona.

    ps: achja, seit wann braucht ein img-tag ein </img>? wäre mir ehrlich gesagt recht neu .. oO
     
    #10 dino, 3. Dezember 2006
    Zuletzt bearbeitet: 3. Dezember 2006
  11. Ilona

    Ilona Well-Known Member

    Registriert seit:
    17. November 2005
    Beiträge:
    84
    Zustimmungen:
    0
    Gern geschehen. :smile:
    Keinen </img> sondern nur einen Endtag. So hier: ... />
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden