1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

MySQL-Version: 5.0.32 -trotzdem installation nicht möglich

Dieses Thema im Forum "Installation" wurde erstellt von chako, 9. Februar 2010.

  1. chako

    chako Member

    Registriert seit:
    9. Februar 2010
    Beiträge:
    5
    Zustimmungen:
    0
    hi,
    wenn ich
    <?php printf("MySQL-Version: %s\n", mysql_get_client_info()); ?>
    aufrufe - kommt als version MySQL-Version: 5.0.32 raus.
    trotzdem scheitere ich bei der installation.
    You cannot install because WordPress 2.9.1 requires MySQL version 4.1.2 or higher. You are running version 4.0.27.
    lt. provider, handelt es sich um einen cluster mit mysql von 4-5.x !?

    hat jemand erfahrung damit?

    thx
     
  2. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.822
    Zustimmungen:
    0
    Wie der Funktionsname schon impliziert, liefert mysql_get_client_info() Informationen über das Clientmodul, nicht den Server. Mit "WordPress 2.9.1 requires MySQL version ..." ist aber die Serverversion gemeint.

    Gruß
    Ingo
     
  3. ncd25

    ncd25 Member

    Registriert seit:
    14. Februar 2006
    Beiträge:
    12
    Zustimmungen:
    0
    Hallo, auch ich habe dasselbe Problem. Der Support bei meinem Provider meinte lediglich ich solle Wordpress so umkonfigurieren, dass es bei der Installation nicht den Installationsstring ausliest, sondern eine "select version" Abfrage macht.

    Kann man das als Nicht-Entwickler denn überhaupt? Wenn ja wie denn bitte?
     
  4. Marcus[IS]

    Marcus[IS] Well-Known Member

    Registriert seit:
    23. August 2009
    Beiträge:
    5.021
    Zustimmungen:
    7
    @ncd25;

    ich poste das jetzt mal hier herein und nicht in deinem Beitrag, da ich in einem anderen Beitrag gerade gelesen habe, dass sich die WP Entwickler im Deutschen Forum wohl kaum rumtreiben. ;)

    Ich habe mich mal bei worpress.org im Forum umgesehen und dies ist ein Eintrag der noch nicht so alt ist.

    Scheinbar hat jemand das selbe Problem mit ein paar Änderungen im Core behoben und die Änderungen im Forum gepostet.

    Hier der Beitrag

    Allerdings gebe ich keine Gewähr, dass diese Schritte wirklich hinhauen. ;)
     
  5. ncd25

    ncd25 Member

    Registriert seit:
    14. Februar 2006
    Beiträge:
    12
    Zustimmungen:
    0
    Danke für Deinen Input, das war's was ich gesucht habe.

    Habe jedoch den dort beschriebenen Lösungsweg etwas abgeändert:

    erstmal habe ich in wp-includes/wp-db.php die benötigte Version geändert:

    PHP:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    zu:

    PHP:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    dann habe ich die aktuelle mySQL Version hardcoded in wp-admin/upgrade.php eingetragen, also:

    PHP:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    zu:

    PHP:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Installieren hat damit funktioniert und es scheint auch alles zu laufen. Bitte aber nicht darauf verlassen - bin wie gesagt kein Entwickler.
     
  6. ncd25

    ncd25 Member

    Registriert seit:
    14. Februar 2006
    Beiträge:
    12
    Zustimmungen:
    0
    Nachtrag zu Wordpress Version 3:

    In Version 3.0 findet man in wp-db.php an besagter Stelle (dort wo '4.1.2' stehen sollte) nur mehr die Variable $required_mysql_version.

    Den Wert dieser Variablen kann man unter wpincludes/version.php auf '2.1.2' (oder was immer man möchte) setzen. Dann klappt die Installation wunderbar.