1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Nach Installation von WPMU erscheint Fehler 500

Dieses Thema im Forum "WordPress MU" wurde erstellt von redcat63, 20. November 2007.

  1. redcat63

    redcat63 Well-Known Member

    Registriert seit:
    31. März 2006
    Beiträge:
    1.036
    Zustimmungen:
    0
    Ich habe soeben Wordpress MU installiert.
    Scheinbar hat auch alles geklappt.
    Wenn ich aber dann den Blog aufrufen oder mich anmelden will dann erscheint folgende Fehlermeldung:
    Ich habe ein Paket bei Strato und kann aus diesem Grund nicht die mod_rewrite ändern.
    Hat das was damit zu tun? Oder warum kommt diese Fehlermeldung?
    Vielen Dank für Eure Hilfe im Voraus.

    VG Elke
     
  2. greenhorn77

    greenhorn77 Active Member

    Registriert seit:
    18. November 2007
    Beiträge:
    36
    Zustimmungen:
    0
    Lösch doch mal die .htaccess?
     
  3. GIGALinux

    GIGALinux Well-Known Member

    Registriert seit:
    28. Dezember 2005
    Beiträge:
    818
    Zustimmungen:
    0
    Würde ich auch vorschlagen, ich glaube kaum dass PHP den 500er erzeugt. Hat den dein Strato-Paket mod_rewrite?

    Gruß Dennis
     
  4. redcat63

    redcat63 Well-Known Member

    Registriert seit:
    31. März 2006
    Beiträge:
    1.036
    Zustimmungen:
    0
    Hallo,

    vielen Dank für Euren beistand.

    Wenn ich die .htaccess lösche dann läd er und läd er und läd er... und dann:
    passiert gar nichts. D. h. die vorher angezeigte Seite (z. B. Google) wird weiterhun angezeigt. Das habe ich sowohl beim IE7 als auch beim Opera ausprobiert.

    Meine .htaccess-Datei sieht so aus:
    Die Datei Datei mod_rewrite gibt es nicht, die wird von Strato verwaltet und von denen auch aus Sicherheitsgründen nicht geändert.
    Sollte Ihr noch eine Idee haben, würde ich mich sehr freuen.
    Vielen Dank im Voraus.

    VG Elke
     
  5. greenhorn77

    greenhorn77 Active Member

    Registriert seit:
    18. November 2007
    Beiträge:
    36
    Zustimmungen:
    0
    Hi,

    bei mir habe ich auf die zweite Zeile der .htaccess verzichtet. Die hat bei mir auch nur Fehlermeldungen verursacht.

    Was hast du für ein Paket bei Strato?

    Gruss
     
  6. redcat63

    redcat63 Well-Known Member

    Registriert seit:
    31. März 2006
    Beiträge:
    1.036
    Zustimmungen:
    0
    ich habe eben mal verschiedene Sachen getestet:
    wenn ich alle Befehle auskommentiere, dann läd er bis zum Nimmerleinstag (s.o.)
    Wenn ich ein oder mehrere Befehle nicht auskommentiere, dann bringt er die o.g. Fehlermeldung.
    Auch das Hinzufügen der Zeile:
    AddType application/x-httpd-php5 .php .php5
    hat keinerlei Wirkung.

    Bei dem Paket handelt es sich um das Premium S-Paket.
    Hast Du noch eine Idee?
    Vielen Dank im Voraus.
    Elke
     
  7. greenhorn77

    greenhorn77 Active Member

    Registriert seit:
    18. November 2007
    Beiträge:
    36
    Zustimmungen:
    0
    Ist WPMU im Rootverzeichnis, oder hast du einen Unterordner angelegt? Soweit ich weiss läuft es nur aus dem Rootverz. heraus.
     
  8. GIGALinux

    GIGALinux Well-Known Member

    Registriert seit:
    28. Dezember 2005
    Beiträge:
    818
    Zustimmungen:
    0
    Stimmt nicht so ganz, aber im Root-Verzeichnis läuft es am besten normalerweise.
     
  9. redcat63

    redcat63 Well-Known Member

    Registriert seit:
    31. März 2006
    Beiträge:
    1.036
    Zustimmungen:
    0
    Ich habe ein Unterverzeichnis namens blog angelegt und darin befindet sich WPMU.
    Habe ich trotzdem noch eine Chance? ;)

    VG Elke
     
  10. GIGALinux

    GIGALinux Well-Known Member

    Registriert seit:
    28. Dezember 2005
    Beiträge:
    818
    Zustimmungen:
    0
    Normaler Weise ja, hast du schon installiert?
     
  11. redcat63

    redcat63 Well-Known Member

    Registriert seit:
    31. März 2006
    Beiträge:
    1.036
    Zustimmungen:
    0
    Ja, ich habe schon installiert und er hat auch Tabellen erstellt, die htaccess und die wp-config.php angelegt.
    Ich gehe davon aus, das alles soweit korrekt gelaufen ist, denn nach der Installation hat er mir erzählt, dass die Installation erfolgreich war.
    Hast Du noch eine Idee?
    Vielen Dank im Voraus.
    Elke
     
  12. GIGALinux

    GIGALinux Well-Known Member

    Registriert seit:
    28. Dezember 2005
    Beiträge:
    818
    Zustimmungen:
    0
    Ich denke eher daran, dass dir die Option mod_rewrite fehlt. Vielleicht habe ich es überlesen, hast du schon mal versucht die .htaccess testweise in z.B. .htaccess_tmp um zu benenen und gucken was dann passiert?

    Vielleicht mal Tante Google fragen, ob andere allgemein mit dem normalen WordPress und .htaccess bei Strato Probleme haben?

    Gruß Dennis
     
  13. redcat63

    redcat63 Well-Known Member

    Registriert seit:
    31. März 2006
    Beiträge:
    1.036
    Zustimmungen:
    0
    Hallo GIGALinux,

    vielen Dank für Eure bisherige Hilfe.
    Nun zu Deinen Fragen:
    Wenn ich die htaccess umbenenne, dann passiert genau das Selbe als wenn ich sie lösche:
    er läd ewig und zeigt anschließend die Seite an, die ich vorher auf dem Bildschirm hatte.

    Tante Google ;) sagt leider garnichts dazu, d.h. wenn ich Einträge dazu finde, dann geht es lediglich um die Permalinkstrukturen. :(

    Ehrlich gestanden befürchte ich ebenfalls, dass es an der fehlenden mod_rewrite liegt, wobei ich mich frage, was da geregelt bzw. eingestellt wird und inwiefern und warum WPMU diese benötigt. Denn das normale WP lebt ja auch ganz gut ohne diese Datei.

    VG Elke

    Edit:
    Mir fällt gerade ein:
    Liegt das Problem vielleicht bei den Permalinkstrukturen, d.h. hat WPMU automatisch als default-Wert dies so eingestellt?
    Das ließe sich ggf. ändern, indem man wie bei dem normalen WP einfach ein /index.php davor setzt.
    Ich werde das gleich mal überprüfen und mich wieder melden.

    Elke
     
    #13 redcat63, 23. November 2007
    Zuletzt bearbeitet: 23. November 2007
  14. GIGALinux

    GIGALinux Well-Known Member

    Registriert seit:
    28. Dezember 2005
    Beiträge:
    818
    Zustimmungen:
    0
    Bei WordPress MU gibt es diese Sache "/index.php" davor, wie bei dem normalen WordPress, nicht. mod_rewrite braucht WordPress MU um das Dateienverzeichnes "/files" zu laden.

    Gruß Dennis
     
  15. redcat63

    redcat63 Well-Known Member

    Registriert seit:
    31. März 2006
    Beiträge:
    1.036
    Zustimmungen:
    0
    Hallo Dennis,

    Du schreibst:
    Was meinst Du damit? Ich stehe im Moment auf dem Schlauch.
    (Ein Verzeichnis files habe ich nicht gefunden. Wo soll das sein?)

    Das mit index.php etc. habe ich in allen möglichen Varianten (in Verbindung mit der .htaccess getestet. Funktioniert aber leider nicht. :?
    Ist wp_1 eigentlich der Hauptweblog, d. h. greift er auf die Informationen, die in den Tabellen wp_1 stehen, zurück, wenn ich die Adresse eingebe?

    Verwendet WPMU grundsätzlich und von Anfang an Permalinks oder wie sieht der Default-Wert aus?
    Vielen Dank schon einmal im Voraus.
    Elke
     
  16. GIGALinux

    GIGALinux Well-Known Member

    Registriert seit:
    28. Dezember 2005
    Beiträge:
    818
    Zustimmungen:
    0
    Moin Moin,

    das Verzeichnis "files" wird automatisch durch das mod_rewrite erzeugt. Man kann es nicht sehen, weil es es nicht gibt, aber doch aufrufbar ist.

    WordPress MU erkennt anhand der Domain um welchen Blog es sich handelt. Dann wird die blog_id erzeugt und der ganze Rest wird aus den wp_*_*-Tabellen geladen.

    Gruß Dennis
     
  17. redcat63

    redcat63 Well-Known Member

    Registriert seit:
    31. März 2006
    Beiträge:
    1.036
    Zustimmungen:
    0
    Wie sieht der Befehl in der mod_rewrite tatsächlich aus?
    (ggf. würde ich Strato fragen, ob diese Zeile drin steht.)
    Ist dieser Befehl in der mod_rewrite standardmäßig drin?
    Kann ich irgendwie feststellen, ob dieses Verzeichnis "files" vorhanden ist?
    Kann man ggf. dieses Verzeichnis anderweitig erstellen, damit es WPMU zur Verfügung steht?

    Und weil ich ganz neugierig bin: ;)
    Wozu wird es benötigt?
    In welchen Dateien kommt dies zum Tragen?

    Vielen Dank (im Voraus).
    VG Elke
     
  18. GIGALinux

    GIGALinux Well-Known Member

    Registriert seit:
    28. Dezember 2005
    Beiträge:
    818
    Zustimmungen:
    0
    Das "/files/"-Verzeichnis ist für die Uploades des Blogs. Man könnte alles umschreiben, also /index.php/ in die URL und auch die files-Sache kann man überschreiben, z.B. auf: /files/index.php/meine_arbeit.jpg

    Wäre möglich, aber kostet etwas arbeit.

    Gruß Dennis

    P.S.: Vielleicht schreibt ich ein Tutorial ;).
     
  19. redcat63

    redcat63 Well-Known Member

    Registriert seit:
    31. März 2006
    Beiträge:
    1.036
    Zustimmungen:
    0
    Nur zu. Das wäre super. :)
    Denn noch weiß ich nicht, was und wo ich die Änderungen vornehmen müsste.

    Euch allen ein wunderschönes Wochenende.
    VG
    Elke