1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

nach server wechsel fehler 500 nichts geht mehr

Dieses Thema im Forum "Installation" wurde erstellt von timur87, 16. Januar 2019.

  1. timur87

    timur87 Member

    Registriert seit:
    16. Januar 2019
    Beiträge:
    10
    Zustimmungen:
    0
    hallo liebe gemeinde
    ich hoffe das ihr mir bei meinem problem helfen könnt..

    hab 2 wp seiten gewechselt auf dem neuen server gleiche ip
    eine von der wp seite hat geklapt nach ein paar anpassung aber die 2te will einfach nicht ich suche nun ganze 5 tage nach dem problem aber bin am verzweifeln ...:(

    ich bin wie folgt vorgegangen

    hab mir die db sql vorgenommen und durch suchen und ersetzen den pfad auf dem server angepasst
    da meine domain geblieben ist war dies nicht notwendig

    dann hab ich in wp-config noch meine mysql daten angepasst und meine db und die seite selber über ftp hochgeladen

    aber ich komme aus dem fehler 500 nicht raus
    würde gerne alles neu machen wenn dort nicht viel arbeit drin stecken würde ...

    wie gesagt hoffe ich das ihr mir hier weiter helfen könnt
     
  2. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    8.418
    Zustimmungen:
    924
    Können statische Dateien wie deinedomain.de/readme.html aufgerufen werden?

    Was steht im Error-Log des Servers?
     
  3. SirEctor

    SirEctor Well-Known Member
    Ehrenmitglied

    Registriert seit:
    28. Oktober 2008
    Beiträge:
    12.341
    Zustimmungen:
    417
    Was sagen die Error-Logs? Hast Du schon mal den Debug-Modus in WP aktiviert? Welche Fehler spuckt dieser aus?
     
  4. timur87

    timur87 Member

    Registriert seit:
    16. Januar 2019
    Beiträge:
    10
    Zustimmungen:
    0
    @b3317133
    deinedomain.de/readme.html kann ich aufrufen.

    @SirEctor
    debug hab ich versucht über wp-config einzustellen aber irgendwie ändert sich nichts wie kann ich es genau anstellen ?
    ohne mich einlogen zu müssen denn nichts geht ...
     
  5. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    8.418
    Zustimmungen:
    924
    Anleitung für wp-config.php, Fehler landen dann in wp-content/debug.log

    Dort ändern / einfügen wo vorher define( 'WP_DEBUG', false ); stand.
     
  6. SirEctor

    SirEctor Well-Known Member
    Ehrenmitglied

    Registriert seit:
    28. Oktober 2008
    Beiträge:
    12.341
    Zustimmungen:
    417
    Kontrolliere auch noch mal genau die wp-config.php. Evtl. hast du dort wichtige Zeichen gelöscht ohne es zu bemerken.
     
  7. timur87

    timur87 Member

    Registriert seit:
    16. Januar 2019
    Beiträge:
    10
    Zustimmungen:
    0
    @b3317133

    hab es nun in die wp-config eingefügt nun spukt er wenn ich die seite aufrufe folgendes aus

    <? php
    / **
    * Vorderseite der WordPress-Anwendung. Diese Datei tut nichts, lädt aber
    * wp-blog-header.php, das WordPress dazu auffordert, das Design zu laden.
    *
    * @package WordPress
    * /
    / **
    * Weist WordPress an, das WordPress-Theme zu laden und auszugeben.
    *
    * Var Bool
    * /
    define ('WP_USE_THEMES', true);
    / ** lädt die WordPress-Umgebung und die Vorlage * /
    required (dirname (__FILE__). '/wp-blog-header.php');



    -->aber wp-content/debug.log gibt es nicht


    @SirEctor

    ich werde gleich mal eine orginale runterladen und meine daten einfügen sag gleich bescheid
     
  8. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    8.418
    Zustimmungen:
    924
    Das ist der Code der Datei index.php mit einem fehlerhaften PHP-Tag am Anfang und auch fehlerhaften Kommentarzeichen und fehlerhaftem PHP-Code...

    Falsch: <? php

    Richtig: <?php

    Falsch: / **
    Falsch: * /

    Richtig: /**
    Richtig: */

    Falsch: required( ... )
    Richtig: require( ... )

    Eine korrekte Datei index.php im WordPress Hauptordner sieht so aus:
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
     
  9. timur87

    timur87 Member

    Registriert seit:
    16. Januar 2019
    Beiträge:
    10
    Zustimmungen:
    0
    @SirEctor

    die neue wp-config hat auch nichts gebracht ..

    @b3317133
    also muss ich auf spuren suche nach deiner legende gehen ?

    @b3317133

    hab die index.php im Stammverzeichnis nun geändert trotzdem gibt es keine /wp-content/debug.log ...
     
    #9 timur87, 16. Januar 2019
    Zuletzt von einem Moderator bearbeitet: 16. Januar 2019
  10. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    8.418
    Zustimmungen:
    924
    Link zur Seite?

    Und die eigentliche Frage: Wie konnte die index.php so fehlerhaft werden? Ggf. sollte man alle Systemdateien aus einem frischen Installationsarchiv der gleichen Version wie derzeit installiert überschreiben.
     
  11. timur87

    timur87 Member

    Registriert seit:
    16. Januar 2019
    Beiträge:
    10
    Zustimmungen:
    0
    hast pn!

    wp 5.0.3 überschreiben tue ich

    wp-admin/
    wp-includes/
    und das stammverzeichnis oder ?

    hab dies nun getan keine Änderung
     
    #11 timur87, 16. Januar 2019
    Zuletzt von einem Moderator bearbeitet: 16. Januar 2019
  12. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    8.418
    Zustimmungen:
    924
    1. Auf dem Server läuft kein PHP, alle PHP-Dateien werden derzeit direkt als Text ausgegeben.
    2. In der derzeit auch als Text ausgegebenen Datei wp-config.php fehlt am Anfang das Kommentar Startzeichen /**
    Also erstmal PHP aktivieren, dann klären wie die index.php so fehlerhaft werden konnte, und klären wohin das Kommentar Startzeichen der wp-config.php verschwunden ist.

    Alles sehr seltsam... o_O
     
  13. timur87

    timur87 Member

    Registriert seit:
    16. Januar 2019
    Beiträge:
    10
    Zustimmungen:
    0
    1. hab vergessen umzustellen ist nun wieder an php für die seite
    2. * war die antwort nun geht es super ich bin verückt geworden endlich :)

    super danke @b3317133 und @SirEctor
     
  14. timur87

    timur87 Member

    Registriert seit:
    16. Januar 2019
    Beiträge:
    10
    Zustimmungen:
    0
    aber verstehen will ich es trotzdem nicht denn da oben hab ich nichts geändert ...
     
  15. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    8.418
    Zustimmungen:
    924
    Könnte an der über 2 Jahre alten Apache Version liegen, vielleicht hat sich ja jemand eingeschlichen... Und das autom. Directory Listing könnte man noch abschalten, siehe z.B. deinedomain.de/wp-includes/ usw.
     
  16. timur87

    timur87 Member

    Registriert seit:
    16. Januar 2019
    Beiträge:
    10
    Zustimmungen:
    0
    apache2 ist aktuell
    autom. Directory Listing ist vom vorteil bei dem linux server
     
  17. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    8.418
    Zustimmungen:
    924
    Apache 2.4.37 vom 18.10.2018 wäre aktuell, auf dem Server läuft Apache 2.4.25 vom 16.12.2016

    Autom. Directory Listing kann auch von Nachteil sein, bei manchen Installationen landen auch mal Dinge in /wp-content/uploads/ die man nicht gelistet haben will usw.
     
  18. timur87

    timur87 Member

    Registriert seit:
    16. Januar 2019
    Beiträge:
    10
    Zustimmungen:
    0
    @b3317133

    hast mich überzeugt habs nun ausgeschaltet und apache neu gestartet danke :)

    jap stimmt kann sein aber dann gibt es bestimmt noch keine packete für meine disbu vom server denn server sagt selber alles aktuell

    Server version: Apache/2.4.25 (Debian)
    Server built: 2018-11-03T18:46:19
     
  19. timur87

    timur87 Member

    Registriert seit:
    16. Januar 2019
    Beiträge:
    10
    Zustimmungen:
    0
    vielen dank nochmal hab mich echt verückt gesucht :)
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden