1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Nach Serverwechsel Probleme

Dieses Thema im Forum "Installation" wurde erstellt von skydrak, 23. November 2005.

  1. skydrak

    skydrak Member

    Registriert seit:
    23. November 2005
    Beiträge:
    24
    Zustimmungen:
    0
    Hallo,

    ich wechselte von einem Server auf einen neuen. Nur jetzt gibt es das Problem, das die Permalinks ohne www anscheinend nicht funktionieren... :(

    Zu sehen ist es unter http://skydrak.de/2005/11/22/keiner-hats-gemerkt . Weiß jemand Rat?
     
  2. \0

    \0 Well-Known Member

    Registriert seit:
    13. Mai 2005
    Beiträge:
    1.569
    Zustimmungen:
    0
    selbst mit www. kommt eine weiße seite.
     
  3. Olaf

    Olaf WPDE-Team
    Mitarbeiter

    Registriert seit:
    3. September 2004
    Beiträge:
    2.737
    Zustimmungen:
    29
    ...lösche die .htaccess mal und erstelle sie im adminbereich neu.
     
  4. skydrak

    skydrak Member

    Registriert seit:
    23. November 2005
    Beiträge:
    24
    Zustimmungen:
    0
    Es klappt nicht :(
     
  5. Olaf

    Olaf WPDE-Team
    Mitarbeiter

    Registriert seit:
    3. September 2004
    Beiträge:
    2.737
    Zustimmungen:
    29
    sieht so aus, dass dein neuer Server "mod_rewrite" nicht unterstützt!
     
  6. skydrak

    skydrak Member

    Registriert seit:
    23. November 2005
    Beiträge:
    24
    Zustimmungen:
    0
    doch, es ist auf jedenfall geladen und mit testeinträgen klappt es auch :rolleyes:
     
  7. \0

    \0 Well-Known Member

    Registriert seit:
    13. Mai 2005
    Beiträge:
    1.569
    Zustimmungen:
    0
    Was soll diese weiße Seite. Poste bitte mal deine .htaccess datei.
     
  8. skydrak

    skydrak Member

    Registriert seit:
    23. November 2005
    Beiträge:
    24
    Zustimmungen:
    0
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Siehe den Testeintrag, daran sieht man das mod_rewrite funktioniert wenn man es testet.
     
  9. \0

    \0 Well-Known Member

    Registriert seit:
    13. Mai 2005
    Beiträge:
    1.569
    Zustimmungen:
    0
    wie ist die einstellung bei deinem Provider mit dem Verzeichnis der domain?
    also skydrak.de befindet sich im verzeichnis /var/www/....
    Falls sich dort am Ende ein / befindet, entferne es.
     
  10. skydrak

    skydrak Member

    Registriert seit:
    23. November 2005
    Beiträge:
    24
    Zustimmungen:
    0
    *g* Der Provider bin ich *lach*

    Also in der conf beim Homedir das / entfernen, wenn es da ist?
     
  11. \0

    \0 Well-Known Member

    Registriert seit:
    13. Mai 2005
    Beiträge:
    1.569
    Zustimmungen:
    0
    ja bei plesk nachschauen und notfalls entfernen. Sry hab diesmal keine Tiefenanalyse gemacht :D
     
  12. skydrak

    skydrak Member

    Registriert seit:
    23. November 2005
    Beiträge:
    24
    Zustimmungen:
    0
    Nachgeschaut ;)

    Ist kein / am Ende...
     
  13. \0

    \0 Well-Known Member

    Registriert seit:
    13. Mai 2005
    Beiträge:
    1.569
    Zustimmungen:
    0
    Was sagt das Errorlogfile des Apache bei den Aufrufen? Schön das du der Provider bist, so bekommen wir das besser gelöst.
     
  14. skydrak

    skydrak Member

    Registriert seit:
    23. November 2005
    Beiträge:
    24
    Zustimmungen:
    0
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Die letzten Einträge
     
  15. \0

    \0 Well-Known Member

    Registriert seit:
    13. Mai 2005
    Beiträge:
    1.569
    Zustimmungen:
    0
    und der access log?
     
  16. skydrak

    skydrak Member

    Registriert seit:
    23. November 2005
    Beiträge:
    24
    Zustimmungen:
    0
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
     
  17. \0

    \0 Well-Known Member

    Registriert seit:
    13. Mai 2005
    Beiträge:
    1.569
    Zustimmungen:
    0
    wirf bitte mal folgende zeile aus der .htaccess raus

    oder lösche das ganze file und rufe die permalinkseite im wp-admin erneut auf.
     
  18. skydrak

    skydrak Member

    Registriert seit:
    23. November 2005
    Beiträge:
    24
    Zustimmungen:
    0
    Mein Anbieter hat grad Stellung bezogen:

    Beim Schreiben dieser Antwort ist uns noch in den Sinn gekommen, dass dies mit der aktuellen PHP Version zusammen haengen koennte, welche auch in Form des aktuellen apache2-mod_php4 Pakets von SuSE Probleme verursacht. Im Zuge dessen haben wir gesehen, dass Sie php-4.4.1 auf Ihrem Server aufgespielt haben, welche, ebenso wie das aktuelle SuSE Paket, zu allerlei Fehlern fuehrt. Ein Lookup der PHP Bug Datenbank bringt beispielsweise folgenden Eintrag hervor:
    http://bugs.php.net/bug.php?id=35059&edit=1

    Ich wuerde Sie daher bitten Ihre WordPress Installation auf skydark.de mit einer originalen SuSE PHP Version (Version _nicht_ neuer als 02.09.2005) zu testen und uns Feedback zu geben.

    Erlauben Sie uns bitte noch die Nachfrage, von wo Sie die php-4.4.1 Pakete bezogen haben.
     
  19. \0

    \0 Well-Known Member

    Registriert seit:
    13. Mai 2005
    Beiträge:
    1.569
    Zustimmungen:
    0
    versuch mal die permalinks abzuschalten. Da der normale Aufruf ja klappt ... wenn du die Permalinks abschaltest sollte eigentlich alles gehen.
     
  20. skydrak

    skydrak Member

    Registriert seit:
    23. November 2005
    Beiträge:
    24
    Zustimmungen:
    0
    So, auf php 5 geupdated und es klappt ;)
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden