1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

nach Update von WP kein zugriff auf Blog

Dieses Thema im Forum "Installation" wurde erstellt von Tagwerker, 24. Mai 2019.

Schlagworte:
  1. Tagwerker

    Tagwerker Active Member

    Registriert seit:
    7. Januar 2019
    Beiträge:
    28
    Zustimmungen:
    0
    Hallo!

    Die Tage wurde ein automatisiertes Update vorgenommen, jetzt kein zugriff auf meinen Blog. https://tagwerk-blog.de/ die Seite bleibt weiß! Da ich keine Wege weiß, wie das wieder zum Laufen bringen kann, ist es verloren. Wer kann mir da helfen?

    ---

    War gerade auf Server und habe eine liesmich.ht.. Datei vom 22.05.2019 auf dem Server

    Habe niemanden den Auftrag erteilt Änderungen vorzunehmen. :(
     
    #1 Tagwerker, 24. Mai 2019
    Zuletzt von einem Moderator bearbeitet: 24. Mai 2019
  2. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    5.345
    Zustimmungen:
    449
    Genaueres könnte sagen, wenn man sich das Server Error-Log im Hosting ansieht oder ggf. auch wenn man WP_DEBUG aktiviert und die Meldungen in wp-content/debug.log schreiben lässt
     
  3. Tagwerker

    Tagwerker Active Member

    Registriert seit:
    7. Januar 2019
    Beiträge:
    28
    Zustimmungen:
    0
    Parse error: syntax error, unexpected end of file, expecting variable (T_VARIABLE) or ${ (T_DOLLAR_OPEN_CURLY_BRACES) or {$ (T_CURLY_OPEN) in /usr/www/users/tagwerc/wp-config.php on line 104

    Habe auch schon versucht diese Dateien auf, vor, dem neuen Backup zu setzen. Läuft nicht.
     
  4. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    5.345
    Zustimmungen:
    449
    Was steht in ca. Zeile 100-110 in der Datei wp-config.php?

    Wenn Du irgendwas sonstiges versuchst, macht eine systematische Fehlersuche hier eher keinen Sinn, weil man nicht weiss, ob Teile des Problems dann durch Deine Versuche dazukommen, Du verschlimmerst die Situation wahrscheinlich nur.
     
  5. Tagwerker

    Tagwerker Active Member

    Registriert seit:
    7. Januar 2019
    Beiträge:
    28
    Zustimmungen:
    0
    Gibt es nur die Zeile 100 -103


    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');
     
  6. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    5.345
    Zustimmungen:
    449
    Dann ist ggf. weiter oben in der Datei was nicht in Ordnung bzgl. der PHP-Syntax.

    Du kannst eine komplette Version der wp-config.php posten, ABER lass die vier Zeilen mit "DB_xxx" und die acht Zeilen ab AUTH_KEY weg und nutze das kleine [+] hier im Forum Editor, um das als "Code" einzufügen.

    Ein seltsamer Effekt, wenn Du manuell nichts geändert hast. Evtl. ein Hack oder ein wildgewordenes Cache- oder "Sicherheits"-Plugin.
     
  7. Tagwerker

    Tagwerker Active Member

    Registriert seit:
    7. Januar 2019
    Beiträge:
    28
    Zustimmungen:
    0
    <?php

    // BEGIN iThemes Security - Diese Zeile nicht verändern oder entfernen
    // iThemes Security Config Details: 2
    define( 'DISALLOW_FILE_EDIT', true ); // Datei-Editor deaktivieren - Sicherheit > Einstellungen > WordPress-Optimierungen > Datei-Editor
    define( 'FORCE_SSL_ADMIN', true ); // Weiterleitung aller HTTP-Seitenanfragen zu HTTPS - Sicherheit > Einstellungen > Secure Socket Layers (SSL) > SSL für das Dashboard
    // END iThemes Security - Diese Zeile nicht verändern oder entfernen

    /**
    * The base configuration for WordPress
    *
    * The wp-config.php creation script uses this file during the
    * installation. You don't have to use the web site, you can
    * copy this file to "wp-config.php" and fill in the values.
    *
    * This file contains the following configurations:
    *
    * * MySQL settings
    * * Secret keys
    * * Database table prefix
    * * ABSPATH
    *
    * @Link https://codex.wordpress.org/Editing_wp-config.php
    *
    * @package WordPress
    */


    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');

    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');

    /**#@+
    * Authentication Unique Keys and Salts.
    *
    * Change these to different unique phrases!
    * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
    * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
    *
    * @since 2.6.0
    */



    /**#@-*/

    /**
    * WordPress Database Table prefix.
    *
    * You can have multiple installations in one database if you give each
    * a unique prefix. Only numbers, letters, and underscores please!
    */
    $table_prefix = 'wp_';

    /**
    * For developers: WordPress debugging mode.
    *
    * Change this to true to enable the display of notices during development.
    * It is strongly recommended that plugin and theme developers use WP_DEBUG
    * in their development environments.
    *
    * For information on other constants that can be used for debugging,
    * visit the Codex.
    *
    * @Link https://codex.wordpress.org/Debugging_in_WordPress
    */
    define('WP_DEBUG', false);

    /**
    * AUTOUPDATE mit nächster Zeile geblockt.
    */

    define( 'AUTOMATIC_UPDATER_DISABLED', true );"
    define( ‘WP_AUTO_UPDATE_CORE’, false );
     
  8. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    5.345
    Zustimmungen:
    449
    1. Das ist nicht die ganze wp-config.php, das Ende fehlt...
    2. Es wurden manuelle Änderungen vorgenommen.
    3. Entferne das alles:
    Die Fehler sind rot markiert, wer auch immer das eingefügt hat, hat von PHP leider keine Ahnung...
     
    #8 b3317133, 24. Mai 2019
    Zuletzt bearbeitet: 24. Mai 2019
  9. Tagwerker

    Tagwerker Active Member

    Registriert seit:
    7. Januar 2019
    Beiträge:
    28
    Zustimmungen:
    0
    Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 262168 bytes) in /usr/www/users/tagwerc/wp-content/plugins/shapepress-dsgvo/includes/lib/tcpdf/include/tcpdf_font_data.php on line 8333
     
  10. Tagwerker

    Tagwerker Active Member

    Registriert seit:
    7. Januar 2019
    Beiträge:
    28
    Zustimmungen:
    0
    Es scheint ein PLUGIN herumticken. Habe mal umbenannt und dann lässt es sich starten.
     
  11. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    5.345
    Zustimmungen:
    449
    Ok, das scheint geklappt zu haben, derzeit erscheint ein anderer Fehler, der auf zuviel Speicheranspruch Deiner Installation hindeutet.

    In so einem Fall deaktiviert man per FTP ein paar Plugins, z.B. benennt man den Ordner /wp-content/plugins/shapepress-dsgvo/ um in sowas /wp-content/plugins/shapepress-dsgvo-inaktiv/ - dann funktioniert die Seite wieder, man kann sich anmelden, und ein paar Plugins rauswerfen. Wenn man welche wieder aktiviert, vorher auf den Originalpfad zurückbenennen per FTP!

    Hier hat jemand mit dem Plugin ein ähnliches Problem, es liegt mMn. aber an sonstigem Speicherhunger oder zu schwachem Hosting für das neue WordPress 5.2.x

    Zusammenfassend:

    Der o.g. Fehler in wp-config.php kam definitiv nicht durch ein automatisiertes WordPress Update die Tage...

    Ergänzend: Dieser Post hat sich mit #9 und #10 überschnitten...
     
    #11 b3317133, 24. Mai 2019
    Zuletzt bearbeitet: 24. Mai 2019
  12. Tagwerker

    Tagwerker Active Member

    Registriert seit:
    7. Januar 2019
    Beiträge:
    28
    Zustimmungen:
    0
    Es läuft wieder! Vielen Dank für deine Hilfe. Es war ein Plugin was noch Probleme gemacht hat. Warum auch immer.
     
  13. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    5.345
    Zustimmungen:
    449
    Zum Plugin siehe Link in #11.

    Das aktuelle Hauptproblem war das manuell eingefügte fehlerhafte PHP in der Datei wp-config.php - evtl. kam das durch eigene Behebungsversuche zustande.

    Generell empfiehlt sich hier ein Umzug / Upgrade des Hostings zu mehr Arbeitsspeicher (RAM) oder mindestens eine Bereinigung und Entfernung unnötiger Plugins, falls vorhanden.
     
    #13 b3317133, 24. Mai 2019
    Zuletzt bearbeitet: 24. Mai 2019
  14. Tagwerker

    Tagwerker Active Member

    Registriert seit:
    7. Januar 2019
    Beiträge:
    28
    Zustimmungen:
    0
    Danke für die Information. Werde mal darüber nachdenken. Sonst hat es mit Probleme gegeben mit dem Hoster.
    2.JPG
     
  15. Tagwerker

    Tagwerker Active Member

    Registriert seit:
    7. Januar 2019
    Beiträge:
    28
    Zustimmungen:
    0
    Musste auf der KonsoleH den Speicher auf 128 erhöhen.

    Einstellungen/PHI-Konfiguration/ unter memory_limit auf 128 und max_execution_time (in Sek.) auf 45 Dann sollte die Oma wieder laufen.

    Speichern nicht vergessen und dann die Konsole verlassen.

    Bei bedarf auf 256 hochstellen.
     
    #15 Tagwerker, 24. Mai 2019
    Zuletzt von einem Moderator bearbeitet: 24. Mai 2019
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden