1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Nach Updates (Plugin & ChildTheme & Wordpress) Produktbilder riiieeesig

Dieses Thema im Forum "Installation" wurde erstellt von Sanfer, 21. Juli 2021.

Schlagworte:
  1. Sanfer

    Sanfer Member

    Registriert seit:
    28. Oktober 2020
    Beiträge:
    12
    Zustimmungen:
    0
    Hallo,

    ich bin grad am verzweifeln.
    Habe zwar vor meinen Updates eine Updraft-Sicherheitskopie gemacht, aber ich möchte nicht alles zurücksetzen.

    Das Problem: habe
    1.) Elementor, Elementor Pro und Updraft upgedated
    2.) Mein Astra Child Theme upgedated
    3.) Wordpress upgedated

    Und nun sind alle Produktbilder in meinem Shop riesig und pixelig (ganze Bildschirmseite groß). Normalerweise sind lt. Customizer immer 4 Produkte in einer Zeile (ist nachwievor so eingestellt).
    Für die Produktseiten verwende ich ein Elementor Pro Template, aber hier finde ich auch keinen Fehler?

    Was kann ich tun??
    Vielen lieben Dank für alle Vorschläge!!! Sandra

    upload_2021-7-21_10-36-44.png
     
  2. Sanfer

    Sanfer Member

    Registriert seit:
    28. Oktober 2020
    Beiträge:
    12
    Zustimmungen:
    0
  3. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    9.034
    Zustimmungen:
    1.078
    Wozu genau wurde dann diese Sicherheitskopie erstellt? :rolleyes:
    Versuche es mal mit nach den Updates neu in die Mediathek hochgeladenen Bildern? Sind die Bilder dann passender? Falls ja, müssen die diversen Bildgrössen der vorhandenen Bildern mit einem Plugin wie Regenereate Thumbnails o.ä. neu erstellt werden.

    Weiterhin deaktiviere alle Minify-, Cache- und sonstige Optimierungsplugins und leere alle ggf. vorhandenen internen sonstigen Caches auch des Themes bzw. von Elementor. Ändert das etwas?
     
  4. Sanfer

    Sanfer Member

    Registriert seit:
    28. Oktober 2020
    Beiträge:
    12
    Zustimmungen:
    0
    Hallo b3317133,

    DANKE für deine Antwort!

    Sicherheitskopie: irgendwann muss ich ja dann trotzdem auf das fehlerhafte Update umsteigen? Lieber finde ich doch gleich den Fehler??

    Habe jetzt mal alles versucht:
    a) neues Bild hochgeladen - sieht genauso riesig aus wie die anderen
    b) Caches in WP, Elementor und meinem Browser gelehrt + anderen Browser verwendet.

    Hat nichts genützt. Ich habe auch WP Rollback, aber ich weiß ja nicht, welches Plugin/Update den Fehler verursacht?
     
  5. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    9.034
    Zustimmungen:
    1.078
    Es sind weiterhin Minify-, Cache- und sonstige Optimierungsplugins aktiv, derzeit mindestens: SiteGround Optimizer

    Um das Problem genauer zu identifizieren, spielt man z.B. das Backup auf einem Testserver ein und macht dann dort schrittweise einzeln die Updates. Generell spielt man eigentlich bei unternehmenskritischen Installationen wie Shops usw. sämtliche Updates erst auf einem Testserver ein und testet dort alles komplett durch.
     
  6. Sanfer

    Sanfer Member

    Registriert seit:
    28. Oktober 2020
    Beiträge:
    12
    Zustimmungen:
    0
    was meinst du damit? ich habe bei SG Optimizer den Cache manuell geleert
     
  7. Sanfer

    Sanfer Member

    Registriert seit:
    28. Oktober 2020
    Beiträge:
    12
    Zustimmungen:
    0
    und ich habe jetzt mal mit WP Rollback zurückgesetzt:
    Elementor, Woocommerce, Astra-Theme (beim Child-Theme kann ich ja nix machen, oder??)

    Ich vermute fast, dass Elementor Pro der Übeltäter ist, da ich hiermit ja die Templates für die Shop-Unterseiten baue. Aber bei Elementor Pro lässt sich kein Rollback durchführen.
     
  8. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    9.034
    Zustimmungen:
    1.078
    Durch aktive Cache- und Optimierungsmechanismen ist es für mögliche Helfer völlig unklar, welches CSS woher kommt usw., habe jetzt mehrfach darauf hingewiesen, diese Plugins zu deaktivieren, mind. SiteGround Optimizer läuft aber immer noch, bin daher hier raus, viel Erfolg bei der Problembehebung.

    Vergleichsweise blind hier irgendwelche Rollbacks zu machen, ist generell wenig zielführend. Um den funktionierenden Stand wiederherzustellen, hast Du ein Komplettbackup erstellt.

    Alternativ wende Dich an die Person, die den Website eingerichtet hat bzw. technisch dafür verantwortlich ist, die kann Dir sicher kurzfristig weiterhelfen.
     
  9. Sanfer

    Sanfer Member

    Registriert seit:
    28. Oktober 2020
    Beiträge:
    12
    Zustimmungen:
    0
    danke, dachte du meinst ich sollte den Cache leeren (was ich im SG gemacht hab), hab nicht kapiert, dass ich das Plugin deaktivieren soll!!!!

    habe nun mit Updraft alles zurück gesetzt und werde mich als nächstes Projekt schlau machen, wie ich in Zukunft das alles mit dem von dir vorgeschlagenen Testserver machen kann.

    Danke für die Inputs! LG, Sandra
     
  10. Tutrix

    Tutrix Well-Known Member

    Registriert seit:
    21. Mai 2010
    Beiträge:
    3.649
    Zustimmungen:
    3
    @Sanfer

    du kannst bist du den Fehler gefunden hast, ist denke mal nur eine Einstellung die wieder hergestellt werden muss, mal diesen Code unter Design > Customizer > Zusätzliches CSS einfügen

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
     
  11. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    9.034
    Zustimmungen:
    1.078
    Auf dem Server läuft lt. HTTP Headern augenscheinlich zusätzlich auch noch ausserhalb von WordPress ein weiterer Cache-Mechanismus, wende Dich an den Hosting Support, um herauszufinden, wie Du den deaktivieren oder leeren kannst.
     
  12. Persephone

    Persephone Well-Known Member

    Registriert seit:
    21. Februar 2016
    Beiträge:
    483
    Zustimmungen:
    33
    Die Website ist nicht optimiert. Auf der Seite Duftkerzen werden 13 Bilder großformatig dargestellt, Bei allen handelt es sich nicht, wie in der Adresszeile angegeben um das Format JPG, sondern um WebP.
    https://www.cam-leon.at/duftkerzen/
    https://www.cam-leon.at/wp-content/uploads/2020/11/4LeEn-800-300x300.jpg
    https://www.cam-leon.at/wp-content/uploads/2020/11/8Gsund-800-300x300.jpg
    https://www.cam-leon.at/wp-content/uploads/2021/04/10Flair-weiss360-800-300x300.jpg
    u. s. w. w. s. f.

    Das Wordpress Update 5.8 kommt u. a. mit folgender Neuerung:
    Unterstützung für WebP hinzugefügt
    WebP ist ein modernes Bildformat, das eine verbesserte verlustfreie und verlustarme Komprimierung für Bilder im Web bietet. WebP-Bilder sind im Durchschnitt etwa 30 % kleiner als ihre JPEG- oder PNG-Äquivalente, was zu schnelleren Websites und geringerem Datenvolumen führt.

    Da bei mir nach dem WP Update 5.8 noch alle Bilder im JPG Format sind, schließe ich WordPress als Verursacher aus.
     
    Koni Lux gefällt das.
  13. Sanfer

    Sanfer Member

    Registriert seit:
    28. Oktober 2020
    Beiträge:
    12
    Zustimmungen:
    0
    @Tutrix danke, ich forsche grad in Richtung WebP, aber irgendwann muss ich ja mal Updaten :D werd deinen Code dann vorher einbauen
     
  14. Sanfer

    Sanfer Member

    Registriert seit:
    28. Oktober 2020
    Beiträge:
    12
    Zustimmungen:
    0
    @Persephone
    ja, ich lade die Bilder als JPG hoch, aber mein SG Optimizer macht dann WebP draus.
    Alle anderen Bilder (normale Startseite) blieben nach den Updates in der richtigen Größe, nur die Bilder im Shop sind immens vergrößert.

    upload_2021-7-22_12-3-38.png
     
  15. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    9.034
    Zustimmungen:
    1.078
    Falls es trotz mehrfacher Hinweise noch immer nicht klar ist:

    Für eine sinnvolle Ursachenermittlung von Darstellungsproblemen sollte man immer alle Minify-, Cache- und sonstige Optimierungsplugins und auch ggf. vorhandene sonstige serverseitige Cache-Mechanismen vollständig deaktivieren.

    Sonst ist das alles nur ein Stochern im Nebel...
     
    SEpp55 und danielgoehr gefällt das.
  16. Persephone

    Persephone Well-Known Member

    Registriert seit:
    21. Februar 2016
    Beiträge:
    483
    Zustimmungen:
    33
    Warum sagst du das denn nicht gleich?

    Wenn SG Optimizer nach der Optimierung in der Adresszeile keine .webp Erweiterung hinzufügt
    Beispiel: https://www.cam-leon.at/wp-content/uploads/2020/11/4LeEn-800-300x300.jpg.webp
    dann kannst du das Plugin SG Optimizer auch in der Pfeife rauchen.
     
  17. Tutrix

    Tutrix Well-Known Member

    Registriert seit:
    21. Mai 2010
    Beiträge:
    3.649
    Zustimmungen:
    3
    @Safner

    Lass dich hier nicht durcheinander bringen, SG Optimizer macht genau das was er soll, die Bilder optimieren und "nicht" den Bildpfad.

    Es gibt hier also nichts zu rauchen ;)
     
    danielgoehr gefällt das.
  18. Sanfer

    Sanfer Member

    Registriert seit:
    28. Oktober 2020
    Beiträge:
    12
    Zustimmungen:
    0
    @Tutrix stimmt, ich hab das grad getestet, indem ich einfach einen Rechtsklick auf Bilder mache, um sie quasi zu speichern. Der Dateityp ist definitiv webp. Warum @Persephone etwas anderes rausfindet weiß ich nicht. Mir ist nur wichtig, dass die Bilder klein sind :) und es ist ja jetzt vom ursprünglichen Thema etwas abgekommen. Aber ich danke allen nochmal für die Inputs zu meinem ursprünglichen Problem!!

    Liebe Grüße!!!
     
  19. Tutrix

    Tutrix Well-Known Member

    Registriert seit:
    21. Mai 2010
    Beiträge:
    3.649
    Zustimmungen:
    3
    Nur noch zur Info:

    Es gibt 2 Möglichkeiten beim nachträglichen optimieren in das WebP Bildformat

    Eine Option fügt der Konfigurationsdatei ".htaccess" von Wordpress einige Rewrite Rules hinzu und lässt den Code deiner Seiten unverändert.
    Eine weitere Option ersetzt <img>tag mit <picture>tag Elementen, hier wird dann auch in der Browserzeile dem Bildpfad das .webp angehängt.

    Die <picture>tag Integrierung Funktioniert aber mit manchen WP Themes nicht, daher wird bei den Plugins oft die .htaccess Variante verwendet
     
  20. Persephone

    Persephone Well-Known Member

    Registriert seit:
    21. Februar 2016
    Beiträge:
    483
    Zustimmungen:
    33
    Ho ho ho, hab noch was ganz anderes herausgefunden, was keinesfalls von einem Plugin, Theme o. WordPress stammt!
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden