1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Nach WP-Umzug auf neuen Server kein Login -WP-admin möglich

Dieses Thema im Forum "Installation" wurde erstellt von Mafa1968, 10. April 2014.

  1. Mafa1968

    Mafa1968 New Member

    Registriert seit:
    10. April 2014
    Beiträge:
    4
    Zustimmungen:
    0
    Hallo an Alle,
    ich hoffe ihr könnt mir helfen. Ich bin mit meinem Blog auf einen neuen Server umgezogen. Habe alle Daten per FTP gesichert. Dann eine Datenbanksicherung gemacht. Die Datenbank auf dem neuen Server wiederhergstestellt und alle WP Daten wieder über FTP hochgeladen. Man kann meine Seite auch aufrufen http://inhaltsstoffe-kosmetik.info Aber ich bekomme immer folgende Fehlermeldung -
    Notice: wp_enqueue_style was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or login_enqueue_scripts hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /var/www/web142/html/inhaltsstoffe_kosmetik/wp-includes/functions.php on line 3049

    Strict Standards: Non-static method SimilarPosts::install_post_plugin_library() should not be called statically in /var/www/web142/html/inhaltsstoffe_kosmetik/wp-content/plugins/similar-posts/similar-posts.php on line 50

    Leider habe ich vom Debugging keine Ahnung und weiß nicht was ich tun muss. Außerdem kann ich mich nicht ins Backend WP-admin einloggen. Über eure Hilfe wäre ich dankbar.
    Mit besten Grüßen Maik
     
  2. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.965
    Zustimmungen:
    8
    Lösche mal per FTP das Plugin similar-posts
     
  3. Mafa1968

    Mafa1968 New Member

    Registriert seit:
    10. April 2014
    Beiträge:
    4
    Zustimmungen:
    0
    Habe ich gemacht, danke. eine Fehlermeldung ist weg aber Login funktioniert trotzdem noch nicht und wieder der Hinweis auf Debugging.
     
  4. g3h

    g3h Well-Known Member

    Registriert seit:
    25. Juni 2013
    Beiträge:
    661
    Zustimmungen:
    0
    Du kannst den Debug-Modus in deiner wp-config.php aktivieren, indem du WP_DEBUG auf true setzt:

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Vielleicht bringt das ein paar mehr infos.

    So was ähnliches hatte ich glaubig schonmal, kam auch von einem Plugin, auch wenn er in der ersten Meldung eine Wordpress Datei angibt.

    Die zweite Meldung sollte eigentlich schon verschwinden, wenn du im Plugin bei der besagten Methode noch das Schlüsselwort "static" hinzufügst.

    MfG
     
    #4 g3h, 10. April 2014
    Zuletzt bearbeitet: 10. April 2014
  5. Mafa1968

    Mafa1968 New Member

    Registriert seit:
    10. April 2014
    Beiträge:
    4
    Zustimmungen:
    0
    Danke, "WP_DEBUG auf true setzen" habe ich auch schon erledigt. Zweite Fehlermeldung ist: Non-static method SimilarPosts::install_post_plugin_library() should not be called statically in /var/www/web142/html/inhaltsstoffe_kosmetik/wp-content/plugins/similar-posts/similar-posts.php on line 50 - ist jetzt weg habe per FTP das Plugin gelöscht. Aber was muss ich debuggen???
     
  6. g3h

    g3h Well-Known Member

    Registriert seit:
    25. Juni 2013
    Beiträge:
    661
    Zustimmungen:
    0
    Du musst nix debuggen, das geht automatisch, aber wenn keine neue Meldung kommt nach anschalten des Debug-Mode, dann benenne mal testweise den ganzen Plugin-Ordner um.
    Wenn dann immer noch die Medlung kommt, mal testweise auf ein Standard Theme wechseln von Wordpress.
     
    #6 g3h, 10. April 2014
    Zuletzt bearbeitet: 10. April 2014
  7. Mafa1968

    Mafa1968 New Member

    Registriert seit:
    10. April 2014
    Beiträge:
    4
    Zustimmungen:
    0
    Ich weiß ja nicht wie es automatisch geht? In der wp-config steht das drin:
    ini_set('display_errors',1);
    define('WP_DEBUG', true);
    define('SCRIPT_DEBUG', true);
    define('WP_DEBUG_LOG', true);

    Versuche jetzt mal den Plugin Ordner umzubennen, wie du geschireben hast. Doch wie kann ich mich bei wp-admin einloggen?
     
  8. g3h

    g3h Well-Known Member

    Registriert seit:
    25. Juni 2013
    Beiträge:
    661
    Zustimmungen:
    0
    Sollten keine neuen Fehlermeldungen erscheinen auf den Seiten, kannst du den Debug-Mod auch wieder abstellen.

    Zum umbennenen des Plugin Ordners brauchst du dich nicht einloggen das geht über FTP. Auf ein standard Theme kannst du auch wechseln, indem du einfach den Ordner des von dir benutzten Themes umbenennst.
     
    #8 g3h, 10. April 2014
    Zuletzt bearbeitet: 10. April 2014
  9. Marcus[IS]

    Marcus[IS] Well-Known Member

    Registriert seit:
    23. August 2009
    Beiträge:
    5.801
    Zustimmungen:
    126
    Das kannst du über deine_domain/wp-login.php
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden