1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

NextGen Gallery erstellt keine Thumbnails

Dieses Thema im Forum "Plugins und Widgets" wurde erstellt von fraz, 18. Oktober 2007.

  1. fraz

    fraz Well-Known Member

    Registriert seit:
    30. April 2007
    Beiträge:
    55
    Zustimmungen:
    0
    Kann gelöscht werden!
     
    #1 fraz, 18. Oktober 2007
    Zuletzt bearbeitet: 18. Oktober 2007
  2. leb3666

    leb3666 Member

    Registriert seit:
    27. Dezember 2007
    Beiträge:
    18
    Zustimmungen:
    0
    Nextgen erstellt keine Thumbails Teil 2

    Hallo in die Runde,

    Nextgen mag mich nicht mehr. :oops: Seit dem Serverumzug kann ich keine Thumbnails mehr erstellen. Folgender Fehlercode wird zurückgegegen:

    Folgende Thumbnails konnten nicht erstellt werden :
    Abriss_Tribuene.jpg (Error : Create Image failed. Check safe mode settings)

    Das sind meine Servereinstellungen:

    Server- Einstellungen

    * Betriebssystem : Linux
    * Server : Apache/2.0.54 (Debian GNU/Linux) PHP/5.2.3 with Suhosin-Patch DAV/2
    * Speicherverbrauch : 12.21 MByte
    * MySQL Version : 5.0.32-Debian_7etch5~bpo31+1-log
    * SQL Modus : Nicht gesetzt
    * PHP Version : 5.2.3
    * PHP Safe Mode : Aus
    * PHP Allow URL fopen : An
    * PHP Memory Limit : 32M
    * PHP Max Upload Size : 8M
    * PHP Max Post Size : 8M
    * PHP Max Script Execute Time : 30s
    * PHP Exif Modul : Ja ( V1.4 )
    * PHP IPTC Modul : Ja
    * PHP XML Modul : Ja

    GD Unterstützung

    * GD Version : bundled (2.0.34 compatible)
    * FreeType Support : Ja
    * FreeType Linkage : with freetype
    * T1Lib Support : Nein
    * GIF Read Support : Ja
    * GIF Create Support : Ja
    * JPG Support : Ja
    * PNG Support : Ja
    * WBMP Support : Ja
    * XPM Support : Nein
    * XBM Support : Ja
    * JIS-mapped Japanese Font Support : Nein

    Das Bild ist im Format 800x547 und 84k groß.
    Die Ordner haben folgende Rechte: 755
    Und ich habe die neusten Versionen von Nextgen und WP?
    Das gestern noch alles funktioniert hat versteht sich von selbst. :D

    Wer hat eine Idee?? :confused:

    Viele Grüße
    LEB3666

    P.S.I.: Wenn ich versuche bestehende Thumbnails neu zu erstellen bekomme ich folgende Fehlermeldung:

    Einige Thumbnails sind schreibgeschützt :

    /is/htdocs/...usw........jpg

    P.S.II: Das Uploaden hat auch noch nie funktioniert, immer war der Umweg über ein FTP-Programm.
     
  3. for-wii-fans.de

    for-wii-fans.de Well-Known Member

    Registriert seit:
    11. August 2007
    Beiträge:
    248
    Zustimmungen:
    0
    Ordner 777 vergeben!
     
  4. leb3666

    leb3666 Member

    Registriert seit:
    27. Dezember 2007
    Beiträge:
    18
    Zustimmungen:
    0
    Das hat funktioniert


    Danke for-wii-fans,

    damit funktioniert es. Aber ist das denn nicht gefährlich? Auf dem alten Server hatten die Ordner auch nicht 777 und es funktionierte trotzdem. Naja die Geheimnisse des Meeres.

    Grüße LEB3666
     
  5. pisti88

    pisti88 Active Member

    Registriert seit:
    25. Februar 2008
    Beiträge:
    43
    Zustimmungen:
    0
    geht mir auch ganz ähnlich, er erstellt von einigen thumbnails, von anderen nicht, beim thumbnail erstellen friert er immer ein.
    auch zeigt die Galerie nur die ersten 4 bilder an, obwohlich 13 hochgeladen habe.
     
  6. csign

    csign Well-Known Member

    Registriert seit:
    29. August 2007
    Beiträge:
    663
    Zustimmungen:
    0
    Thumbnails werden nicht nach Bilderupload erstellt

    Hallo,

    Ich kann auch keine Thumbnails erstellen, trotz Rechte 777, trotz SafeMode AUS.


    Server- Einstellungen
    • Betriebssystem : Linux
    • Server : Apache/1.3.34 Ben-SSL/1.55
    • Speicherverbrauch : 13.7 MByte
    • MySQL Version : 5.0.51-log
    • SQL Modus : Nicht gesetzt
    • PHP Version : 4.4.8
    • PHP Safe Mode : Aus
    • PHP Allow URL fopen : An
    • PHP Memory Limit : 40M
    • PHP Max Upload Size : 20M
    • PHP Max Post Size : 8M
    • PHP Max Script Execute Time : 50000s
    • PHP Exif Modul : Ja ( V1.4 )
    • PHP IPTC Modul : Ja
    • PHP XML Modul : Ja
    GD Unterstützung
    • GD Version : bundled (2.0.28 compatible)
    • FreeType Support : Ja
    • FreeType Linkage : with freetype
    • T1Lib Support : Nein
    • GIF Read Support : Ja
    • GIF Create Support : Ja
    • JPG Support : Ja
    • PNG Support : Ja
    • WBMP Support : Ja
    • XBM Support : Ja
    • JIS-mapped Japanese Font Support : Nein
    Ich habe eine neue Galerie erstellt.
    Dann habe ich vom Rechner ein einziges Bild hochgeladen ("Bilder hochladen") mit 54 kb, 800 x 600 Größe, jpg, entsprechende Galerie(namen) gewählt, auf "hochladen" geklickt.

    Ich sehe daraufhin immer nur dies hier:

    ------------------
    Neue Thumbnails erstellen

    0%

    Läuft... Bitte warten


    ------------------

    Kein Ladebalken in der Browserstatusleiste ... irritiert mich das schon.
    Und: ich kann stundenlang warten: immer nur "0% ... läuft".

    Woran kann das liegen?

    Getestet mit WIN XP und Firefox als auch I.E. 7 - beide Male das Gleiche.

    Wenn ich mit dem FTP-Programm nachsehe, hat er auch keinen Ordner unter wp-content/gallery mit entsprechendem Galerienamen erstellt.
    :confused:
     
    #6 csign, 10. April 2008
    Zuletzt bearbeitet: 10. April 2008
  7. csign

    csign Well-Known Member

    Registriert seit:
    29. August 2007
    Beiträge:
    663
    Zustimmungen:
    0
  8. alex.rabe

    alex.rabe Well-Known Member

    Registriert seit:
    18. November 2006
    Beiträge:
    243
    Zustimmungen:
    0
  9. csign

    csign Well-Known Member

    Registriert seit:
    29. August 2007
    Beiträge:
    663
    Zustimmungen:
    0
    Oh klasse, vielen Dank.

    Auf die Idee, bei denen nachzusehen, bin ich gar nicht gekommen ...
    ... dass die so einen "Luxus" anbieten :mrgreen:
     
  10. lebensläufer

    lebensläufer Active Member

    Registriert seit:
    3. Oktober 2006
    Beiträge:
    25
    Zustimmungen:
    0
    Ich will jetzt keinen neuen Thread aufmachen, da ich ein ähnliches Problem habe:

    Es werden keine Thumbnails erstellt. Die Bilder selbst sind aber (auch auf 800x600 skaliert) zu sehen.
    Mir wird so etwas ausgegeben:

    Folgende Thumbnails konnten nicht erstellt werden :
    baustelle_1.png (Error : Create Image failed. Check safe mode settings)
    ...

    Die Zusammenfassung sagt:

    Zusammenfassung

    Es gibt insgesamt 58 Bilder in 1 Galerien - verteilt in 0 Alben.
    Server- Einstellungen
    Betriebssystem : Linux
    Server : Apache
    Speicherverbrauch : 7.8 MByte
    MySQL Version : 5.0.27-standard
    SQL Modus : Nicht gesetzt
    PHP Version : 4.4.5-dev
    PHP Safe Mode : An
    PHP Allow URL fopen : Aus
    PHP Memory Limit : 80M
    PHP Max Upload Size : 8M
    PHP Max Post Size : 8M
    PHP Max Script Execute Time : 30s
    PHP Exif Modul : Ja ( V1.4 )
    PHP IPTC Modul : Ja
    PHP XML Modul : Ja
    GD Unterstützung
    GD Version : bundled (2.0.28 compatible)
    FreeType Support : Ja
    FreeType Linkage : with freetype
    T1Lib Support : Ja
    GIF Read Support : Ja
    GIF Create Support : Ja
    JPG Support : Ja
    PNG Support : Ja
    WBMP Support : Ja
    XBM Support : Ja
    JIS-mapped Japanese Font Support : Nein

    Ich habe irgendwo hier gelesen, dass es was mit dem Safe-Mode zu tun haben kann, der ausgeschaltet werden sollte. Kann jemand bitte sagen, ob das stimmt und - wenn ja - wie ich das mache?
    Danke.

    P.S.: Benutze die neueste Nextgen-Gallery-Version, Wordpress 2.3.3, Opera 9.27 und bin bei Canhost.

    Danke für jede Hilfe.
     
  11. csign

    csign Well-Known Member

    Registriert seit:
    29. August 2007
    Beiträge:
    663
    Zustimmungen:
    0
  12. Woodstock

    Woodstock Well-Known Member

    Registriert seit:
    14. November 2004
    Beiträge:
    959
    Zustimmungen:
    0
    Bin auch bei Canhost, da kannst du den Safe Mode nicht ausschalten. Du kannst aber trotzdem NextGen Gallery benutzen (ich benutze das auch), du musst nur die Verzeichnisse per FTP anlegen und ihnen als Berechtigung 777 geben.
     
  13. lebensläufer

    lebensläufer Active Member

    Registriert seit:
    3. Oktober 2006
    Beiträge:
    25
    Zustimmungen:
    0
    @Woodstock: Das hatte ich probiert, ohne Erfolg zu haben. Ich habe aber Canhost kontaktiert und folgende Mail erhalten:

    Tatsächlich konnte ich SUPHP auf AN stellen, und jetzt ist der safe_mode auch ausgestellt. Die Thumbnails wurden diesmal fehlerfrei erstellt.
    Ob das Ganze jetzt funktioniert, weiß ich aber nicht, weil ich nur
    sehe anstelle von Thumbnails...
     
  14. csign

    csign Well-Known Member

    Registriert seit:
    29. August 2007
    Beiträge:
    663
    Zustimmungen:
    0
    Und wenn du mit FTP in diesen Ordner schaust? Sind sie wirklich erstellt oder nur der Ordner "thumbs"?
     
  15. Woodstock

    Woodstock Well-Known Member

    Registriert seit:
    14. November 2004
    Beiträge:
    959
    Zustimmungen:
    0
    Das spricht ja eigentlich dafür, dass das Plugin deaktiviert ist. Also funktioniert das Plugin vielleicht nicht mit diesem SUPHP? Ruf doch mal bei Canhost an, die haben ja einen sehr fähigen Support.
     
  16. lebensläufer

    lebensläufer Active Member

    Registriert seit:
    3. Oktober 2006
    Beiträge:
    25
    Zustimmungen:
    0
    @csign: Die Thumbnails sind mittlerweile alle ordnungsgemäß angelegt und im entsprechenden Ordner zu finden. Doch mir wird weiterhin nur
    anstelle einer echten Galerie angezeigt.

    @Woodstock: Jup. Ich werde gleich mal eine Mail an den Support schreiben und berichte dann davon, was dabei rauskam...
     
  17. lebensläufer

    lebensläufer Active Member

    Registriert seit:
    3. Oktober 2006
    Beiträge:
    25
    Zustimmungen:
    0
    Also, der Supprot konnte mir auch nicht weiterhelfen, meinte, ich solle hier Nachfragen, ob Probleme mit SUBHP bekannt seien.

    Ich habe kurzentschlossen alles gelöscht und sowohl die neueste Wordpress- als auczh die neueste Nextgen-Gallery-Version installiert - und plötzlich funktioniert es. Bin begeistert und erfreut und danke euch für eure Unterstützung.
     
  18. benpen

    benpen Active Member

    Registriert seit:
    14. April 2008
    Beiträge:
    30
    Zustimmungen:
    0
    Will mich mal einklinken. Mein Problem:

    Thumbnails werden alle ohne Probleme erstellt. Nur nicht, wenn ich ein Album in eine Seite einfüge, ob extend oder kurz, wird kein Thumbnail erstellt.
    Woran kann das liegen.

    Habe PHP5, alle Ordner 777, Thumbnails sind alle erstellt.
     
  19. Woodstock

    Woodstock Well-Known Member

    Registriert seit:
    14. November 2004
    Beiträge:
    959
    Zustimmungen:
    0
    Läuft es denn jetzt bei dir mit oder ohne SUPHP?
     
  20. neontrauma

    neontrauma Well-Known Member

    Registriert seit:
    30. Juli 2007
    Beiträge:
    230
    Zustimmungen:
    0
    Hallo,

    ich habe das gleiche Problem - beim Hochladen eines Fotos erhalte ich die Fehlermeldung Error : Create Image failed. Check safe mode settings.
    Safe Mode ist aus, die Ordner haben 777, PHP 5.

    Es werden in der Galerie selber keine Thumbs angezeigt, ebenso nicht das Vorschaubild, was man für eine Galerie wählen kann. Die Thumbnails existieren jedoch! Dort, wo sie hingehören, nämlich im Galerieverzeichnis im Thumbs-Ordner. In der Galerie-Übersicht im Backend, wo man die einzelnen Bilder einer Galerie sieht, werden die Thumbs auch korrekt angezeigt.

    Dort, wo der Thumb im Frontend zu sehen sein soll, ist die URL total vermurkst:
    http://eden-existiert.de/wp-content/gallery/blackfield-festival-2008cxs2.jpg
    ... sollte eigentlich zu folgendem Thumb führen:
    http://eden-existiert.de/wp-content/gallery/blackfield-festival-2008/thumbs/thumbs_cxs2.jpg

    Das Seltsame ist, dass es vor wenigen Tagen noch problemlos geklappt hat - auf dem gleichen Server, mit der gleichen WP-Version (ob es die gleiche Nextgen-version ist, weiß ich ehrlich gesagt nicht - gab es innerhalb der letzten Woche ein Update? Ich update immer direkt, wenn in der Plugin-Übersicht eine neue Version angezegt wird - nur in einem anderen Verzeichnis (wobei das ja nun keine Rolle spielen sollte oO).

    Zu Hülf... :???:
     
    #20 neontrauma, 10. Juli 2008
    Zuletzt bearbeitet: 10. Juli 2008
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden