1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Nextgen Gallery Problem in WP 2.8

Dieses Thema im Forum "Plugins und Widgets" wurde erstellt von Mama Kay, 12. Juni 2009.

  1. Mama Kay

    Mama Kay Well-Known Member

    Registriert seit:
    23. Februar 2005
    Beiträge:
    113
    Zustimmungen:
    0
    Hallo zusammen,
    erst mal: Glückwunsch und Danke an das Team zur neuen WP-Verison!

    Ich habe mehrere Blogs zu verwalten auf denen ich das Nextgen Gallery Plugin verwende. Nach dem Upgrade auf 2.8 habe ich bei einem dieser Blogs das Problem, dass auf der Übersichtsseite der Galerien nur jede zweite Galerie erscheint (bei allen anderen Blogs tritt das Problem nicht auf).

    Hier die Problemseite: Link

    Ich habe schon:
    * die Seite neu geschrieben und jedes Album wieder neu eingefügt
    * die Problemseite mit den Galerien auf meinen anderen Blogs verglichen und keine Unterschiede festgestellt
    * das Plugin deaktiviert und wieder aktiviert
    * ratlos vor der Galerie-Verwaltung gesessen

    Schaut man sich den Quelltext an, erkennt man, dass nur jeder zweite Befehl album id="X" template="extend"] angenommen und richtig dargestellt wird.

    Kann mir jemand helfen?
    Vielen Dank im Voraus!

    LG,
    MK

    EDIT:
    Hab noch was vergessen: Alle Galerien sind vorhanden und können aufgerufen werden über die Hauptnavigation, die auch die Unterseiten (Einzelgalerien) anzeigt.
     
    #1 Mama Kay, 12. Juni 2009
    Zuletzt bearbeitet: 12. Juni 2009
  2. Oeffi

    Oeffi Well-Known Member

    Registriert seit:
    23. August 2007
    Beiträge:
    78
    Zustimmungen:
    0
    Wenn ich auf den LINK deiner Seite klicke, löst mein AVAST-Antiviren Scanner aus und gibt ALARM!

    Gruß
     
  3. Mama Kay

    Mama Kay Well-Known Member

    Registriert seit:
    23. Februar 2005
    Beiträge:
    113
    Zustimmungen:
    0
    Ähhh ... HILFE!!!!
     
  4. Oeffi

    Oeffi Well-Known Member

    Registriert seit:
    23. August 2007
    Beiträge:
    78
    Zustimmungen:
    0
    Kann ja auch sein, dass mein Avast was falsch erkennt.
     
  5. infected

    infected Well-Known Member

    Registriert seit:
    9. Juli 2006
    Beiträge:
    9.816
    Zustimmungen:
    1
    Hi!

    Wie ich sehe versuchst Du auch mehrere Alben auf einer Seite ausgeben zu lassen, richtig?!

    Hier scheint es wohl momentan ein kleines Problem zu geben. Ich habe selbst das Problem, dass mir manche Galerien doppelt angezeigt werden. Das hängt wohl auch irgendwie damit zusammen.

    Wie ich heute morgen herausgefunden habe, ist das Problem (mehrere Alben in einem Post/einer Seite) schon bekannt und in Überarbeitung.
     
  6. Mama Kay

    Mama Kay Well-Known Member

    Registriert seit:
    23. Februar 2005
    Beiträge:
    113
    Zustimmungen:
    0
    @ oeffi
    Ich bleibe dran und überprüfe das. Vielen Dank für den Hinweis!

    @ all
    Bekommt noch jemand ne Virenmeldung wenn er die Seite aufruft?

    @ infected
    Ja, ich will mehrere Alben anzeigen lassen.
    Danke erst mal für die Antwort und den Link. Ich werde das mal verfolgen.

    Was mich eben stutzig macht: Bei einem anderen Blog, den ich mitverwalte und bei dem ich auch mehrere Alben anzeigen lasse, funktioniert das einwandfrei.
     
  7. infected

    infected Well-Known Member

    Registriert seit:
    9. Juli 2006
    Beiträge:
    9.816
    Zustimmungen:
    1
    Viren: Eine Virenwarnung habe ich bei mir nicht erhalten (Avira AntiVir 9)

    Galerie: Verwendest Du denn bei beiden Installationen die gleichen Pluginversionen? Ich konnte das Problem auch erst seit dem Update auf 1.3.2 feststellen, obwohl es bei einigen (wie im verlinkten Beitrag) schon in 1.3.1 auftrat. Mit 1.3.1 lief bei mir noch alles wunderbar. Und bei mir werden, im Gegensatz zu Dir, ja auch alle Alben angezeigt. Lediglich einige Galerien werden doppelt ausgegeben. Es scheint da irgendwo ein willkürliches Verhalten zu geben, sofern unsere Probleme auf der gleichen Ursache beruhen (wovon ich aber ausgehe).
     
    #7 infected, 12. Juni 2009
    Zuletzt bearbeitet: 12. Juni 2009
  8. Oeffi

    Oeffi Well-Known Member

    Registriert seit:
    23. August 2007
    Beiträge:
    78
    Zustimmungen:
    0
    Hier die Meldung, habe es erneut versucht:
     
  9. Mama Kay

    Mama Kay Well-Known Member

    Registriert seit:
    23. Februar 2005
    Beiträge:
    113
    Zustimmungen:
    0
    Jepp... Sobald eine neue Version eines Plugins vorliegt, aktualisiere ich.
     
  10. oKons

    oKons Well-Known Member

    Registriert seit:
    6. Mai 2009
    Beiträge:
    64
    Zustimmungen:
    0
    Ich konnte jedenfalls keinen Befall Deiner Seiten feststellen (tested with AVIRA Prof. Vers. 9).
     
  11. Mama Kay

    Mama Kay Well-Known Member

    Registriert seit:
    23. Februar 2005
    Beiträge:
    113
    Zustimmungen:
    0
    @ oeffi
    Danke für die Grafik! Ich kann den Namen des Virus/Wurms nicht entziffern (trotz Brille ;) )

    Kannst Du den bitte hier nochmal posten?
     
  12. Mama Kay

    Mama Kay Well-Known Member

    Registriert seit:
    23. Februar 2005
    Beiträge:
    113
    Zustimmungen:
    0
    Danke für's Testen oKons!
     
  13. infected

    infected Well-Known Member

    Registriert seit:
    9. Juli 2006
    Beiträge:
    9.816
    Zustimmungen:
    1
    @Mama: Mit hoher Wahrscheinlichkeit handelt es sich um einen Fehlalarm von Avast und nicht um (d)eine infizierte Website. So ist es zumindest dem Avast-Supportforum zu entnehmen.
     
  14. Mama Kay

    Mama Kay Well-Known Member

    Registriert seit:
    23. Februar 2005
    Beiträge:
    113
    Zustimmungen:
    0
    Wow.. danke für deine Mühe, infected

    Nun kann ich wieder beruhigt schlafen ;)
     
  15. infected

    infected Well-Known Member

    Registriert seit:
    9. Juli 2006
    Beiträge:
    9.816
    Zustimmungen:
    1
    Na, aber nicht vergessen: Ich sagte "Mit hoher Wahrscheinlichkeit..." Zu 100% bestätigen kann ich das nicht. :mrgreen:
     
  16. Mama Kay

    Mama Kay Well-Known Member

    Registriert seit:
    23. Februar 2005
    Beiträge:
    113
    Zustimmungen:
    0
    He he ... schade.. ich wollte gerade eine eidesstattliche Erklärung für dich vorbereiten ;)
     
  17. zinn2003

    zinn2003 Well-Known Member

    Registriert seit:
    24. Mai 2006
    Beiträge:
    284
    Zustimmungen:
    0
    Also mein Avast hat sich nicht gezuckt.
     
  18. Mama Kay

    Mama Kay Well-Known Member

    Registriert seit:
    23. Februar 2005
    Beiträge:
    113
    Zustimmungen:
    0
    Danke zinn :)

    Das Ganze wird immer dubioser...
     
  19. infected

    infected Well-Known Member

    Registriert seit:
    9. Juli 2006
    Beiträge:
    9.816
    Zustimmungen:
    1
    Vielleicht hat sich ja was in oeffis temporären Internetdateien eingenistet?! Aber mal zurück zum eigentlich Problem:

    Im wordpress.org Forum hatte der Pluginautor eben einen Link zu einem Fix gepostet.

    Tausche mal den Inhalt der Datei nggfunctions.php mit diesem dort geposteten aus und überprüfe mal ob´s dann wieder geht (sichere Dir aber vorher den Inhalt der Originaldatei, falls mal was schief geht). Bei mir funktioniert nun wieder alles einwandfrei.
     
    #19 infected, 12. Juni 2009
    Zuletzt bearbeitet: 12. Juni 2009
  20. Mama Kay

    Mama Kay Well-Known Member

    Registriert seit:
    23. Februar 2005
    Beiträge:
    113
    Zustimmungen:
    0
    Habs getestet - keine Änderung :(
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden