1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Notice Fehlermeldungen seit 2 Tagen > Verzweiflung

Dieses Thema im Forum "Allgemeines" wurde erstellt von stativkunst.de, 8. November 2018.

  1. stativkunst.de

    Registriert seit:
    8. November 2018
    Beiträge:
    5
    Zustimmungen:
    0
    Hallo in die Runde,

    ich habe seit 2 Tagen Notice- Fehler in meiner Wordpress Woocommerce Germanized- Installation (siehe screenshot). Leider nicht nur im backend sondern tatsächlich auch im Frontend während des Bestellvorganges :(

    ich kann mir das nicht erklären. In der wp-config habe ich schon geprüft, ob die notification "false" sind. Sind sie.

    Wäre toll, wenn mir jemand helfen kann. Plugins, Wordpress ist alles up2date.

    Danke und viele Grüße

    Daniel
     

    Anhänge:

  2. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    4.058
    Zustimmungen:
    263
    Es handelt sich offenbar um einen Fehler in WooCommerce, mehr dazu siehe hier, als erster Treffer gefunden über eine Suchmaschine mit den Stichworten: undefined index priority woocommerce

    Ist in der Datei wp-config.php die Variable WP_DEBUG auf true gesetzt? Falls ja, setze sie auf false, hilft das? Mehr dazu hier.
     
  3. stativkunst.de

    Registriert seit:
    8. November 2018
    Beiträge:
    5
    Zustimmungen:
    0
    Hi,
    danke für die Antwort. Ich habe mir die Finger blutig gegoogled und nix gefunden, außer den Hinweis in der wp-config-php die VAR wp-debug auf false zu setzen. Das war ja aber schon der Fall.

    Haben da bei woocommerce die Qualitätssicherungsmaßnahmen versagt? :(

    Lieben Dank für die Hilfe!

    Daniel
     
  4. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    4.058
    Zustimmungen:
    263
    Die Datei heisst wp-config.php und die Variable WP_DEBUG

    Poste doch mal alles ab/nach ca. der Zeile 70 ab define('WPLANG', ... aus Deiner Datei (also ohne die DB_xx Einträge und ohne die xx_SALT Einträge aus dem oberen Teil), dann sieht man ggf. ob/wo es da ein Problem geben könnte.
     
  5. stativkunst.de

    Registriert seit:
    8. November 2018
    Beiträge:
    5
    Zustimmungen:
    0
    Guten Morgen b3317133,

    hier ist alles nach den DB- Einträgen:

    wp_debug ist bewusst auskommentiert und durch den orangen Teil ersetzt worden. Laut einer website sollte das die notice-Meldungen unterdrücken. Hat aber leider auch nicht geklappt.


    /**
    * For developers: WordPress debugging mode.
    *
    * Change this to true to enable the display of notices during development.
    * It is strongly recommended that plugin and theme developers use WP_DEBUG
    * in their development environments.
    *
    * For information on other constants that can be used for debugging,
    * visit the Codex.
    *
    * @Link https://codex.wordpress.org/Debugging_in_WordPress
    */
    /**define('WP_DEBUG', false);
    */
    ini_set('log_errors','On');
    ini_set('display_errors','Off');
    ini_set('error_reporting', E_ALL );
    define('WP_DEBUG', false);
    define('WP_DEBUG_LOG', true);
    define('WP_DEBUG_DISPLAY', false);


    /* That's all, stop editing! Happy blogging. */

    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    define( 'WP_ALLOW_MULTISITE', true );

    define ('FS_METHOD', 'direct');

    add_filter( "auto_update_plugin", "__return_true" );add_filter( "auto_update_theme", "__return_true" );add_filter( "allow_dev_auto_core_updates", "__return_true" ); add_filter( "allow_major_auto_core_updates", "__return_true" );

    Bin mal gespannt..

    Danke im Voraus und viele Grüße

    Daniel
     
  6. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    4.058
    Zustimmungen:
    263
    Probiere es mal ohne ini_set('error_reporting', E_ALL ); bzw. ohne alle orangen Zeilen, alleine nur mit define('WP_DEBUG', false);

    Hinweis am Rande, add_filter(..) haben in wp-config.php nichts verloren, mehr dazu hier. Und ob man "allow_major_auto_core_updates" wirklich will, nunja, das muss jeder selbst wissen bzw. merken.
     
  7. Persephone

    Persephone Well-Known Member

    Registriert seit:
    21. Februar 2016
    Beiträge:
    226
    Zustimmungen:
    1
    Hallo,

    WP_DEBUG ist eine PHP-Konstante (eine permanente globale Variable), mit der der Debug-Modus in WordPress ausgelöst werden kann. Es wird davon ausgegangen, dass es standardmäßig "false" ist und normalerweise in der Datei " wp-config.php " auf Entwicklungskopien von WordPress auf "true" gesetzt wird.

    Debugging aktivieren
    define ('WP_DEBUG', true);

    Deaktivieren Sie das Debugging

    define ('WP_DEBUG', false);

    Die Werte true und false im Beispiel werden nicht in Apostrophe (') festgelegt, da es sich um boolesche Werte handelt. Wenn du WP_DEBUG auf 'false' setzt, wird es als true interpretiert, da es sich um einen String und nicht um einen Boolean handelt.


    Gruß
     
  8. stativkunst.de

    Registriert seit:
    8. November 2018
    Beiträge:
    5
    Zustimmungen:
    0
    Moin moin,

    hat leider nichts gebracht.... die Meldungen treten immer noch auf. Doof vor dem Weihnachtsgeschäft.... ich würde bei solchen Scriptschnipseln in einem Shop gleich die Finger davon lassen. Wie kann ich denn auf die vorherige Version von Woocommerce downgraden?

    Danke für Eure / Ihre Hilfe

    Daniel
     
  9. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    4.058
    Zustimmungen:
    263
    Seltsam, es sind gar keine Scriptschnipsel nötig.

    Wenn alles orange weg ist und alleine nur die ganz normale WordPress Einstellung define('WP_DEBUG', false); benutzt wird, und trotzdem Warnings auftreten, liegt es ggf. an anderen Voreinstellungen des Servers o.ä.

    Alternativ kannst Du den ursächlichen, bereits oben verlinkten Fehler in WooCommerce ggf. manuell beheben, bevor ein neues Update rauskommt.
     
    stativkunst.de gefällt das.
  10. Hadestid

    Hadestid Member

    Registriert seit:
    7. November 2018
    Beiträge:
    10
    Zustimmungen:
    0
    Ich bin froh, dass ich an diesem Forum teilnehme.
     
  11. stativkunst.de

    Registriert seit:
    8. November 2018
    Beiträge:
    5
    Zustimmungen:
    0
    Moin moin,

    habe das manuell angepasst und nun tritt der Fehler nicht mehr auf. Super, vielen Dank!

    Gruß
    Daniel
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden