1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Nutze Wordpress 3.4.1 - Wordpress meint es wäre zu alt!

Dieses Thema im Forum "Konfiguration" wurde erstellt von o.host, 22. Juli 2012.

  1. o.host

    o.host Member

    Registriert seit:
    22. Juli 2012
    Beiträge:
    7
    Zustimmungen:
    0
    Guten Tag Gemeinde,

    Ich habe eine mittelschweres Problem - wie viele hier.
    Ich bin, wie soll's auch anders sein, absoluter Wordpress-Neuling/Laie
    Ich haben heute nun zum ersten Mal Wordpress 3.4.1 installiert und gleich im ersten Anlauf alles richtig gemacht.
    Ich durfte mich anmelden und sogar einen neuen Benutzernamen nebst Passwort vergeben.
    Auf der normalen Handelsüblichen Startseite von Wordpress angekommen wollte ich auch gleich loslegen und eine von diesen Blogseiten erstellen die es schon zu Hauf im Internet gibt, als mich Wordpress darauf Hinwies das ich wohl nicht die aktuellste und neueste Version benutze.

    Also dachte ich mir machste mal eben noch ein Update für die neueste Version und dann gehts los.

    Aber, wie soll es auch anders sein, nach dem Update meinte Wordpress weder von mir gehört oder gelesen zu haben.
    Ich bekomme jetzt im Headerbereich, bzw. im Topbereich, folgende Meldung angezeigt:

    Notice: add_custom_background ist seit Version 3.4 veraltet!
    Benutze stattdessen add_theme_support( 'custom-background', $args ). in
    /customers/_8/5/4/meinedoofeseite.com/httpd.www/blogpages/wp-includes/functions.php
    on line 2628 Notice: add_custom_image_header ist seit Version 3.4
    veraltet! Benutze stattdessen add_theme_support(
    'custom-header', $args ). in
    /customers/_8/5/4/meinedoofeseite.com/httpd.www/blogpages/wp-includes/functions.php
    on line 2628 Warning: Cannot modify header information - headers already sent by
    (output started at
    /customers/_8/5/4/meinedoofeseite.com/httpd.www/blogpages/wp-includes/functions.php:2628)
    in /customers/_8/5/4/paraguaywebsites.com/httpd.www/landingpages/wp-login.php on
    line 362 Warning: Cannot modify header information - headers already sent by
    (output started at
    /customers/_8/5/4/meinedoofeseite.com/httpd.www/blogpages/wp-includes/functions.php:2628)
    in /customers/_8/5/4/meinedoofeseite.com/httpd.www/blogpages/wp-login.php on
    line 374 Warning: Cannot modify header information - headers already sent by
    (output started at
    /customers/_8/5/4/meinedoofeseite.com/httpd.www/blogpages/wp-includes/functions.php:2628)
    in
    /customers/_8/5/4/meinedoofeseite.com/httpd.www/blogpages/wp-includes/pluggable.php
    on line 680 Warning: Cannot modify header information - headers already sent by
    (output started at
    /customers/_8/5/4/meinedoofeseite.com/httpd.www/blogpages/wp-includes/functions.php:2628)
    in
    /customers/_8/5/4/meinedoofeseite.com/httpd.www/blogpages/wp-includes/pluggable.php
    on line 681 Warning: Cannot modify header information - headers already sent by
    (output started at
    /customers/_8/5/4/meinedoofeseite.com/httpd.www/blogpages/wp-includes/functions.php:2628)
    in
    /customers/_8/5/4/meinedoofeseite.com/httpd.www/blogpages/wp-includes/pluggable.php
    on line 682 Warning: Cannot modify header information - headers already sent by
    (output started at
    /customers/_8/5/4/meinedoofeseite.com/httpd.www/blogpages/wp-includes/functions.php:2628)
    in
    /customers/_8/5/4/meinedoofeseite.com/httpd.www/blogpages/wp-includes/pluggable.php
    on line 881

    Nun meine Frage:
    Was kann ich tun ohne alles Neu installieren zu müssen ?
     
    #1 o.host, 22. Juli 2012
    Zuletzt bearbeitet: 22. Juli 2012
  2. Domino5702

    Domino5702 Well-Known Member

    Registriert seit:
    30. April 2009
    Beiträge:
    2.634
    Zustimmungen:
    0
    Hallo,

    Meinst Du mit der "handelsüblichen Startseite" das Dashboard (manchmal auch Backend genannt)? Hast Du von hier die DE-Edition installiert oder das Original in Englisch? Welches Theme (Design) setzt Du ein? Erscheint diese Meldung auch beim Standardtheme Twenty-Eleven? Hast Du bereits irgendwelche Plugins installiert? (ausser Hello Dolly und Akismet, die sind zwar im Paket enthalten aber sollten nicht aktiviert sein)?

    Sorry für die vielen Rückfragen, ich versuche damit festzustellen, wie genau Deine WordPress-Umgebung aussieht.
     
  3. Ammaletu

    Ammaletu Well-Known Member
    Ehrenmitglied

    Registriert seit:
    14. Juli 2007
    Beiträge:
    4.694
    Zustimmungen:
    0
    Der Hinweis auf die veraltete (deprecated) Funktion ist für Entwickler gedacht und muss Dich nicht weiter stören. Wenn Du Plugins und Themes einsetzt, kommst Du eigentlich nicht drum herum. Was schlecht ist, dass der Fehler am Bildschirm ausgegeben wird. Das gehört in eine Logdatei und nicht Deinen Besuchern angezeigt. Da wirst Du mal schauen müssen, wie Du Deine PHP-Installation entsprechend konfigurierst. Frag ggf. den Support Deines Hosters bzw. probiere mal, in der wp-config.php WP_DEBUG auf false zu stellen (einfügen falls nicht vorhanden).
     
  4. o.host

    o.host Member

    Registriert seit:
    22. Juli 2012
    Beiträge:
    7
    Zustimmungen:
    0
    Genau ich meine das Dashboard und ich habe die deutsche Version - also DE-Edition 3.4.1 installiert. Ich habe auch zwischenzeitlich alles auf dem Testserver, was meine Domain bei One.com ist, gelöscht mit anschließender Neuinstallation, genau nach Anleitung. Wenn ich jetzt die Seite aufrufe bekomme ich gleich im Top-Bereich folgende Meldung:

    Notice: add_custom_background ist seit Version 3.4 veraltet!
    Benutze stattdessen add_theme_support( 'custom-background', $args ). in
    /customers/_8/5/4/pmeinedoofeseite.com/httpd.www/blogpageswp-includes/functions.php
    on line 2628 Notice: add_custom_image_header ist seit Version 3.4
    veraltet! Benutze stattdessen add_theme_support(
    'custom-header', $args ). in
    /customers/_8/5/4/meinedoofeseite.com/httpd.www/blogpages/wp-includes/functions.php
    on line 2628

    angezeigt.
    Wenn ich mich dann Anmelden will kennt er meine Anmeldung garnicht erst und gibt mir den langen Text aus, den ich gestern schon abgebildet habe, ohne irgendetwas vom Dashboard an zu zeigen.

    Ich bin verzweifelt und am Ende ...
     
  5. Michi91

    Michi91 Well-Known Member

    Registriert seit:
    8. November 2008
    Beiträge:
    1.851
    Zustimmungen:
    20
    Also ich würde sagen nicht dein Wordpress ist veraltet sondern das von dir eingesetzte Design oder plugins :)
    Kannst du bei One die PHP Option "Display Errors" deaktivieren? Und hast du in der wp-config.php evtl Wp Debug aktiviert? Damit solltest du die Fehlermeldung unterdrücken können


    wie bereits von ammaletu beschrieben...
     
    #5 Michi91, 22. Juli 2012
    Zuletzt bearbeitet: 22. Juli 2012
  6. o.host

    o.host Member

    Registriert seit:
    22. Juli 2012
    Beiträge:
    7
    Zustimmungen:
    0
    habe den Debug zwischenzeitlich deaktiviert. leider kann ich nicht sagen/schreiben ob die Plugins veraltet sind.
    Zwar zeigt WP die Fehlermeldung nicht mehr an aber ich komme auch nicht mehr mit meiner Anmeldung rein.
    Jetzt heißt es:
    [h=1]Fehler beim Aufbau einer Datenbankverbindung[/h]
    obwohl ich die richtige Datenbank und den richtigen Benutzernamen nebst Password in der wp-config.php eingetragen habe.
    Ist echt ärgerlich das ganze ...
     
  7. Michi91

    Michi91 Well-Known Member

    Registriert seit:
    8. November 2008
    Beiträge:
    1.851
    Zustimmungen:
    20
    hmm wenn die daten richtig sind ist evtl gerADE DER datenbankserver nicht erreichbar?
     
  8. o.host

    o.host Member

    Registriert seit:
    22. Juli 2012
    Beiträge:
    7
    Zustimmungen:
    0
    möglich ... meine seite lässt sich momentan erreichen aber wenn ich die Blogseite dahinter eingebe dann kommt die 404 fehlermeldung
     
  9. Michi91

    Michi91 Well-Known Member

    Registriert seit:
    8. November 2008
    Beiträge:
    1.851
    Zustimmungen:
    20
    OO hast du vielleicht ausversehen irgendwelche ordner verschoben? höärt sich so an als wäre irgendwas durcheinader gerateb
     
  10. o.host

    o.host Member

    Registriert seit:
    22. Juli 2012
    Beiträge:
    7
    Zustimmungen:
    0
    ich muss mich berichtigen - die Fehlermeldung lautet 500 und nicht 404.
    nein alles ist da wo es hingehört und was mich am meisten ärgert ist das ich selbst nach einem löschen und anschliessender neuinstallation keinen zugang bekomme ...
     
  11. Ammaletu

    Ammaletu Well-Known Member
    Ehrenmitglied

    Registriert seit:
    14. Juli 2007
    Beiträge:
    4.694
    Zustimmungen:
    0
    Also die Datenbank-Fehlermeldung kommt eigentlich wirklich nur, wenn die Zugangsdaten falsch sind oder die Datenbank wirklich nicht erreichbar ist. Letzteres kannst Du mit dem technischen Support des Hosters klären, ist aber langfristig nicht sehr wahrscheinlich, dass es daran liegt. Sicher dass Du nicht aus Versehen einen Fehler in die wp-config.php eingebaut hast?

    Für Dein eigentliches Problem musst Du wohl oder übel mal die Behandlung von PHP-Fehlern korrekt einstellen. Also Anzeige am Bildschirm aus, Logging in eine Datei an (und da dann auch ruhig ab und an mal reinschauen). Mit ein bisschen Glück war es das ja schon und Du kanst Dich wieder anmelden.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden