1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Parse error - Spicepress Pro - CSS

Dieses Thema im Forum "Design" wurde erstellt von s-a-r-p, 25. März 2019.

  1. s-a-r-p

    s-a-r-p New Member

    Registriert seit:
    25. März 2019
    Beiträge:
    3
    Zustimmungen:
    0
    Guten Tag,

    für unsere Homepage welche wir über Wordpress gestalten benötigen wir Support. Hiiiiilfe!! [​IMG]

    Wir würden gerne das "Spicepress-Pro"-Theme auf Wordpress verwenden.
    Wir haben die Vollversion gekauft und normal in den FTP hochgeladen.

    Wenn wir nun auf Wordpress das Theme aktivieren möchten, bekommen wir folgende Fehlermeldung:

    Parse error: syntax error, unexpected T_FUNCTION in /hp/bc/ad/eu/www/security/wp-content/themes/spicepress-pro/functions/hooks/functions.php on line 42


    In der Line 42 steht hinter dem Wort Function in der Klammer nichts drin. So sieht es aus:
    $hook, function() use ( $hook ) {

    Wir haben folgendes schon probiert:

    - Löschen des Themes im FTP
    - Neuinstallation des Themes
    - Update von der "free" Version
    - Support bei Spice-Press (Indien) direkt erstellt - Diese Seite ist aber aufgrund eines abgelaufenen Zertifikates nicht mehr gültig.

    Dank vorab für (hoffentlich) hilfreiche Antworten.
     

    Anhänge:

  2. maxe

    maxe WPDE-Team
    Mitarbeiter

    Registriert seit:
    1. Mai 2008
    Beiträge:
    19.177
    Zustimmungen:
    180
    welche PHP Version läuft denn?
     
  3. Henk1060

    Henk1060 Well-Known Member

    Registriert seit:
    4. September 2014
    Beiträge:
    2.438
    Zustimmungen:
    108
    schon mal den fehler geoogelt?
    Da kommt der hinweis auf eine neuere PHP version einzustellen.
    Welche PHP version läuft bei dir
     
  4. s-a-r-p

    s-a-r-p New Member

    Registriert seit:
    25. März 2019
    Beiträge:
    3
    Zustimmungen:
    0
    PHP Version 5.2.17
     
  5. s-a-r-p

    s-a-r-p New Member

    Registriert seit:
    25. März 2019
    Beiträge:
    3
    Zustimmungen:
    0
    maxe

    Vielen Viele Dank!

    Nach Update der PHP Version funktioniert es.
    Danke ! :D

     
  6. Henk1060

    Henk1060 Well-Known Member

    Registriert seit:
    4. September 2014
    Beiträge:
    2.438
    Zustimmungen:
    108
    ok, dann war es an der zeit die php version zu ändern... ich hoffe du verwendest jetzt mind. php 7.1
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden