1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Parse error: syntax error, unexpected T_OBJECT_OPERATOR

Dieses Thema im Forum "Allgemeines" wurde erstellt von nuss75, 11. Juli 2019 um 19:49 Uhr.

  1. nuss75

    nuss75 Well-Known Member

    Registriert seit:
    20. Juni 2017
    Beiträge:
    70
    Zustimmungen:
    1
    Hi,

    wollte gerade eine WP-Site veröffentlichen jedoch dürft es irgendwo haken :/. Ich hab einen Error erhalten: Parse error: syntax error, unexpected T_OBJECT_OPERATOR in /home/meinedomain.com/wp-settings.php on line 356

    Hab im Netz gelesen, dass kann zusammenhängen, wenn ma eine niedrige PHP Version verwendet. Aktuell läuft der Server mit PHP Version ".4.8-pl0-gentoo".

    Kann das damit zusammenhängen? Ich werd morgen den Hoster kontaktieren, da ich C-Panel die PHP Version nirgends raufschrauben kann, wollte mir nur eine Zusicherung holen damit das auch wirklich der Grund ist.

    Hoffe auf eine Antwort.

    Besten Dank!

    Alex
     
  2. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    5.548
    Zustimmungen:
    466
    Mindestvoraussetzung für WordPress ist PHP 5.6.20, empfohlen ist PHP 7.3.
    Ein Server mit einer PHP 5.4.8 (wahrscheinlich fehlt die führende 5?) aus dem Jahr 2012(!) ist nicht ausreichend und sollte eher nicht im Internet betrieben werden.
     
  3. nuss75

    nuss75 Well-Known Member

    Registriert seit:
    20. Juni 2017
    Beiträge:
    70
    Zustimmungen:
    1
    Upsss, ich wollt schreiben 4.4.8 sogar .. wirklich URALT - das heißt jetzt, die PHP Version ist zu alt um Wordpress zum Laufen zu bekommen?
     
  4. danielgoehr

    danielgoehr Well-Known Member

    Registriert seit:
    13. Juli 2016
    Beiträge:
    2.330
    Zustimmungen:
    37
    Ja, definitiv. Dieser Server sollte so gar nicht mehr (öffentlich) betrieben werden. Nicht nur nicht für Wordpress, sondern schlicht gar nicht.
     
  5. SirEctor

    SirEctor WPDE-Team
    Mitarbeiter

    Registriert seit:
    28. Oktober 2008
    Beiträge:
    11.572
    Zustimmungen:
    284
    Welcher Hoster setzt denn noch eine so alte Version ein? Ich kann das kaum glauben.

    Mittlerweile sind wir bei 7.x
     
  6. nuss75

    nuss75 Well-Known Member

    Registriert seit:
    20. Juni 2017
    Beiträge:
    70
    Zustimmungen:
    1
    Hi,

    ja auf dem Server wurde nie etwas Aktualisiert geschweige Updates gemacht. Nach dem Upgrade auf PHP 7.0 und Mysql auf 5.6 läuft die Site. An dem ists wohl gelegen.

    Danke!
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden