1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

WP 4.3 Permalink Problem beim erstellen neuer Seite

Dieses Thema im Forum "Konfiguration" wurde erstellt von Beofax, 4. September 2015.

  1. Beofax

    Beofax New Member

    Registriert seit:
    4. September 2015
    Beiträge:
    3
    Zustimmungen:
    0
    Ahoi!

    Ich habe seit heute ein Problem beim erstellen einer Seite.

    Jedes mal wenn ich eine neue Seite mit dem Titel XY erstellen
    möchte, fügt WP ein "-2/" hinzu.

    Also so siehts aus:
    http://meinedomain.de/Titel-XY-2/

    soll aber so aussehen:
    http://meinedomain.de/Titel-XY/

    Ich hatte zuvor eine Seite mit dem gleichen Titel, diese wurde aber
    bereits unwiederruflich gelöscht, im Papierkorb ist nichts vorhanden.

    Ich hab mehrmals versucht die Seite zu erstellen, aber Fehlanzeige, es
    wird immer eine -2 hinzugefügt. Das komische ist das in der MSQL-DB der Eintrag
    gar nicht drin steht bzw. ich ihn nicht finden kann, sonst hätte ich ihn dort
    löschen können. Editieren lässt sich der Permalink auch nicht.

    Ein Cache-Problem des Browsers kann ich ausschließen.

    Hat jemand eine Idee woran das Problem liegen könnte? Über Hinweise und
    Lösungvorschläge würde ich mich freuen.

    Beofax
     
  2. Beofax

    Beofax New Member

    Registriert seit:
    4. September 2015
    Beiträge:
    3
    Zustimmungen:
    0
    Thema hat sich erledigt!

    Ich bin jetzt nochmal in die MySQL-DB und habe die komplette Tabelle
    manuell durchsucht und den Übeltäter gefunden und vernichtet! :D
     
  3. Marcus[IS]

    Marcus[IS] Well-Known Member

    Registriert seit:
    23. August 2009
    Beiträge:
    5.611
    Zustimmungen:
    93
    Kannst du das noch ein wenig genauer erläutern, was der Übeltäter war und wie du in ausgemerzt hast?
    Ich meine mich dunkel zu erinnern, dass dieses Problem schon mal vor einiger Zeit hier auftauchte und glaube das es irgendwann wieder mal auftaucht. :)
     
  4. Brawler

    Brawler Gast

    Das sind die Orphans/Revisionen, die gerne in der Datenbank verbleiben. WordPress findet dann bei der Überprüfung die immer noch vorhandene Taxonomie und hängt brav den Counter an den Permalink. :)
     
  5. Monika

    Monika Well-Known Member
    Ehrenmitglied

    Registriert seit:
    4. Juni 2005
    Beiträge:
    14.126
    Zustimmungen:
    2
    gibt es eine Seite, einen Beitrag, ein Bild => egal, ob veröffentlicht, einfach hochgeladen oder im Papierkorb ist das die "erste URL, " je nach Permalink Einstellung,
    da es doppelte URLs nicht geben soll passiert dann das Anhängen von Ziffern.
     
  6. Beofax

    Beofax New Member

    Registriert seit:
    4. September 2015
    Beiträge:
    3
    Zustimmungen:
    0
    Nichts spektakuläres, ich habe lediglich den Eintrag, welcher den Titel meines Beitrags enthielt, aus der wp_posts Tabelle gelöscht. Dazu musste ich aber die ganze Tabelle, welche etliche Einträge hat, manuell durchsuchen, denn die Such-Funktion hatte nichts gefunden. Erwähnen sollte man vielleicht noch, dass ich zuvor, bevor ich in der DB rumgewurschelt habe, eine Sicherung der Datenbank gemacht habe. Bei mir auf dem Server läuft zwar 1x am Tag automatisch eine Sicherung, aber sicher ist sicher.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden