1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Permalink-Problem: Blättern nicht mehr möglich

Dieses Thema im Forum "Konfiguration" wurde erstellt von Schattendings, 26. Mai 2009.

Schlagworte:
  1. Schattendings

    Schattendings Well-Known Member

    Registriert seit:
    27. Juni 2005
    Beiträge:
    56
    Zustimmungen:
    0
    ... und noch ein Problem :( :

    Seit einiger Zeit ist in meinem Blog das Blättern bei aktivierten Permalinks nicht mehr möglich. Ich kann leider nicht mehr nachvollziehen, wann das passiert ist und welche Änderungen ich zuvor vorgenommen habe.
    Beim Blättern erscheint z.B. beim Aufruf des Links http://www.schattendings.de/page/2/ die Fehlermeldung:

    Not Found
    The requested URL /page/2/ was not found on this server.
    (Wobei mich da zusätzlich noch wundert, warum nicht die 404er-Fehlermeldung von Wordpress erscheint.)

    Wenn ich die Permalinks deaktiviere, kann ich hingegen ohne Einschränkungen überall hin vor- und zurückblättern.

    Ich hatte ähnliche Probleme schon hier im Forum gefunden, aber vermutlich ist es bei mir etwas anders, denn die vorgeschlagenen Lösungsmöglichkeiten halfen alle nicht:

    Die Permalinks basieren bei mir auf Tag und Name, das habe ich auch nie geändert.
    Irgendwann habe ich BotTrap installiert, aber auch wenn ich BotTrap jetzt entferne bleibt die Fehlermeldung.
    Ich habe alle Plugins deaktiviert.
    Ich habe die Standard-Templates wieder aktiviert.
    Ich habe in der DB-Tabelle wp_options die Werte für rewrite_rules gelöscht.
    Ich habe eine leere .htaccess hochgeladen, als alles wieder auf Standard war, und dann Permalinks wieder aktiviert.

    Hat alles nichts gebracht, das Problem bleibt.
    Jetzt weiss ich wirklich nicht, was ich noch ausprobieren kan...
     
  2. Monika

    Monika Well-Known Member
    Ehrenmitglied

    Registriert seit:
    4. Juni 2005
    Beiträge:
    14.126
    Zustimmungen:
    2
    in den Archiven funktioniert die Blätterei habe ich grade getestet

    poste hier mal die index.php rein ;)

    lg
     
  3. funkygog

    funkygog Well-Known Member

    Registriert seit:
    2. November 2006
    Beiträge:
    631
    Zustimmungen:
    0
    Hast Du evtl. in den WP-Einstellungen ->Ausgabe ->Leseoptionen
    etwas eingestellt.

    So sieht es bei mir aus:
    Deshalb lautet der Link zur Seite 1
    blog.funkygog.de/chrono/
    und zur Seite 2
    blog.funkygog.de/chrono/page/2/
     
    #3 funkygog, 26. Mai 2009
    Zuletzt bearbeitet: 26. Mai 2009
  4. Schattendings

    Schattendings Well-Known Member

    Registriert seit:
    27. Juni 2005
    Beiträge:
    56
    Zustimmungen:
    0
    Sorry für die lange Schweigepause. Ich hatte auf eine Benachrichtigungsmail für neue Antworten gewartet, aber vergessen, das zu aktivieren.

    Stimmt, das mit dem Archiv hatte ich noch gar nicht getestet.

    Hier ist die index.php. Da ist momentan die Blätterfunktion auskommentiert, weil sie eben nicht funktioniert, aber so sah sie seit jeher aus. Das Theme ist übrigens ein eigenes.

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Bei mir ist als Startseite "Deine letzten Artikel" aktiviert. (Und es heisst alles etwas anders, wahrscheinlich habe wir unterschiedliche WP-Versionen.)
     
  5. Schattendings

    Schattendings Well-Known Member

    Registriert seit:
    27. Juni 2005
    Beiträge:
    56
    Zustimmungen:
    0
    Leider besteht das Problem immer noch. :(

    Ich hatte einen neuen Lösungsansatz gefunden im internationalen WP-Forum. PHP läuft bei mir nämlich seit einiger Zeit auch als CGI, was nicht immer so war. (Wie gesagt, ich weiss leider nicht mehr, seit wann das Blättern nicht mehr funktioniert.) Aber das war's leider auch nicht.
     
  6. sonilein

    sonilein Well-Known Member

    Registriert seit:
    29. Januar 2008
    Beiträge:
    53
    Zustimmungen:
    0
    Habe das gleiche Problem. Auf der Startseite ist das Blättern nicht mehr möglich. Hab alle Plugins deaktiviert und auch Permalink mal abgeschaltet.
    Aber alles hat nichts geholfen.Vermute das es gar nicht an Wordpress liegt sondern das vielleicht an den Servereinstellungen etwas geändert wurde?!
     
  7. AlexH

    AlexH Member

    Registriert seit:
    18. Juli 2009
    Beiträge:
    9
    Zustimmungen:
    0
    Bei mir ist es Seite 13...

    Auch hier das Problem. Die Navigation läuft bis Seite 12 einwandfrei. Danach, ab Seite 13, immer 404-Fehler! Echt seltsam.

    Also Permalink sieht so aus:

    /index.php/%year%/%monthnum%/%day%/%postname%/

    Standard funktioniert. Am Theme liegt es nicht. Diese Sache hier funktioniert bei mir nicht:

    http://forums.lesterchan.net/index.php/topic,3285.0.html

    Anybody? :neutral:
     
  8. Schattendings

    Schattendings Well-Known Member

    Registriert seit:
    27. Juni 2005
    Beiträge:
    56
    Zustimmungen:
    0
    Was es letztendlich war, weiss ich immer noch nicht, aber immerhin konnte ich das Problem lösen - mehr oder weniger.

    Ich habe eine aktuelle Version von Wordpress aufgesetzt (2.8, deutsche Version) und die gleichen Einstellungen für die Permalinks angegeben. Dann habe ich die Daten mit der Export-Import-Funktion von Wordpress von der alten, kaputten Installation in die neue gebracht. Dann habe ich nach und nach alle Plugins (von einigen gab es inzwischen neuere Versionen) wieder aktualisiert. Zwischendurch habe ich immer wieder überprüft, ob das Blättern noch funktioniert.

    Ich habe allerdings Bottrap nicht mehr installiert. Ich hatte es im Verdacht, den Fehler ausgelöst zu haben, weil das zu den letzten Änderungen gehörte, bevor mir der Fehler erstmalig aufgefallen ist, und dabei Änderungen an der htaccess notwendig waren. Belegen kann ich es allerdings nicht. Ich hatte in der alten Installation die Änderungen für Bottrap rückgängig gemacht, um das als Fehlerquelle auszuschließen, und es hatte keine Auswirkungen.

    Der Fehler ist bisher nicht mehr aufgetaucht.

    Optimal ist die Lösung natürlich nicht. Es ist ganz schön aufwendig, die ganzen Sachen manuell nachzuziehen, die beim Export-Import von WP nicht mitgenommen werden wie z.B. die registrierten Benutzer und deren Verknüpfungen zu ihren Kommentaren, Link-Kategorien, Links usw.

    Für die Angabe der Seitenzahlen benutze ich übrigens nun auch das Plugin von Lester Chan.
     
  9. sonilein

    sonilein Well-Known Member

    Registriert seit:
    29. Januar 2008
    Beiträge:
    53
    Zustimmungen:
    0
  10. AlexH

    AlexH Member

    Registriert seit:
    18. Juli 2009
    Beiträge:
    9
    Zustimmungen:
    0
    @Sonilein:


    Mh, war das Blättern generell nicht mehr möglich oder erst ab einer bestimmten Seitenzahl? Bei mir ists ja so, dass es erst ab Seite 12 nicht mehr geht, obwohl es 30 Seiten sind. Setze ich den wp-navi Befehl in die Fusszeile, funktioniert es komischerweise insofern, dass es nur 12 Seiten anzeigt zum Navigieren. Alle anderen Artikel werden also gar nicht angezeigt.

    Hab das bei mir so geändert, auch wenn der ursprüngliche Code anderes aussah, hat aber nix gebracht:

    <?php query_posts("showposts=4&category_name=Featured&paged=".$paged); $i = 1; ?>
     
  11. sonilein

    sonilein Well-Known Member

    Registriert seit:
    29. Januar 2008
    Beiträge:
    53
    Zustimmungen:
    0
    Bei mir war das Blättern generell nicht mehr möglich.
    Versuch doch mal alternativ WP Page Numbers. Damit hatte ich dein beschriebenes Problem noch nicht.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden