Permalink-Struktur nach Update geändert?

Dieses Thema im Forum "Konfiguration" wurde erstellt von learner, 11. Januar 2011.

  1. learner

    learner Active Member

    Registriert seit:
    7. März 2008
    Beiträge:
    36
    Zustimmungen:
    0
    Ich habe gerade bemerkt, dass sich die Permalink-Struktur in meinem Blog geändert hat.

    Vorher:
    http://kommunikation-zweinull.de/12-1-2011-11-twittwoch-ruhr-still-leben-a40-und-die-resonanz-im-social-web/

    URL/postname

    Nachher:
    http://kommunikation-zweinull.de/blog/12-1-2011-11-twittwoch-ruhr-still-leben-a40-und-die-resonanz-im-social-web/

    url/blog/postname

    Es existiert kein Unterverzeichnis "blog". Das Blog ist im Hauptverzeichnis installiert. Ich habe auch nichts an den Einstellungen geändert.
    Habe jedoch vor kurzem das Update auf 3.04 gemacht.

    htaccess sieht so aus:
    # BEGIN Wordpress

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    Stehe gerade etwas auf dem Schlauch. Hat jemand nen Tipp für mich?
     
    #1 learner, 11. Januar 2011
    Zuletzt bearbeitet: 11. Januar 2011
  2. maxe

    maxe WPDE-Team
    Mitarbeiter

    Registriert seit:
    1. Mai 2008
    Beiträge:
    18.161
    Zustimmungen:
    18
    Die Einstellungen für Permalinks hast du auch kontrolliert, auch die Kategorie-Basis?
     
  3. learner

    learner Active Member

    Registriert seit:
    7. März 2008
    Beiträge:
    36
    Zustimmungen:
    0
    ja, habe ich. Das ist es leider nicht.

    Taucht im nicht-editierbaren Bereich auf.

    Siehe Bild
     
  4. maxe

    maxe WPDE-Team
    Mitarbeiter

    Registriert seit:
    1. Mai 2008
    Beiträge:
    18.161
    Zustimmungen:
    18
    Funkt da viell. ein Plugin zwischen was den Fehler verursacht? Bitte mal testweise ALLE Plugins deaktivieren.
     
  5. learner

    learner Active Member

    Registriert seit:
    7. März 2008
    Beiträge:
    36
    Zustimmungen:
    0
    Das habe ich auch versucht. Leider erfolglos :-(

    Ich könnte mir vorstellen, dass es sich um eine Providerseitiges Problem handelt. Allerdings spricht dagegen, dass sich die Startseite ganz normal aufrufen lässt, ohne dass die /blog/ an die URL gehängt wird.

    Außerdem lässt sich das Backend (wp-admin) mit normaler URL aufrufen.

    Dieses drangehangenen /blog/ in die URL erscheint nur auf Beitragsebene. Kenne mich jetzt aber nicht gut genug mit htaccess aus um das zu entschlüsseln.
    Außerdem verwende ich den ganz normalen Standard htacess Code, der von Wordpress vorgeschlagen wird.

    Vielleicht sollte ich mal einen Blick in die Datenbank werfen?

    Habe in der w-options den Eintrag gefunden und mal umgestellt. Die Permalinks werden dann wieder richtig ausgegeben. Aber die Artikel werden leider nicht gefunden -> 404

    Hat jemand noch einen Tipp?
     
    #5 learner, 12. Januar 2011
    Zuletzt bearbeitet: 12. Januar 2011
  6. infected

    infected Well-Known Member

    Registriert seit:
    9. Juli 2006
    Beiträge:
    9.816
    Zustimmungen:
    0
    Das /blog/ wird bei aktiviertem Multisite Feature angehängt. Deaktiviere dieses in der wp-config.php (wenn nicht benötigt), speichere die Permalinks neu ab und schon sollte Dein Problem behoben sein.

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Wert auf false setzen oder ganze Zeile löschen.
     
  7. coffeemick

    coffeemick New Member

    Registriert seit:
    12. Januar 2011
    Beiträge:
    1
    Zustimmungen:
    0
    Ich denke, @infected hat den Fehler schon gefunden. Multi-Site kann ziemlich nerven.

    Ansonsten bei Problemen, die mit Permalinks zu tun haben:

    Die .htaccess kann automatisch von WordPress geändert werden, sobald die Rechte für diese Datei entsprechend gesetzt sind, was ich immer empfehlen würde. WordPress würde aber auf dem Konfigurationsdialog sagen, wenn es keine Schreibrechte für diese Datei besäße.

    An der .htaccess musst Du eigentlich nichts manuell ändern. WordPress erstellt sie entsprechend der eingestellten Konfiguration. Außer wenn Du alte URLs umschreiben willst, was ich aber meistens besser in der DB direkt erledige.

    Die Kategorie- und Schlagwortbasis sollte bei Dir "/" sein, und nicht "/blog". So wie Du es ja auch haben wolltest. Du kannst das zwar in der wp-options einstellen, solltest Du aber nicht, außer Du weißt genau, was Du tust. Sind diese Parameter dort eingestellt, kannst Du sie nicht mehr im Admin-Bereich ändern.

    Wenn Änderungen im Admin-Bereich für die Permalink-Struktur vorgenommen werden, ändert WordPress auch alle Einträge in der DB korrekt. Dort sind sie nämlich für jeden Beitrag noch mal hinterlegt. Wenn es manuell in der wp-options gemacht wird, dann musst Du es auch manuell in der DB machen. Ich hatte selbst mal durch Blog-Umzüge ein schiefen Stand erzeugt, obwohl ich mich meiner Meinung nach korrekt verhalten hatte.

    Ich würde also

    1) Die Permalinks in der wp-options auskommentieren oder löschen
    2) Im Admin-Bereich prüfen, welche Permalinks erkannt werden bzw. eingestellt sind
    3) u.U. im Admin-Bereich auf "/" zurück stellen, wenn es nicht eingestellt ist
    4) Links prüfen für
    - Startseite
    - Artikelseiten
    - Archiv, Tags, etc.

    Wenn dann noch etwas schief ist, würde ich die entsprechenden Einträge in der DB manuell ändern. Es gibt wohl auch Plugins für so eine Korrektur.