1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

WP 4.7 Permalinks nicht änderbar

Dieses Thema im Forum "Konfiguration" wurde erstellt von TPhil_HD, 2. Januar 2017.

  1. TPhil_HD

    TPhil_HD Member

    Registriert seit:
    1. Januar 2017
    Beiträge:
    9
    Zustimmungen:
    0
    Hallo zusammen,

    Ich habe ein Problem mit der Permalinkstrucktur meiner Website (Nevation.de).
    Ich würde sie gerne auf "Beitragsname" stellen um BuddyPress zu installieren, doch immer wenn ich die Permalinks ändere werden die Seiten nichtmehr gefunden.
    Die .htaccess ist beschreibbar und wird auch von Wordpress bearbeitet.

    Die Website ist im Wartungsmodus also falls jemand Zugriff auf die Website benötigt um den Fehler zu finden kann er mich über http://www.nevation.de kontaktieren.

    Infos:
    vServer
    apache2
    WP 4.7

    Ich würde mich über Tipps, was der Fehler sein könnte freuen.
    Vielen Dank!

    MfG TPhil_HD | Philipp
     
  2. danielgoehr

    danielgoehr Well-Known Member

    Registriert seit:
    13. Juli 2016
    Beiträge:
    2.450
    Zustimmungen:
    64
    Webserver ist Apache und mod_rewrite aktiviert?
     
  3. TPhil_HD

    TPhil_HD Member

    Registriert seit:
    1. Januar 2017
    Beiträge:
    9
    Zustimmungen:
    0
    Ich habe es mit "sudo a2enmod rewrite" und sudo "a2enmod actions" aktiviert.
    Wie muss meine "000-default.conf" Datei aussehen wenn ich das Modul aktivieren will?
    Muss man da noch etwas ändern?

    Danke schon mal für die Antwort!
     
  4. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.965
    Zustimmungen:
    8
    Vergiss den Webserver nicht neu zu starten.
    Sinnvollerweise sollte man für jeden Kunden / Domain einen extra vhost anlegen und nicht alles in einer default konfigurieren.
     
  5. TPhil_HD

    TPhil_HD Member

    Registriert seit:
    1. Januar 2017
    Beiträge:
    9
    Zustimmungen:
    0
    Ich habe nur 2 Seiten auf meinem vServer und diese habe ich eben 000-default.conf und die andere in mail.conf.
    Hab ihn neugestarten
     
  6. danielgoehr

    danielgoehr Well-Known Member

    Registriert seit:
    13. Juli 2016
    Beiträge:
    2.450
    Zustimmungen:
    64
    Und? Funktionierts?
     
  7. TPhil_HD

    TPhil_HD Member

    Registriert seit:
    1. Januar 2017
    Beiträge:
    9
    Zustimmungen:
    0
    Nein leider nicht :(
    Muss man mod_rewrite irgendwie noch per vhost aktivieren oder reicht es mit den beiden befehlen?
     
  8. danielgoehr

    danielgoehr Well-Known Member

    Registriert seit:
    13. Juli 2016
    Beiträge:
    2.450
    Zustimmungen:
    64
    Die Frage ist, läuft mod_rewrite nicht oder funktionieren deine Permalinks nicht, obwohl mod_rewrtie läuft? Erstell mal eine Datein mit phpinfo() und schau mal, ob mod_rewrite läuft.


    Ich würde behaupten, einfach aktivieren und gut ist. Ich erinnere mich nicht, dass ich da jemals großartig etwas konfigurieren musste.

    Ansonsten schau mal in die Anleitung:
    https://wiki.ubuntuusers.de/Apache/mod_rewrite/
     
  9. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.965
    Zustimmungen:
    8
    Schau mal, ob im entsprechenden vhost

    AllowOverride None

    steht. Falls ja, auf

    AllowOverride All

    ändern und ein Server Reload ausführen.
     
  10. TPhil_HD

    TPhil_HD Member

    Registriert seit:
    1. Januar 2017
    Beiträge:
    9
    Zustimmungen:
    0
    @danielgoehr

    mod_rewrite ist aktiv Danke!


    @Hille


    Nachdem ich "AllowOverride All" eingefügt habe konnte der apache nicht mehr starten :/
     
  11. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.965
    Zustimmungen:
    8
    Wo hast du das eingefügt, poste mal den vhost
     
  12. danielgoehr

    danielgoehr Well-Known Member

    Registriert seit:
    13. Juli 2016
    Beiträge:
    2.450
    Zustimmungen:
    64
    Und am besten auch die Fehlermeldung vom Apache.
     
  13. TPhil_HD

    TPhil_HD Member

    Registriert seit:
    1. Januar 2017
    Beiträge:
    9
    Zustimmungen:
    0
    Also so sieht der vhost aus:

    <VirtualHost *:80>
    ServerName www.nevation.de
    ServerAlias nevation.de
    ServerAdmin webmaster@localhost
    DocumentRoot /var/www/Website
    ErrorLog /var/log/apache2/error.log
    LogLevel warn
    CustomLog /var/log/apache2/access.log combined
    ServerSignature On
    </VirtualHost>

    Und hier habe ich es eingefügt:

    <VirtualHost *:80>
    ServerName www.nevation.de
    ServerAlias nevation.de
    ServerAdmin webmaster@localhost
    DocumentRoot /var/www/Website
    AllowOverride All
    ErrorLog /var/log/apache2/error.log
    LogLevel warn
    CustomLog /var/log/apache2/access.log combined
    ServerSignature On
    </VirtualHost>

    Danach steht in der Konsole dass in der Zeile "AllowOverride All" ein Fehler ist.

     
  14. danielgoehr

    danielgoehr Well-Known Member

    Registriert seit:
    13. Juli 2016
    Beiträge:
    2.450
    Zustimmungen:
    64
    Ich zitiere Mal aus der Doku...

    Quelle: https://httpd.apache.org/docs/2.4/de/mod/core.html#allowoverride


    Edit: Du hast die Directory listings nicht deaktiviert. Das solltest du !unbedingt!
    tun.

    Jetzt bitte nicht falsch verstehen, aber bist du dir sicher, dass es eine gute Idee ist, einen eigenen root server zu betreiben? Ich vermute, du wärst mit einem webhosting Paket, das "gemanaged" wird, besser bedient. Bedenke bitte, dass ein fehlerhaft aufgesetzter und nicht professionell administrierter Root-Server eine Gefahr für dich und andere darstellt...
     
    #14 danielgoehr, 2. Januar 2017
    Zuletzt bearbeitet: 2. Januar 2017
  15. TPhil_HD

    TPhil_HD Member

    Registriert seit:
    1. Januar 2017
    Beiträge:
    9
    Zustimmungen:
    0
    Ich verstehe schon bischen von Linux und das mit den Virtuellen vhosts ist momentan meine einzige Schwachstelle.

    Ich betreibe auf meinem vServer unter anderem mehrere Game-Server und einen Mail-Server... diese kann ich schlecht auf einem webhosting Packet laufen lassen.



    Ich habe mich nochmal informiert doch es funktioniert immer noch nicht.
    Wie würde denn ein funktionierender vhost für Wordpress aussehen?

    Danke für die Antworten!
     
  16. danielgoehr

    danielgoehr Well-Known Member

    Registriert seit:
    13. Juli 2016
    Beiträge:
    2.450
    Zustimmungen:
    64
    Naja, nur weil du es brauchst, heißt es nicht, dass es eine gute Idee ist.
    Ich brauche auch oft Klempner, Elektriker, etc. und es wäre trotzdem keine gute Idee, dass ich es selbst mache.
    Es war auch nur ein gut gemeinter Hinweis. Befolgen musst du es natürlich nicht.

    Hast du dir meine Antwort und meinen Link angeschaut? Da steht die Antwort eigentlich drin...

    Du schreibst ja, du hast dich nochmal informiert und es funktioniert immer noch nicht. Wie sieht denn dein vhost aktuell aus?
     
    #16 danielgoehr, 2. Januar 2017
    Zuletzt bearbeitet: 2. Januar 2017
  17. TPhil_HD

    TPhil_HD Member

    Registriert seit:
    1. Januar 2017
    Beiträge:
    9
    Zustimmungen:
    0
    HURRA!

    Es funktioniert!
    Ich habe bei "AllowOverride" mal "FileInfo" hingeschrieben und nun funktioniert es!



    Was bewirkt das?


    Hier nochmal der vhost

    <VirtualHost *:80>
    ServerName www.nevation.de
    ServerAlias nevation.de
    ServerAdmin webmaster@localhost
    DocumentRoot /var/www/Website
    <Directory /var/www/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride FileInfo
    Order allow,deny
    allow from all
    </Directory>
    ErrorLog /var/log/apache2/error.log
    LogLevel warn
    CustomLog /var/log/apache2/access.log combined
    ServerSignature On
    </VirtualHost>


    Vielen Dank nochmal an euch beiden.
     
  18. danielgoehr

    danielgoehr Well-Known Member

    Registriert seit:
    13. Juli 2016
    Beiträge:
    2.450
    Zustimmungen:
    64
    FileInfo erlaubt nicht alle Modifikationen über die htaccess. Für mod_rewrite reicht es aber aus.
    Der entscheidende Teil dürfte aber sein, dass du die "<directory>" Tags ergänzt hast.

    DirectoryListings ist (vereinfacht gesagt) das (öffentliche) anzeigen von Dateien auf deinem Server.. Wenn es aktiv ist (so wie jetzt) kannst du dir direkt die Dateien in einem Verzeichnis anschauen und herunterladen, sofern keine index.html oder index.php vorhanden ist. Das kann ein ernstzunehmendes Sicherheitsrisiko darstellen.

    Her zwei Beispiel von deinem Server:
    http://www.nevation.de/wp-includes/
    http://www.nevation.de/wp-content/uploads/

    Die wirklich kritischen Dateien lassen sich (zumindest auf den ersten Blick) aktuell nicht anzeigen, weil index-Dateien in den Verzeichnissen liegen. Es gibt aber keinen wirklich guten Grund das aktiviert zu lassen, insofern solltest du es dringend ausstellen.
    Das kannst du auch relativ einfach innerhalb der <directory> Tags machen, indem du Options -Indexes hinzufügst.


    Sehr gern :)
     
    #18 danielgoehr, 2. Januar 2017
    Zuletzt bearbeitet: 2. Januar 2017
  19. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.965
    Zustimmungen:
    8
    Ich bin mir zu 99% sicher, das du nichts von Linux verstehst bzw. weißt, wie man einen Server richtig konfiguriert. Ich habe mal ein paar "kleine Test" von außerhalb an deinem Server durchgeführt. Glaube mir, da sind etliche Problemstellen sofort erkennbar. Das beginnt bei einer fehlerhaften DNS Konfiguration los, geht weiter über einen fehlenden Paketfilter usw usw. Server wie deiner sind es, die andere Admins dazu zwingen, sich jeden Tag mit dem Thema Spamabwehr, DDoS, Brute Force usw zu beschäftigen.
     
    #19 Hille, 2. Januar 2017
    Zuletzt bearbeitet: 2. Januar 2017
  20. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    7.348
    Zustimmungen:
    734
    Den Anhang 16245 betrachten

    Do you want get hacked? Because that's how you get hacked. - Archer ants
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden