1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Permalinks und rewrite funktioniert nicht

Dieses Thema im Forum "Konfiguration" wurde erstellt von michaHH, 25. Januar 2012.

Schlagworte:
  1. michaHH

    michaHH New Member

    Registriert seit:
    25. Januar 2012
    Beiträge:
    3
    Zustimmungen:
    0
    Hallo Community,

    ich habe ein Problem mit den Permalinks, und zwar läßt sich die default-Einstellung http://domain.de/?p=123 nicht umwandeln in die URL
    http://domain.de/%post_id%/%postname%/
    Auch andere Formen funktionieren nicht. Benutze ich allerdings /index.php vor den gewünschten Änderungen gehts. Ich weiß das bei diesem Verfahren kein Zugriff über mod_rewrite und .htaccess erfolgt.
    Die Lösung finde ich aber suboptimal, und möchte nun herausfinden wo das Problem liegt.
    Mein Apache hat den mod_rewrite enabled, das habe ich unter mods-enabled nachgesehen. Die .htaccess liegt im wordpress-Ordner, also auch dort wo die wp-config.php liegt. Schreibrechte habe ich vergeben, momentan ist 770 eingestellt obwohl eigentlich auch 700 für www-data reichen sollte.
    Hat vielleicht einer eine Idee woran das liegen kann dass die URL nicht weitergeleitet wird, und ich immer 404 bekomme?
    Hier noch der Inhalt meiner .htaccess:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Vielen Dank für eure Hilfe!

    Gruss

    Michael
     
  2. Ammaletu

    Ammaletu Well-Known Member
    Ehrenmitglied

    Registriert seit:
    14. Juli 2007
    Beiträge:
    4.694
    Zustimmungen:
    0
  3. michaHH

    michaHH New Member

    Registriert seit:
    25. Januar 2012
    Beiträge:
    3
    Zustimmungen:
    0
    Ja ich habe root-Rechte und einen root-Server, die Rechte habe ich rekursiv mit 770 für www-data:www-data vergeben, schreiben kann der Server und tut es auch nur hat es keine Auswirkung auf das Ergebnis, es wird trotzdem 404 angezeigt, dass ist ja das was ich nicht verstehe. Muss eine .htaccess noch im themes-Ordner erstellt werden?
     
  4. Ammaletu

    Ammaletu Well-Known Member
    Ehrenmitglied

    Registriert seit:
    14. Juli 2007
    Beiträge:
    4.694
    Zustimmungen:
    0
    Mit "Rechten" meinte ich, dass im Apache für das WP-Verzeichnis das hier erlaubt sein muss:

     
  5. michaHH

    michaHH New Member

    Registriert seit:
    25. Januar 2012
    Beiträge:
    3
    Zustimmungen:
    0
    Juhuu, hab unter Sites-enabled das AllowOverwrite von none auf FileInfo umgestellt und es funktioniert :)
    Danke dir!!!!!!!!!
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden