1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

WP 6.x php 7.4 => 8.1

Dieses Thema im Forum "Installation" wurde erstellt von jan99, 2. Mai 2023.

  1. jan99

    jan99 Well-Known Member

    Registriert seit:
    18. September 2011
    Beiträge:
    176
    Zustimmungen:
    1
    Moin!

    ich muss mein PHP bei 1und1 hochziehen (derzeit noch kein https).

    Es geht um http://www.osm-luebeck.de/

    Habe die empfohlene Version 8.1 gewählt. Beim ersten Aufruf kam noch die Startseite (vermutlich aus dem Cache), aber schon beim ersten Aufruf einer Seite eine Meldung, dass ein kritischer Fehler vorliegt.

    Ich werde dann auf die Seite https://wordpress.org/documentation/article/faq-troubleshooting/ weitergeleitet.

    Aber nun stehe ich auf dem Schlauch und brauche einmal Hilfe.

    Das "dumme" ist nämlich, dass noch zwei Domainen (mit https) anstehen die auch noch hochgezogen werden müssen.

    Ich meine alle Plugins vor dem Hochziehen aktuell gesetzt zu haben.

    Kann mir einer weiterhelfen? Gibt es eine Logdatei, die zum Beispiel dokumentiert wenn Plugins stören?

    Gruß Jan
     
    #1 jan99, 2. Mai 2023
    Zuletzt bearbeitet: 2. Mai 2023
  2. Zunächst solltest Du die PHP Version wieder zurücksetzen auf Deine vorige Version und dann weiter schauen. Vor dem nächsten "hochziehen" - was immer das für Dich heissen mag, deaktiviere alle Plugins und wähle die nächsthöhere PHP-Version, dann aktiviere der Reihe nach die Plugins und prüfe die Website usw. usw.
     
  3. jan99

    jan99 Well-Known Member

    Registriert seit:
    18. September 2011
    Beiträge:
    176
    Zustimmungen:
    1
    Moin!

    habe gerade eine Mail vom System bekommen und der WP-Ticker, sowie der Theme waren die Ursache.

    Gewechselt bzw. weg damit und alles ist wieder da!

    Dennoch Danke für die Rückmeldung.

    Jan
     
  4. r23

    r23 Well-Known Member

    Registriert seit:
    9. Dezember 2006
    Beiträge:
    7.283
    Zustimmungen:
    576
    Problem kann das Theme sein oder ein Plugin. Die Log Dateien von 1und1 kann man in der regel vergessen und es geht oft leider nur über recht umständliche weg wie bereist beschrieben.

    Die PHP Migration von 7.4 auf PHP 8.1 ist nicht ohne.
    Von 7.4 auf 8.0 das Handbuch
    https://www.php.net/manual/de/migration80.php

    von 8.0 auf 8.1 das Handbuch
    https://www.php.net/manual/de/migration81.php

    Und wenn du dich mit PHP Klassen beschäftigen möchtest ...
    machst du gleich den Sprung auf 8.2
    https://www.php.net/manual/de/migration82.php

    Gute PHP Kenntnisse sind erforderlich.
    bei einigen PHPFehlermeldungen.... Die Autoren von PHP können wirklich ganz tolle Fehlermeldungen erzeugen - auf die kein denkender Mensch freiwillig kommt.... Dafür verwende ich de Bing KI. Dies verkürzt die Suche in den einschlägigen Foren erheblich.... Die Bin Ki nennt auch die Quellen ohne extra Rückfragen.

    Ansonsten noch der Tipp => Job Forum.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden