1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

WP 4.9 PHP-Code über Textfeld auf Seite ausführen

Dieses Thema im Forum "Allgemeines" wurde erstellt von kasvolli, 29. November 2018.

  1. kasvolli

    kasvolli Member

    Registriert seit:
    4. Oktober 2017
    Beiträge:
    5
    Zustimmungen:
    0
    Hallo zusammen,

    verzweifele gerade etwas... Ich versuche seit Tagen durch Googlen und Ausprobieren etwas wiederherzustellen, was ich längst schon mal zum Laufen gebracht hatte... Wie der Titel des Themas schon sagt, möchte ich meine PHP-Skripts über [includes] in Wordpress-Seiten ausführen. Dazu habe ich in die 'functions.php' entsprechend benötigten Code geschrieben. Leider bekomme ich es trotz großer Anstrengungen nicht mehr hin. Meine Frage wäre nun: woran kann das liegen? Meine Überlegungen dazu:
    • Ist diese Möglichkeit ab einer bestimmten Wordpress-Version gesperrt worden? Ich setze aktuell die 4.9.8 ein.
    • Ich habe ein Child-Theme für mein 'MH Magazine Lite' eingerichtet. Den Code für die PHP-Includes habe ich in die 'functions.php' des Child-Themes geschrieben. Könnte das ein Problem sein?
    Gibt es vielleicht noch etwas, was ich nicht bedacht habe? Wenn weitere Details benötigt werden, würde ich diese natürlich gerne preisgeben. :)

    Vielen Dank schon mal für Eure Hilfe.

    Viele Grüße
    Sven
     
  2. r23

    r23 Well-Known Member

    Registriert seit:
    9. Dezember 2006
    Beiträge:
    4.134
    Zustimmungen:
    16
    Leider zeigst du deinen PHP Code nicht

    includes get_template_directory() . '/lib/dein_script.php';


    hier liegt das Script im Verzeichnis /lib/ von dem Theme.

    Du könntest dir die Fehler im System ansehen:

    PHP:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
     
  3. kasvolli

    kasvolli Member

    Registriert seit:
    4. Oktober 2017
    Beiträge:
    5
    Zustimmungen:
    0
    Danke für die schnelle Antwort. Hier der Code, den ich in die 'functions.php' des Child Themes eingefügt habe:
    PHP:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Ausgeführt wird dann mein jeweiliges Skript über folgenden Aufruf im Textfeld der jeweiligen Seite:
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Wie bereits geschrieben, auf diese Weise lief das auch schon mal problemlos. Müsste es auch unter WP 4.9.8 so sein?
     
  4. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    4.146
    Zustimmungen:
    274
    TEMPLATEPATH zeigt a) auf den Ordner des Parent Themes und b) die direkte Nutzung der Konstanten wird nicht mehr empfohlen, verwende z.B. in Deinem Fall get_stylesheet_directory().

    Zum einfacheren Debugging könnte der Shortcode z.B. entspr. Texte zurückgeben, wenn die Datei nicht exisitert usw.
     
    kasvolli gefällt das.
  5. kasvolli

    kasvolli Member

    Registriert seit:
    4. Oktober 2017
    Beiträge:
    5
    Zustimmungen:
    0
    Vielen Dank, das war es. Nachdem ich TEMPLATEPATH durch get_stylesheet_directory() ersetzt habe, klappt es nun wieder.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden