1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

PHP mail() und HostEurope

Dieses Thema im Forum "Konfiguration" wurde erstellt von F.LM, 8. März 2007.

  1. F.LM

    F.LM Well-Known Member

    Registriert seit:
    24. Juli 2005
    Beiträge:
    192
    Zustimmungen:
    0
    Hi,

    an irgend einer Sicherheitsenstellung bei HostEurope (wo allem meine WP-Blogs und Foren laufen) liegt es, dass Mails mit phpmail() nicht verschickt werden. Ich habe schon alle möglichen Plugins ausprobiert.

    Kennt sich irgend jemand soweit aus, dass er mir sagen kann, was das für eine Sicherheitseinstellung sein kann und wie ich die deaktiviere/umgehe?
     
  2. spickzettel

    spickzettel Well-Known Member

    Registriert seit:
    19. Januar 2006
    Beiträge:
    1.848
    Zustimmungen:
    0
    #2 spickzettel, 8. März 2007
    Zuletzt bearbeitet: 8. März 2007
  3. F.LM

    F.LM Well-Known Member

    Registriert seit:
    24. Juli 2005
    Beiträge:
    192
    Zustimmungen:
    0
    Danke für den Hinweis.

    Das Problem ist, dass ich eine alte KIS-Version in meinem Paket habe, die auch nicht aktualisiert wird (weil es ein Gratis-Presseaccount ist). Daher gibt es im Skripte-Menü die Einstellungsmöglichkeit nicht.

    Wie kann ich den Parameter "-f absender@hier-bitte-ihren-domainnamen-einsetzen.de" denn innerhalb von Wordpress an das php_mail() übergeben? Bzw. in welcher Datei muss ich das Skript modifizieren?
     
  4. F.LM

    F.LM Well-Known Member

    Registriert seit:
    24. Juli 2005
    Beiträge:
    192
    Zustimmungen:
    0
    Ich hab die Angabe mittlerweile (in wp-includes/pluggable.php) entdeckt:

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Aber wo übergebe ich jetzt den "-f email@domain.de"-Parameter?

    Am liebsten wäre mir natürlich, dass ich die Mailadresse nicht direkt in die php-Datei schreiben muss, sondern er sie sich aus der Variable, die ich unter Einstellungen>Allgemein angegeben habe, holt.
     
  5. F.LM

    F.LM Well-Known Member

    Registriert seit:
    24. Juli 2005
    Beiträge:
    192
    Zustimmungen:
    0
    Kann mir da niemand helfen?
     
  6. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.823
    Zustimmungen:
    1
    Mal wieder ein Fall für die my-hacks.php :)
    Also im WP-Wurzelverzeichnis eine Datei 'my-hacks.php' anlegen, falls nicht schon vorhanden, und folgendes reinschreiben:
    PHP:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Nun noch unter Einstellungen -> Allgemeines die Option
    [x] Die veraltete my-hacks.php-Datei unterstützen.
    aktivieren und freuen :)

    Gut ich habe das jetzt nicht konkret mit HostEurope getestet, aber die Option "-f absender@example.com" wird nur dann gesetzt, wenn im $phpmailer-Objekt auch der Wert für "Sender" gesetzt ist. Und genau das machen die drei Zeilen Code da oben.

    Und die Admin-Mail-Adresse muß natürlich eine bei HostEurope im entsprechenden Paket vorhandene E-Mail-Adresse sein.

    Gruß
    Ingo
     
  7. F.LM

    F.LM Well-Known Member

    Registriert seit:
    24. Juli 2005
    Beiträge:
    192
    Zustimmungen:
    0
    Danke. Das habe ich mal eingesetzt. Danach ließ sich allerdings der TinyMCE-Editor nicht mehr starten und ich musste die Postings im HTML-Modus eingeben. Außerdem hat der RSS-Feed für die Kommentare nicht mehr funktioniert. Ich hab das daher mal wieder deaktiviert.
     
    #7 F.LM, 19. August 2007
    Zuletzt bearbeitet: 19. August 2007
  8. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.823
    Zustimmungen:
    1
    Das ist allerdings sehr seltsam.
    Steht denn in der my-hacks.php sonst noch was drin, außer meinen paar Zeilen? Wichtig ist auch, das vor dem <?php und nach dem ?> nichts weiter stehen darf, auch keine Leerzeichen oder Leerzeilen.
    Hat das mit den E-Mails denn dann wenigstens funktioniert?

    Gruß
    Ingo
     
  9. F.LM

    F.LM Well-Known Member

    Registriert seit:
    24. Juli 2005
    Beiträge:
    192
    Zustimmungen:
    0
    Nein, ich habe die Datei erst angelegt und somit stand nur der Code von dir drin.

    Soweit, zu testen, ob der Mail-Versand funktioniert, bin ich nicht gekommen: Es handelt sich beim Mail-Versand nämlich um einen Newsletter, der nach dem Erscheinen neuer Beiträge verschickt wird. Neue Beiträge ließen sich aber - wie oben beschrieben - nicht verfassen, während die my-hacks.php aktiviert war.

    Gibt es denn keine Möglichkeit, die Parameter-Übergabe direkt irgendwo im Code der WP-Installation einzuhacken?
     
  10. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.823
    Zustimmungen:
    1
    Sicher gibt es die auch, nur sollte man zunächst versuchen, einen "legalen" Weg zu gehen. Man kann das ganze aus der my-hacks.php auch in ein Plugin verpacken, dann würde es so aussehen:
    PHP:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Hier als Download: plw123_mailsnd.zip

    Gruß
    Ingo
     
    #10 Putzlowitsch, 22. August 2007
    Zuletzt bearbeitet: 6. Februar 2008
  11. F.LM

    F.LM Well-Known Member

    Registriert seit:
    24. Juli 2005
    Beiträge:
    192
    Zustimmungen:
    0
    Danke. Das probiere ich mal aus.
     
  12. JayZee

    JayZee Member

    Registriert seit:
    6. August 2007
    Beiträge:
    14
    Zustimmungen:
    0
    Ich habe das gleiche Problem mit HostEurope (denke ich jedenfalls), wenn sich jemand auf meiner Site registriert bekommt er kein Passwort zugeschickt. Standardmailadresse ist gesetzt.
    Ich hab das getestet mit verschiedenen funktionierenden Mailadressen von mir, womit ausgeschlossen ist, dass der Host wegen fehlerhafter Adresse kein Passwort verschickt.
    Ich habe nun das Putzlowitsch-Plugin importiert und aktiviert, dadurch ändert sich aber leider nichts.
    Gibt es noch eine Idee, Möglichkeit?

    Gruß
    Jay
     
    #12 JayZee, 22. Dezember 2007
    Zuletzt bearbeitet: 22. Dezember 2007
  13. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.823
    Zustimmungen:
    1
    Bekommst Du denn E-Mails bei neuen Kommentaren? Falls ja, liegt das Problem woanders, falls nicht aber auch :)
    Denn entweder es funkioniert mit der Standard-E-Mail-Adresse oder meinem Plugin. Hab es grad nochmal probiert (WP 2.3.1).

    Gruß
    Ingo
     
  14. JayZee

    JayZee Member

    Registriert seit:
    6. August 2007
    Beiträge:
    14
    Zustimmungen:
    0
    Hallo Ingo,

    nein, ich bekommen auch keine Mail bei Kommentaren.

    Gruß
    Jay
     
  15. JochenH

    JochenH New Member

    Registriert seit:
    25. März 2008
    Beiträge:
    3
    Zustimmungen:
    0
    Ich hatte auch die Probleme mit den Mails und Host Europe.
    Ich schicke jetzt meine Mails per SMTP mit diesem Plugin:

    WordPress › WP Mail SMTP « WordPress Plugins

    Funktioniert super :D

    Ich hoffe ich konnte weiterhelfen.

    Viele Grüße
     
  16. aldi2006

    aldi2006 Member

    Registriert seit:
    8. Januar 2008
    Beiträge:
    24
    Zustimmungen:
    0
    Hallo Ingo,

    ich habe von Host-Europe folgende Antwort zu dem Problem bekommen:

    Frage: die Geschichte mit dem "-f" - muss das nicht auch noch in Dein Plugin? Oder ist das dann überflüssig?

    Gruß, jens
     
  17. Putzlowitsch

    Putzlowitsch Well-Known Member

    Registriert seit:
    21. Oktober 2006
    Beiträge:
    5.823
    Zustimmungen:
    1
    Nein, das -f wird automatisch vom PHP-Mail hinzugefügt, wenn ein Wert für "Sender" gesetzt ist. Genau das macht das Plugin, es sind keine weiteren Änderungen erforderlich.
    Bedingung ist allerdings, daß die bei den Blog-Optionen angegebene E-Mail-Adresse tatsächlich im WebPack existiert.

    Gruß
    Ingo
     
  18. leevey

    leevey New Member

    Registriert seit:
    16. Juli 2010
    Beiträge:
    3
    Zustimmungen:
    0
    Hi,

    und vielen Dank für das kleine Plugin. Verwende es auf einem Host Europe
    Web Pack L 2.0, Wordpress 3.0 und Contact Form 7.2.3.

    Vorher kam immer folgende Fehlermeldung beim Versuch eine Mail zu senden.

    Nun funktioniert alles einwandfrei - Daumen hoch!
     
  19. KenOne

    KenOne Active Member

    Registriert seit:
    22. August 2008
    Beiträge:
    37
    Zustimmungen:
    0
    Bei mir funktionieren die Kontaktformulare nicht. Hat schon jemand eine Lösung gefunden?
     
  20. Hille

    Hille Well-Known Member

    Registriert seit:
    22. Januar 2012
    Beiträge:
    7.965
    Zustimmungen:
    8
    Schön das du einen 4 Jahre alten Thread raus gesucht hast.
    Google hätte dir sofort geholfen.

    faq.hosteurope.de/index.php?cpid=11073
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden