1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Problem mit Permalink Structure

Dieses Thema im Forum "Konfiguration" wurde erstellt von drscheme, 18. Januar 2005.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Goodspeed

    Goodspeed Well-Known Member

    Registriert seit:
    9. Januar 2005
    Beiträge:
    168
    Zustimmungen:
    0
    Hallo suedkind,

    so jetzt klappt es. Danke.
     
  2. DogMan

    DogMan Well-Known Member

    Registriert seit:
    3. September 2004
    Beiträge:
    931
    Zustimmungen:
    0
    Vorschlag:

    Bei den Optionen/Permalinks schreibst Du in die obere der beiden Eingabefelder folgendes:
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Und in die untere Zeile:
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!

    Du mußt übrigens nicht zwangsläufig Slashes zum trennen der Variablen benutzen. Ich habe bei mir die Variablen teilweise sogar mit Bindestrich verbunden.

    Aus einem:
    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    wird beispielsweise folgender link:

    http://www.example.com/2005-01/wordpress-ist-ganz-toll

    Wie Du siehst, taucht der Ausdruck /archiv bisher nirgends auf. Den brauchst Du nämlich erst in der Zeile in der auch "abgelegt unter:" steht. Er führt zu den einzelnen Kategorien. Darum habe habe ich ihn bei mir auch nicht weiter /archiv genannt, sondern /kategorie.

    Also summa sumarum sollte der Text in Deiner .htaccess so aussehen:

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Gruß
    DogMan
     
  3. DogMan

    DogMan Well-Known Member

    Registriert seit:
    3. September 2004
    Beiträge:
    931
    Zustimmungen:
    0
    Hmpff - ist doch immer wieder das gleiche: Ich brauche zu lange, weil ich das erst einmal bei mir probieren will... und dann bin ich zu spät ... hmpff
     
  4. imixed

    imixed Active Member

    Registriert seit:
    15. Januar 2005
    Beiträge:
    28
    Zustimmungen:
    0
    Auch ich verzweifel gerade ...

    Hallo,

    habe heute meine Webseite http://www.imixed.net von dem Open Source CMS Mambo auf WordPress umgestellt.

    Lt. info.php ist rewrite_mod geladen.

    Die .htaccess ist auch vorhanden und wird generell auch modifiziert, wenn ich die Permalink-Einstellungen im Admin-Interface ändere. Abgelegt ist die .htaccess im Root-Verzeichnis meines Webserver, dort wo auch WordPress installiert ist (samt index.php).

    Beim Zugriff auf ein Archiv, eine Kategorie oder einen Blog laufe ich jedoch immer auf eine "Objekt nicht gefunden - Error 404" Meldung.

    Inhalt der .htaccess:

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Falls es wichtig sein sollte: Ich nutze die 1.5er Beta vom 25. Jan '05.
     
  5. suedkind

    suedkind Well-Known Member

    Registriert seit:
    5. Oktober 2004
    Beiträge:
    1.665
    Zustimmungen:
    0
  6. imixed

    imixed Active Member

    Registriert seit:
    15. Januar 2005
    Beiträge:
    28
    Zustimmungen:
    0
    Danke Dir erst mal, Suedkind. Hat jemand anders vielleicht noch eine Idee?
     
  7. Olaf

    Olaf WPDE-Team
    Mitarbeiter

    Registriert seit:
    3. September 2004
    Beiträge:
    2.739
    Zustimmungen:
    30
    Also da hast du irgendwo was durcheinandergebracht. Was steht denn bei dir im Adminbereich unter

    Optionen > Permalinks > Struktur

    Da müsste bei dir ungefähr das stehen:

    index.php/%year%-%monthnum%-%day%/%postname%

    entferne die "index.php" aus der Strukur, dann generiert dir WP den Inhalt der .htacces, kopiere den Inhalt in dein root-Verzeichnis. Wenn du dann ohne ende 404er anfezeigt bekommst, unterstützt dein Server den mod_rewrite nicht.
     
  8. imixed

    imixed Active Member

    Registriert seit:
    15. Januar 2005
    Beiträge:
    28
    Zustimmungen:
    0
    Hallo Olaf,

    ich abe heute Morgen noch den Eintrag index.php vorangestellt, damit es überhaupt funktioniert. Wenn ich den Eintrag lösche, erhalte ich das gestern beschriebene Problem! Aber so (mit index.php) sieht es halt echt doof aus. :(

    Im Output von info.php wird klar dargestellt, dass der rewrite_mod geladen ist. Und wenn es das nicht wäre, würde es ja auch jetzt nicht funktionieren?!?! Denn egal, ob ich nun ein index.php in den Eintrag unter Admin-Options-Permalinks einbaue oder nicht ... es sind virtuelle URLs, oder?

    Für alle Fälle hier mal ein Blick auf info.php bei mir: http://www.imixed.net/info.php

    Ich habe vorher mit Mambo ja auch den rewrite_mod genutzt und hatte dort keine Probleme.

    So ein Mist ...
     
  9. DogMan

    DogMan Well-Known Member

    Registriert seit:
    3. September 2004
    Beiträge:
    931
    Zustimmungen:
    0
    Ich hörte mal, dass sich WordPress 1.2 und PHP 5 nicht so recht vertragen sollen. Inwieweit Dein Problem davon betroffen ist, kann ich aber leider nicht beurteilen...

    Hast Du die Möglichkeit, das ganze mit einer 4rer Version auszuprobieren?


    Gruß
    DogMan
     
  10. imixed

    imixed Active Member

    Registriert seit:
    15. Januar 2005
    Beiträge:
    28
    Zustimmungen:
    0
    Ich habe ja gar kein WP 1.2, sondern 1.5 ...
    PHP Version kann ich nicht ändern.

    Ich höre aber auch gerade in einem anderen Forum von Anwendern, die Probleme bit htaccess bei dem Webpack haben, dass ich auch nutze ... muss das erst mal klären; könnte doch am Provider liegen.
     
  11. DogMan

    DogMan Well-Known Member

    Registriert seit:
    3. September 2004
    Beiträge:
    931
    Zustimmungen:
    0
    Merkwürdig: Wenn ich auf die Seite

    http://www.stanley-goodspeed.com/
    gehe und in den Quelltext schaue, steht da in der sechsten Zeile:

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Lass mich raten: Ihr redet mittlerweile von einer anderen Seite, gelle? 8)

    DogMan
     
  12. imixed

    imixed Active Member

    Registriert seit:
    15. Januar 2005
    Beiträge:
    28
    Zustimmungen:
    0
  13. Goodspeed

    Goodspeed Well-Known Member

    Registriert seit:
    9. Januar 2005
    Beiträge:
    168
    Zustimmungen:
    0
  14. imixed

    imixed Active Member

    Registriert seit:
    15. Januar 2005
    Beiträge:
    28
    Zustimmungen:
    0
  15. imixed

    imixed Active Member

    Registriert seit:
    15. Januar 2005
    Beiträge:
    28
    Zustimmungen:
    0
    Seit Samstag ist es definitiv: Es liegt am Web-Provider. Zwar wird das Modul mod_rewrite generell geladen aber in dem von mir gewähltem WebPack nicht unterstützt. Suuuuper :x Das war vorab mit der Dame vom Vertrieb von Hosteurope anders besprochen. Jetzt schaumer mal, wie ich am unkompliziertesten wechseln kann. Denn ich will wieder - so wie früher - .htaccess Zugriff haben. Ich will, ich will, ich will.
     
  16. DogMan

    DogMan Well-Known Member

    Registriert seit:
    3. September 2004
    Beiträge:
    931
    Zustimmungen:
    0
    Ich weiß ja nicht, ob der Vergleich arg hinkt, aber es fühlt sich für mich so an, als hättest Du ein neues Auto, dürftest aber die Gangschaltung nicht benutzen.

    Sieh zu, dass Du diesen ungastlichen Ort alsbald verlässt...

    Gruß
    DogMan
     
  17. suedkind

    suedkind Well-Known Member

    Registriert seit:
    5. Oktober 2004
    Beiträge:
    1.665
    Zustimmungen:
    0
    welchen grund kann es eigentlich dafür geben, dass mod_rewrite in einem paket nicht freizuschalten?

    was ist daran ein kostenfaktor?
     
  18. imixed

    imixed Active Member

    Registriert seit:
    15. Januar 2005
    Beiträge:
    28
    Zustimmungen:
    0
    Das dürfte dann wohl reine Politik sein und der Wunsch mehr Geld zu verdienen. Einen wirklichen Grund gibt es nicht.

    Ich für meinen Teil zahle nun also monatlich zwei Euro mehr und habe dafür seit 4 Stunden auch endlich meine Permalinks.

    Es lebe die Marktwirtschaft. Hurra. :evil:
     
  19. suedkind

    suedkind Well-Known Member

    Registriert seit:
    5. Oktober 2004
    Beiträge:
    1.665
    Zustimmungen:
    0
    na ich hoffe der provider ist ansonsten akzeptabel ...
     
  20. imixed

    imixed Active Member

    Registriert seit:
    15. Januar 2005
    Beiträge:
    28
    Zustimmungen:
    0
    Bin bei Hosteurope und habe eigentlich in über zwei Jahren noch nie irgendwelche Probleme gehabt. Keine mir bekannten Ausfälle, nur sehr wenig Wartungsarbeiten (immer angekündigt), immer korrekte Rechnungen, vernünftiger Online-Zugriff auf alle Einstellungen und eMails. Kann mich - von diesem Mal abgesehen - nicht beklagen.
     
Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden