1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Probleme bei der Konfiguration der Permalinks

Dieses Thema im Forum "Konfiguration" wurde erstellt von Hosss, 4. November 2007.

  1. Hosss

    Hosss Member

    Registriert seit:
    4. November 2007
    Beiträge:
    16
    Zustimmungen:
    0
    Tach zusammen!
    Auf die Gefahr hin, die werten Diskutanten mit meinem Anliegen zu langweilen, möchte ich trotzdem einfach mal in die Runde fragen: Wie bekomme ich die Permalinks gescheit konfiguriert? Momentan sieht die Linkstruktur folgendermaßen aus:

    /index.php/%year%/%monthnum%/%day%/%postname%/

    Das ist soweit auch in Ordnung. Allerdings soll 'index.php' weg und dafür ein 'item' oder 'archiv' hin oder so. mod_rewrite ist vonseiten meines Hosters verfügbar. eine htaccess existiert momentan noch nicht. Wenn ich richtig informiert bin, muss eben diese Datei erstellt werden, um die Permalinkstruktur entsprechend meiner Vorstellungen anzupassen. Nur: Was zum Teufel schreibe ich da rein? Oder brauche ich einfach nur im Menüpunkt 'Permalink-Struktur anpassen' im WP-admin-Bereich rumzuwurschteln?

    Hoss
     
  2. jottlieb

    jottlieb Well-Known Member
    Ehrenmitglied

    Registriert seit:
    20. August 2005
    Beiträge:
    17.381
    Zustimmungen:
    0
    Wenn WP die .htaccess nicht erstellen/beschreiben kann, dann erscheint just auf der Seite in der du die Permalinks einstellst ganz unten in einem Kästchen was du in die .htaccess eintragen sollst.
     
  3. Hosss

    Hosss Member

    Registriert seit:
    4. November 2007
    Beiträge:
    16
    Zustimmungen:
    0
    Danke für die schnelle Antwort!
    Also ich habe bei 'Permalink-Struktur anpassen' unter 'Benutzerdefinierte Struktur' folgendes eingetragen, um einfach nur das 'index.php' zu entfernen:

    /%year%/%monthnum%/%day%/%postname%/

    WP meldete 'Permalink-Struktur aktualisiert.' Es wurde keine htaccess automatisch angelegt. Ein Kästchen mit einem Code für die htaccess habe ich jedoch auch nicht entdecken können. Klicke ich auf einen Eintrag im Blog kommt nur 'Not Found The requested URL /2007/11/02/hallo-welt/ was not found on this server.' :(
     
  4. marX

    marX Well-Known Member
    Ehrenmitglied

    Registriert seit:
    5. Oktober 2006
    Beiträge:
    12.943
    Zustimmungen:
    0
    Leg dir eine leere .htaccess im WP-Rootverzeichnis an (da wo die wp-config.php liegt). Dieser gibst du z.B. mit deinem FTP-Programm die Zugriffsrechte 666 (chmod). Dann sollte WP die Datei beschreiben können.
     
  5. Hosss

    Hosss Member

    Registriert seit:
    4. November 2007
    Beiträge:
    16
    Zustimmungen:
    0
    Habe die leere '.htaccess' im Rootverzeichnis angelegt und auch die Zugriffsrechte angepasst. Trotzdem bekomme ich nur den 404-not found-Fehler angezeigt wenn ich auf einen Beitrag klicke. Das einzigste was stimmt, ist die URL die angezeigt wird (http://www.domain.org/2007/11/02/hallo-welt/)
    Was mach ich da falsch? Gibts noch einen anderen Weg?
     
  6. marX

    marX Well-Known Member
    Ehrenmitglied

    Registriert seit:
    5. Oktober 2006
    Beiträge:
    12.943
    Zustimmungen:
    0
    Wird die .htaccess beschrieben? Theoretisch sollte da sowas drin stehen:

    Code:
    Entschuldige, aber du musst dich registrieren oder anmelden um den Inhalt sehen zu können!
    Eventuell müssen RewriteBase und RewriteRule noch angepasst werden, falls dein Blog in einem Unterverzeichnis liegt.
     
  7. Hosss

    Hosss Member

    Registriert seit:
    4. November 2007
    Beiträge:
    16
    Zustimmungen:
    0
    Ah, okay, dann nehme ich an, dass da der Fehler liegt. WP ist in einem Unterverzeichnis installiert. Ich habe das allerdings so gedeichselt, dass das Blog nicht übers Unterverzeichnis, sondern nur über die Domain erreichbar ist... Andererseits sollte doch die .htaccess automatisch beschrieben werden??

    Die .htaccess ist jedenfalls nicht beschrieben worden. Ich habe die (leere) Datei ins Unterverzeichnis, also zu WP kopiert, was nicht funktioniert hat (d. h. die .htaccess wurde nicht beschrieben und die Permalinks funktionierten nicht), und dann auch nochmal ins Hauptverzeichnis, aber auch das funzte nicht.

    Nun gut, soll ich die .htaccess nun manuell anlegen? Und wie passe ich denn RewriteBase und RewriteRule an?
     
  8. SW-1965

    SW-1965 Active Member

    Registriert seit:
    20. April 2007
    Beiträge:
    42
    Zustimmungen:
    0
    Hallo,

    habe das gleiche Problem wenn ich bei mir die Permalinks umstellle auf logische Verzeichnisse anstatt der Standard Einstellung.

    Die Kategorien werden gefunden, aber die Seiten/Pages selbst führen zu einem Error 404. WP liegt bei mir auch im Unterverzeichnis die index.php ist umkopiert ins Hauptverzeichnis.

    Was muss ich an der .htaccesss denn ändern, hab da keine Ahnung von

    Gruß
    Silvia
     
  9. SW-1965

    SW-1965 Active Member

    Registriert seit:
    20. April 2007
    Beiträge:
    42
    Zustimmungen:
    0
    Hallo,

    mir fällt hier gerade beim nochmaligen lesen etwas auf.

    Ich hatte ja auch versucht die Permalinks zu ändern, mit dem Ergebinis das manche Seiten in einem Error 404 endeten.
    Mein Wordpress liegt in einem Unterverzeichnis, habe es aber so konfiguriert das die index.php im Hauptverzeichnis liegt.

    marX schreibt:
    Die wp-config liegt ja weiterhin im Unterverzeichnis beim Umstellen der Permalinks hat Wordpress die .htaccess Datei aber dort erzeugt wo die index.php liegt, also im Hauptverzeichnis.
    Könnte das der Knackpunkt sein ? Muss ich mal austesten.

    Doch dazu noch ne Frage:
    Wie genau pass ich die denn an ? Ich kann sieja nach erzeugen vom Hauptverzeichnis in den Ordner Wordpress kopieren dort wor die wp_config liegt, nur was trag ich ein??

    Viele Grüße
    Silvi
     
  10. SW-1965

    SW-1965 Active Member

    Registriert seit:
    20. April 2007
    Beiträge:
    42
    Zustimmungen:
    0
    Phuuuuu.... ich glaube ich hab es geschafft. Es funktioniert Juuhuuuuuu :)

    Vielleicht interessiert es Euch ja was bei mir das Problem war.

    (Nutze zur Zeit wegen einiger Plugins noch Wordpress 2.2, weiss nicht ob es in der 2.3 anders ist???)

    Ich habe mein Wordpress in einem Unterverzeichnis laufen, habe es aber so eingestellt das die index.php im Hauptordner der Domain liegt. Kann man in Wordpress ja umstellen.

    Nun habe ich die Permalinks umgestellt von Standard auf Benutzerdefiniert (/%postname%/). Die .htaccess Datei wird von Wordpress im Hauptordner erstellt. Und das scheint wohl das Problem zu sein, denn die noch bestehenden von Hand gesetzen Links auf die Standardverlinkung führen zu einem Error 404. Ich habe dann die .htaccess zusätzlich ins Unterverzeichnis kopiert wo auch Wordpress installiert ist. Und siehe da erstes Problem gelöst. Auch die noch existierenden Standard Verlinkungen (Von Hand gesetzte) führen zur richtigen Datei :)

    Jetzt frage ich mich nur warum muss ich die .htaccess zusätzlich ins Unterverzeichnis kopieren ?
    Hat jemand eine Idee dazu ? Ich dachte die Einstellung trifft auch auf alle Unterverzeichnisse zu ?

    Aber dann bestand ja auch noch das Problem mit ein paar Pages.
    Komischerweise half da die .htaccess nicht, manche funktionierten andere nicht, wieder Error 404. Obwohl die das gleiche Template usw. nutzen.

    Ich habe dann in den nicht funktionierenden Pages mal die Titelform geändert von z.b.: impressum auf: zum-impressum
    Und das hat funktioniert. Bei allen nicht funktionierenden Pages also die Titelform für den Link geändert Error 404 ist weg.

    Vielleicht hilft das ja ein paar von Euch weiter.

    Viele Grüße
    Silvi
     
  11. thomas57

    thomas57 Well-Known Member

    Registriert seit:
    6. Oktober 2007
    Beiträge:
    69
    Zustimmungen:
    0
    Permalink-struktur

    Vielen Dank, hier mal was gelesen, getestet und es funktioniert.
    :D
     
  12. MotMann

    MotMann Member

    Registriert seit:
    25. November 2007
    Beiträge:
    21
    Zustimmungen:
    0
    Ich verstehe das nicht. Ich kann nur den Standard nutzen.
    Sofern, wie bei den anderen auch, etwas verändert wird, erscheint 500 :(
     
  13. marX

    marX Well-Known Member
    Ehrenmitglied

    Registriert seit:
    5. Oktober 2006
    Beiträge:
    12.943
    Zustimmungen:
    0
    Manche Hoster erlauben den Einsatzvon Mod-Rewrite nicht. Forensuche benutzen! (Bist du bei Strato?)
     
  14. redcat63

    redcat63 Well-Known Member

    Registriert seit:
    31. März 2006
    Beiträge:
    1.036
    Zustimmungen:
    0
    Hallo MotMann,

    MarX hat Recht. Trotzdem kannst Du "Permalinks" verwenden. Auch bei Strato. Du musst nur bei "benutzerdefiniert" folgendes eintragen:
    Bspl:
    /index.php/%year%/%monthnum%/%day%/%postname%/

    Wichtig ist dabei, dass das /index.php vorhanden ist.Das darfst Du nicht löschen.

    VG Elke
     
  15. marX

    marX Well-Known Member
    Ehrenmitglied

    Registriert seit:
    5. Oktober 2006
    Beiträge:
    12.943
    Zustimmungen:
    0
  16. MotMann

    MotMann Member

    Registriert seit:
    25. November 2007
    Beiträge:
    21
    Zustimmungen:
    0
    Ich habe einfach eine htaccess von einer anderen Seite von mir genommen, die klappt.
    Da ist nur die erste Zeile folgend:

    RewriteEngine On

    Options +FollowSymLinks

    #RewriteBase /

    Der Part wird auch von WP nicht umgeschrieben. Dann klappt das auch... :)
     
  17. SW-1965

    SW-1965 Active Member

    Registriert seit:
    20. April 2007
    Beiträge:
    42
    Zustimmungen:
    0
    Also ich habs mittlerweilen aufgegeben, ich hätte besser die Finger von diesen Permalinks gelassen, hier landet jeder zweite Aufruf in nem Error. Never touch a running System :evil:

    Und durch diese blöde Umstellerei wird auch die Seite mittlerweilen nicht mehr gut in Google gefunden, ich kann nur jedem abraten die Permalink Struktur umzustellen. Meine "sprechenden URLs" mag Google nämlich nicht und die anderen landen im Error :confused:
     
  18. Holger L.

    Holger L. New Member

    Registriert seit:
    11. Januar 2008
    Beiträge:
    1
    Zustimmungen:
    0
    Gar so schrecklich ist es auch nicht

    Also wenn man es richtig angeht, ist es eigentlich ganz leicht. Man muss bloß eine vernünftige Anleitung bekommen.
    Ich weiß, wovon ich rede, denn ich habe gerade als absoluter Neuling in Sachen WordPress und Apache zwei Tage damit zugebracht, mir "Schöne Permalinks" zuzulegen.

    Ich arbeite mit WP 2.3.2 DE unter XAMPP für Windows 1.6.5. So 'ne lokale Installation ist herrlich fürs Kennenlernen und ausprobieren!

    Letztlich hat sich bei mir WP um alles gekümmert und meinen Wunsch nach sprechenden Permalinks ohne index.php problemlos umgesetzt. Ich musste nur die entsprechenden Voraussetzungen schaffen und die bestehen eigentlich nur darin mod_rewrite zu aktivieren.
    Wenn - und auch nur dann! - das Rewrite-Modul aktiviert ist, schlägt WP in Einstellungen -> Permalinks alternative Permalinks ohne index.php vor. Wählt man einen Vorschlag oder gibt eine eigene Struktur vor, schreibt WP einen entsprechenden Rewrite-Code in .htaccess bzw. erstellt diese Datei. (Dafür hat bei mir sogar chmod 644 ausgereicht)
    Ich habe vorher alles möglich an manueller Konfiguration ausprobiert, bis ich merkte, dass mod_rewrite gar nicht aktiviert war. Als ich das Modul aktivierte, hat WP den Rest automatisch gemacht.

    Jedem, der mit der Konfiguration seiner Permalinks nicht weiterkommt, empfehle ich den Plugin AskApache RewriteRules Viewer. Oben rechts wird der Ist-Zustand des Systems angezeigt einschließlich eines Hinweise auf die Verfügbarkeit von mod_rewrite. Oben links gibt es ein Fenster mit dem nötigen Rewrite-Code für Permalinks ohne index.php.
     
  19. SW-1965

    SW-1965 Active Member

    Registriert seit:
    20. April 2007
    Beiträge:
    42
    Zustimmungen:
    0
    Hi Holger,

    das Plugin werde ich mir mal ansehen danke für den Tipp.
    Trotzdem bleibe ich dabei, in meinem Falle war das Umstellen auf Permalinks eher von Nachteil, meine Seite war sehr gut indiziert mit den normalen Links in Google. Aber man liesst ja dann doch immer die "sprechenden URLs" wären für Google besser. Dies mag ja der Fall sein bei neuen Webseiten, aber wer schon gut plaziert ist mit der alten Struktur sollte es besser lassen.
    Den Error 404 Fehler bekomme ich seit dem nicht mehr weg, die Seite ist in der Positionierung total abgefallen, mit manchen Suchwörtern wird meine Seite gar nicht mehr gefunden.
    Alles in alles mehr als Schrott !

    Gruß
    Silvi
     
  20. onE

    onE Well-Known Member

    Registriert seit:
    9. April 2008
    Beiträge:
    65
    Zustimmungen:
    0
    ich habe da auch ein komisches problem,
    und zwar gehen bei mir alle seiten und artikel usw. nur die tags funktionieren nich?

    folgende strucktur habe ich eingestellt:
    /index.php/%category%/%postname%

    kennt jemand das problem?
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden