1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Probleme mit der DB Connection ab php >5.4

Dieses Thema im Forum "Konfiguration" wurde erstellt von siggler, 29. Januar 2021.

  1. siggler

    siggler New Member

    Registriert seit:
    29. Januar 2021
    Beiträge:
    3
    Zustimmungen:
    0
    Hallo,

    ich nutze aktuell folgende Konfiguration meiner Wordpress Site:
    WP: 5.1.8
    PHP: 5.4.45
    MySQL: Server Version: 10.1.47-MariaDB-0+deb9u1 mit utf8

    Da die Versionen ja mittlerweile doch sehr angestaubt sind, und ich aktuell wegen der php-Version keine weiteren WP Update installieren kann, wollte ich auf php7.3 wechseln ABER: Egal welche Version >5.4 ich auch bei meinem Server auswähle, WP kann danach keine DB Connection mehr herstellen - auch wenn das PW nochmals neu gesetzt wird.

    Hat hier jemand eine Idee? Muss am MySQL Server was angepasst werden? Stimmt was mit der Codierung utf8 nicht?

    Ich bedanke mich im Vorraus,

    Viele Grüße
    Siggler
     
  2. r23

    r23 Well-Known Member

    Registriert seit:
    9. Dezember 2006
    Beiträge:
    5.434
    Zustimmungen:
    193
    eine WP 5.x Version funktioniert mir PHP 5.4? kann man sich eigentlich gar nicht vorstellen.

    und eine PHP 5.4.45 kommt mit MariaDB 10.1 klar ... cool.. wenn man bedenkt,

    Die Weiterentwicklung von PHP 5.4 wurde im Herbst 2015 eingestellt. Auch Sicherheitsupdates werden seit der Veröffentlichung von PHP 5.4.45 am 3. September 2015 nicht mehr zur Verfügung gestellt.

    Und so eine Version ist bei einem Provider Online? Ungestraft?

    cool... also in deiner Vorstellung läuft Wp 5.1.8 ohne eine Änderung mit PHP 7.3.? wunderbar.

    Wie kommt man darauf?


    Was ist wohl mit "PW nochmals neu gesetzt wird." gemeint?

    An MySQL Server muss in der Regel nichts geändert werden auch an der utf-8 Kodierung nicht. Wo bei PHP erst mit 5.6.

    Hier im Job Forum kannst du dir ja einen Suchen der dir eine Migration auf 7.3. erstellt. Mit nur rumklicken im Adminbereich geht dies meiner Meinung nach leider nicht mehr.
     
  3. siggler

    siggler New Member

    Registriert seit:
    29. Januar 2021
    Beiträge:
    3
    Zustimmungen:
    0
    Oh, weh ich merk schon ich bin im falschen Forum.

    ja, tatsächlich läuft die Seite mit den Versionen.
    ja, mir ist klar dass keine Updates mehr für 5.4...
    ja, dass dies mit geklickse im AdminBereich nicht geht...

    schade, dass nichts konstruktives kommt. Ich les mich ein.

    Danke.
     
  4. SEpp55

    SEpp55 Well-Known Member

    Registriert seit:
    3. Februar 2016
    Beiträge:
    2.686
    Zustimmungen:
    436
    Ob du dich im falschen Forum fühlst, mußt du beurteilen.
    Wenn du dich aber seit Jahren nicht um irgend etwas gekümmert hast bei deinem Internetauftritt, kannst du auch keine Wunder erwarten, wenns vielleicht scharf pointiert geschrieben wurde .......
    Wenn die Reanimation eines Dinosauriers dein Können übersteigt, gibt es die Jobbörse wie oben erwähnt. Dort kannst du dir jemanden aussuchen, den du vertraust und wer versuchen darf, die richtigen Maßnahmen in richtiger Reihenfolge zu setzen.
    Ich bin da nicht dabei - also schreibe ich nicht im Eigeninteresse!!!
     
  5. JABA-Hosting

    JABA-Hosting Well-Known Member

    Registriert seit:
    29. März 2016
    Beiträge:
    2.675
    Zustimmungen:
    124
    Kannst du in den error-logs etwas sehen? Wie lautet die Webseite?
     
  6. siggler

    siggler New Member

    Registriert seit:
    29. Januar 2021
    Beiträge:
    3
    Zustimmungen:
    0
    Hallo,

    danke @SEpp55 für deine Antwort!

    @JABA-Hosting: Ja wenn ich php umbaue auf 7.x, dann erhalte ich folgende Meldung:

    Warning: mysqli_real_connect(): (HY000/2000): mysqlnd cannot connect to MySQL 4.1+ using the old insecure authentication. Please use an administration tool to reset your password with the command SET PASSWORD = PASSWORD('your_existing_password'). This will store a new, and more secure, hash value in mysql.user. If this user is used in other scripts executed by PHP 5.2 or earlier you might need to remove the old-passwords flag from your my.cnf file in /home/www/web1851/html/Wordpress/wp-includes/wp-db.php on line 1612



    mysqlnd cannot connect to MySQL 4.1+ using the old insecure authentication. Please use an administration tool to reset your password with the command SET PASSWORD = PASSWORD('your_existing_password'). This will store a new, and more secure, hash value in mysql.user. If this user is used in other scripts executed by PHP 5.2 or earlier you might need to remove the old-passwords flag from your my.cnf file

    Habe nun das Password wie folgt nochmals gesetzt.
    SET PASSWORD FOR user@localhost = PASSWORD('new_password');

    Leider aber noch ohne Erfolg. Muss mir das morgen mal genauer anschauen.

    Viele Grüße
     
  7. arnego2

    arnego2 Well-Known Member

    Registriert seit:
    10. Januar 2021
    Beiträge:
    248
    Zustimmungen:
    23
    von PHP 5 auf 7.3 haben sich eine Menge Dinge geändert. Von 7.3 auf 7.4 haben weitere Änderungen für Wirbel gesorgt.
    https://wordpress.org/support/topic/php-migration-problem-5-3-to-7-3/

    Auf 7.3 upzudaten wird dir neue Probleme geben.
    Nutze die Chance und mach die Seite neu.
     
  8. Michi91

    Michi91 Well-Known Member

    Registriert seit:
    8. November 2008
    Beiträge:
    1.808
    Zustimmungen:
    8
    hast du den Befehl genau so abgesetzt? Der Befehl muss angepasst und möglicherweise in unterschiedlichen Varianten mehrfach ausgeführt werden.

    Am MySQL Server kannst du als Hostingkunde ja vermutlich nicht viel ändern?
     
  9. JABA-Hosting

    JABA-Hosting Well-Known Member

    Registriert seit:
    29. März 2016
    Beiträge:
    2.675
    Zustimmungen:
    124
    Bei welchem Hoster bist du eigentlich?

    Vielleicht kannst du versuchen in die User Tabelle von WordPress via phpmyadmin einfach ein neues Passwort gehasht rein zu setzen.

    Gibt ja jede Menge Online Tools, die Dir ein Hash zaubern, ob die funktionieren keine Ahnung.
    Vielleicht eine zweite Instanz von WordPress installieren, dort den Passwort Hash kopieren und in deine alte Wordpress Datenbank kopieren.
     
  10. b3317133

    b3317133 Well-Known Member

    Registriert seit:
    21. November 2014
    Beiträge:
    8.762
    Zustimmungen:
    1.006
    Um für einen WordPress Benutzer via phpMyAdmin ein neues Passwort in die Usertabelle zu schreiben, setzt man einfach den MD5 Hash des Passworts in die Spalte user_pass, ein entspr. Fallback dafür ist in der Passwortprüfung von WordPress vorhanden, aber darum geht es bei dieser Frage von @siggler gar nicht.

    Das Passwort für die Datenbank - darum geht es hier - ändert man normalerweise über das Backend im Hosting im Bereich Datenbanken und trägt das neue Passwort dann auch in die Datei wp-config.php ein, bzw. man wendet sich an den Hostinganbieter falls es dort im Backend keine solche Möglichkeit gibt oder die Fehlermeldung auch nach Änderung gleich bleibt.
     
  11. JABA-Hosting

    JABA-Hosting Well-Known Member

    Registriert seit:
    29. März 2016
    Beiträge:
    2.675
    Zustimmungen:
    124
    Oh, da habe ich ja dummes Zeug erzählt. So tief deckt man gar nicht, da man ausgehen kann das die Serverdienste eigentlich richtig konfiguriert sind.
    Da wird dein Hoster „vermutlich“ neben der PHP Version auch den Datenbankserver aktualisiert haben, ohne die Datenbanken zu migrieren.
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden