1. Herzlich willkommen bei WPDE.org, dem grössten und ältesten deutschsprachigen Community-Forum rund um das Thema WordPress. Du musst angemeldet oder registriert sein, um Beiträge verfassen zu können.
    Information ausblenden

Probleme mit Formularen

Dieses Thema im Forum "Plugins und Widgets" wurde erstellt von wirt, 7. Januar 2012.

  1. wirt

    wirt Well-Known Member

    Registriert seit:
    10. Oktober 2010
    Beiträge:
    63
    Zustimmungen:
    0
    Genau, das trifft zu.

    Aber wenn es am Hoster liegt, hätte es ja beim anderen Blog auch nicht funktionieren dürfen, oder?
     
  2. wirt

    wirt Well-Known Member

    Registriert seit:
    10. Oktober 2010
    Beiträge:
    63
    Zustimmungen:
    0
    Hab's gerade noch mal getestet. Bei meiner anderen Seite kommen die E-Mails problemlos an.
     
  3. infected

    infected Well-Known Member

    Registriert seit:
    9. Juli 2006
    Beiträge:
    9.816
    Zustimmungen:
    1
    Und die Seiten liegen auf dem gleichen Server? Dann wird´s vermutlich an den Plugineinstellungen oder an einem Konflikt mit einem anderen Plugin liegen.
     
  4. wirt

    wirt Well-Known Member

    Registriert seit:
    10. Oktober 2010
    Beiträge:
    63
    Zustimmungen:
    0
    Ja, beide Seiten liegen auf demselben Server.

    Die anderen Plugins hatte ich testweise deaktiviert, um zu prüfen, ob es daran liegt. Auch das änderte nichts.

    Ich schaue gleich noch mal, ob ich irgendetwas in den Einstellungen des Plugins finden kann.

    Falls jemand in der Zwischenzeit einen weiteren Tipp hat, gern. :smile:
     
  5. wirt

    wirt Well-Known Member

    Registriert seit:
    10. Oktober 2010
    Beiträge:
    63
    Zustimmungen:
    0
    Ich habe gerade festgestellt, dass beim Dropdown-Menü ("Tag generieren") überalle "undefined" steht. Normalerweise sind hier die unterschiedlichen Feldertypen (E-Mail-Adresse, Textfeld etc.) aufgelistet. An diesen Beitrag habe ich mal einen Screenshot davon angehängt.

    Kann das die Ursache sein? :confused:
     
  6. bgeissler

    bgeissler Well-Known Member

    Registriert seit:
    6. August 2006
    Beiträge:
    4.404
    Zustimmungen:
    0
    Welches plugin ist denn auf deinem sreenshot zu aktualisieren?
     
  7. wirt

    wirt Well-Known Member

    Registriert seit:
    10. Oktober 2010
    Beiträge:
    63
    Zustimmungen:
    0
    Das war Akismet. Auch nach erfolgter Aktualisierung tut sich nichts.
     
  8. infected

    infected Well-Known Member

    Registriert seit:
    9. Juli 2006
    Beiträge:
    9.816
    Zustimmungen:
    1
    Ja Moment... Du nutzt nicht die aktuellste WordPress Version, ansonsten gäbe es oben keinen Hinweis, dass eine neue WordPress Version verfügbar ist. Welche ist denn bei Dir im Einsatz?

    CF7 dürfte dann ja die aktuellste Version sein, wenn es nicht als Aktualisierung vorgeschlagen wird.
     
  9. wirt

    wirt Well-Known Member

    Registriert seit:
    10. Oktober 2010
    Beiträge:
    63
    Zustimmungen:
    0
    Blog, bei dem E-Mails nach Absenden des Formulars ankommen: Wordpress 3.1.3

    Blog, bei dem keine E-Mails nach Absenden des Formulars ankommen: Wordpress 3.2

    Ich hatte WP vor einiger Zeit aktualisiert, aber danach funktionierte die gesamte Seite nicht mehr, daher habe ich mein Back up mit der älteren Version wieder hochgeladen und seitdem Abstand von automatischen WP-Aktualisierungen genommen.

    Ja, bei CF7 habe ich keine Aktualisierung ausstehen, ist also up to date. :)
     
  10. infected

    infected Well-Known Member

    Registriert seit:
    9. Juli 2006
    Beiträge:
    9.816
    Zustimmungen:
    1
    Vielleicht steht das in irgendeinem Zusammenhang... CF7 benötigt in der aktuellen Version mind. WP 3.2

    Aber wie bereits schon vor mehreren Beiträgen gesagt: Wende Dich mal an Deinen Hoster, dass dieser die Maillogs überprüft, warum die Mails nicht zugestellt werden.

    Ich kann Dir auch anbieten, da mal reinzuschauen, aber dazu bräuchte ich dann einen Account mit den nötigen Berechtigungen. Wenn Du das möchtest, dann schick mir die entsprechenden Zugangsdaten per PN. Nicht hier öffentlich posten.
     
  11. infected

    infected Well-Known Member

    Registriert seit:
    9. Juli 2006
    Beiträge:
    9.816
    Zustimmungen:
    1
    Habe Zugangsdaten erhalten. Es liegt jedenfalls nicht an WP oder am Server. Test über phpmail() und SMTP Mail war erfolgreich. E-Mails gehen raus. Hier liegt das Problem scheinbar am Plugin selbst. Komplett deinstallieren (inkl. Datenbankeinträge) und dann nochmal neu installieren. Vielleicht hilft´s.
     
  12. wirt

    wirt Well-Known Member

    Registriert seit:
    10. Oktober 2010
    Beiträge:
    63
    Zustimmungen:
    0
    Nachdem ich WP komplett neu aufgesetzt und das CF7 neu installiert habe, werden die Formulare nun korrekt dargestellt und auch die E-Mails kommen wie gewünscht an. Hallelujah! :p

    Besten Dank für Euren Support!!!

    Ich bechäftige mich jetzt mit der Datenbank-Erweiterung von CF 7. Kann ich dort unter "Datenbank" die Reihenfolge der Spalten anpassen bzw. manche Spalten, die ich nicht benötige auch entfernen?
     
  13. Johannes86

    Johannes86 Member

    Registriert seit:
    9. Dezember 2013
    Beiträge:
    12
    Zustimmungen:
    0
    Hi,

    ich brauche ganz dringend schnell eure Hilfe.
    Ich habe gestern für ein Projekt Wordpress auf die aktuelle Version geupdated.
    Dann habe ich gestern Contact Form 7 installiert und alles eingerichtet.
    Ein Punkt warum ich Contact Form 7 gewählt habe war die Option durch das Contact Form 7 Data Base Plugin, die mögllichkeit die Daten in einer Datenbank abzulegen und zu exportieren.

    Nun mein Problem ist nachdem ich eben CFDB Plugin installiert hatte und die Einstelungen überprüft hatte, sagt mir das Plugin die Fehlermeldung:
    "Keine Kontaktformular oder ähnliches in der Datenbank"

    In den Optionen von CFDB ist natürlich die Einstelung für
    "Formulardaten von Contact Form 7 Plugin speichern" auf "Ja" gesetzt.

    Ganz kurz gesagt es findet einfach nicht das Kontaktformular!!

    Ich habe die CF7 Version 3.5.4
    und CFDB Version 2.6.3

    Wird die neue CF7 Version nicht unterstützt von CFDB???

    Es ist noch ein anderes Kontaktformular installiert und aktiviert SimpleContact Version v1.2.2
    Kommen die sich irgendwie in die "Querre" sprich soll ich es deaktiveren deinstallieren?
    Vielen Dank im Vorraus

    Gruß
     
    #33 Johannes86, 11. Dezember 2013
    Zuletzt bearbeitet: 11. Dezember 2013
  14. Johannes86

    Johannes86 Member

    Registriert seit:
    9. Dezember 2013
    Beiträge:
    12
    Zustimmungen:
    0
    Wenn ich Contact Form DB nach dem installieren aktiviere kommt oben in der Leiste im Backend folgende Nachricht:

    --------------------------------
    Das Plugin verursachte eine Fehlermeldung 744 Zeichen unerwartete Ausgabe während der Aktivierung. Sollte du Fehlermeldungen wie “headers already sent”, Probleme mit der Syndizierung der Feeds oder andere Fehler erhalten, versuche das Plugin zu deaktivieren oder zu löschen.
     
  15. Johannes86

    Johannes86 Member

    Registriert seit:
    9. Dezember 2013
    Beiträge:
    12
    Zustimmungen:
    0
    Weis keiner Abhilfe? Wäre echt wichtig weil ich es für die Arbeit brauche!
     
  16. Johannes86

    Johannes86 Member

    Registriert seit:
    9. Dezember 2013
    Beiträge:
    12
    Zustimmungen:
    0
    Keiner der mir helfen kann?
    Mist und es wäre so wichtig!
     
  17. Johannes86

    Johannes86 Member

    Registriert seit:
    9. Dezember 2013
    Beiträge:
    12
    Zustimmungen:
    0
    Morgen,

    aus irgend einem Grund findet nun CFDB alle Formulare, keine Ahnung was der Grund ist.
    Naja jetzt bin ich happy :)
     
  18. Johannes86

    Johannes86 Member

    Registriert seit:
    9. Dezember 2013
    Beiträge:
    12
    Zustimmungen:
    0
    Hallo,

    zu den obigen Beiträgen...nun ja.. ich hab mich viel informiert aber den Text auf der Plugin Seite vom Entwickler habe ich garnicht zuerst gefunden. Nun ist das zum Glück geklärt. Also CFDB zeigt "nur" Formulare mit Datenbankinhalt.

    Nun habe ich noch 2 Fragen/Anliegen:
    Weis jemand wie ich den Inhalt bzw. Formatierung mit dem Header "Submitted" verändern kann?
    Momentan sieht er so aus:
    2013-12-11 13:37:01 +01:00

    Soll aber so aussehen: 11-12-2013 13:37 also deutsche Schreibweise.

    Evtl. in den Einstellungen von CFDB unter "Datums- und Zeitformat"? Aber ich kann zu meinem bedauern kein PHP.

    Und wie ich einstellen kann mit shortcode, dass die Daten mit dem Header "Submitted From" garnicht erst exportiert oder gespeichert werden? Und somit garnicht in Excel zu sehen sind? Der Header soll auch gelöscht werden. [TABLE="width: 115"]
    [TR]
    [TD="class: xl22, width: 115"][/TD]
    [/TR]
    [/TABLE]
     
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden